This forum uses cookies. Click X button to hide this message. What is stored? 
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

delete file on USB disk fail
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Total Commander Forum Index -> Bug reports from previous betas (unresolved) Printable version
View previous topic :: View next topic  
Author Message
petermad
Power Member
Power Member


Joined: 05 Feb 2003
Posts: 7323
Location: Valsted, Denmark

PostPosted: Sun Mar 07, 2010 12:58 pm    Post subject: Reply with quote

2karlchen

My bad - for some reason I have got the idea that warem was writing about a USB stick, but now I see that it is a USB disk. Embarassed

I will test his ini file with a USB-disk then.

CopyCompatUsbSticks=1 is default as you say, but when you set default via the UI, this parameter is simply removed from wincmd.ini - when you disable "USB stick" via the UI then CopyCompatUsbSticks=0 is set in the ini file.

Quote:
CopyCompatUsbSticks affect USB harddisks as well

I don't think so.

EDIT:
I have now tested in a real USB disk with warem's ini file and the file mask set to >* in both panels - and I still cannot reproduce the bug.

I notice that warem has set TC to delete to Recycle bin. Personally I never uses Recycle bin and have it disabled on system level (and in TC). But maybe there is a problem with accessing the Recycle bin on warem's USB disk? So I suggest that he tries to delete with Shift+F8, to see if TC is then able to delete from that disk.
_________________
#524
Danish Total Commander Translator
TC 9.10b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit. TC 2.81b8 on Android 6.0

Get Extended Total Commander Menus
Back to top
View user's profile Send private message Send e-mail Visit poster's website
warem
Junior Member
Junior Member


Joined: 05 Mar 2010
Posts: 21

PostPosted: Sun Mar 07, 2010 9:38 pm    Post subject: Reply with quote

2petermad,

i am sorry that i made you confused. when i used the word "usb disk", i actually used a memory stick(only 128M). but this problem also comes up when i use a usb disk(80G).

F8/del deletes to Recycle bin. Shift+F8/Shift+del deletes directly.
i have already tried F8/del and Shift+F8/Shift+del. all failed.

2karlchen,

i tried following methods, all failed.

==>
CopyDefaultMethod=1

==>
CopyDefaultMethod=0 with CopyCompatDrives=FG

==>
CopyDefaultMethod=0 without CopyCompatDrives=FG

no matter if CopyCompatUsbSticks is set or not, all above methods failed.

let me summary some points for your reference:

==>
setting userspec=>*, it works in 7.04 but fails in 7.5a. any difference bwteen this two versions for this point?

==>
setting userspec=*, it works in 7.5a. can this indicate something?

==>
using Explorer to delete files in usb stick has no problem.

thank petermad and karlchen.
Back to top
View user's profile Send private message
petermad
Power Member
Power Member


Joined: 05 Feb 2003
Posts: 7323
Location: Valsted, Denmark

PostPosted: Mon Mar 08, 2010 4:35 am    Post subject: Reply with quote

Quote:
setting userspec=>*, it works in 7.04 but fails in 7.5a. any difference bwteen this two versions for this point?

Not to my knowledge - and it really shouldn't make any difference >* is just a saved * mask.

How about *.* - can you delete files with that mask? And if so - if you save it, can you then delete with >*.*

Also, if you save >* with another name like Allfiles kan you then delete with >Allfiles ?
_________________
#524
Danish Total Commander Translator
TC 9.10b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit. TC 2.81b8 on Android 6.0

Get Extended Total Commander Menus
Back to top
View user's profile Send private message Send e-mail Visit poster's website
warem
Junior Member
Junior Member


Joined: 05 Mar 2010
Posts: 21

PostPosted: Mon Mar 08, 2010 6:19 am    Post subject: Reply with quote

i set *.*_SearchFor=*.*, then set userspec=>*.*. then everything is ok. i can delete files on usb stick.

so what does it mean? what is the difference of `>*' and `*.*'?

thank petermad.
Back to top
View user's profile Send private message
petermad
Power Member
Power Member


Joined: 05 Feb 2003
Posts: 7323
Location: Valsted, Denmark

PostPosted: Mon Mar 08, 2010 10:17 am    Post subject: Reply with quote

Quote:
so what does it mean? what is the difference of `>*' and `*.*'?

There shouldn't be any - and both works the same here by me.

What happens if you press F12, write a * in the input field and press Enter - can you delet the usb files with that mask?

BTW - I cannot understand why you have a saved mask for * (>*) - If you want all files listed, just press Ctrl+F10.

But it is still an interesting problem/bug you found - it would be nice fo figure out what the prerequisite to reproduce it is - so far, you seem to be the only one with the problem.
_________________
#524
Danish Total Commander Translator
TC 9.10b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit. TC 2.81b8 on Android 6.0

Get Extended Total Commander Menus
Back to top
View user's profile Send private message Send e-mail Visit poster's website
warem
Junior Member
Junior Member


Joined: 05 Mar 2010
Posts: 21

PostPosted: Mon Mar 08, 2010 8:52 pm    Post subject: Reply with quote

i don't understand the action "What happens if you press F12, write a * in the input field and press Enter - can you delet the usb files with that mask?"

after pressing CTRL+F12, writing a * and then pressing Enter, there is no change in my wincmd.ini.

the reason why i have a saved mask >* is that i don't know the shortcut CTRL+F10. after only showing some specified files, i don't know how to restore to show all files. now i know it.

as to how to reproduce the problem, i don't know how to make it reproduce in your computer. in my computers(one is whinxp at home and the other is win vsta in office, the problem always comes up if i use the mask >*. when i first googled this forum, i really felt strange that no one had met this problem.

in the case of the moment, i don't know how to go on this problem. but i found a solution at least with your help. so, thanks a lot.
Back to top
View user's profile Send private message
warem
Junior Member
Junior Member


Joined: 05 Mar 2010
Posts: 21

PostPosted: Mon Mar 08, 2010 9:33 pm    Post subject: Reply with quote

hi, petermad,

i just found it is very easy to reproduce the problem in my computer(windows vista) now.

first go to usb stick, then press CTRL+F12 and choose whatever mask. now TC is freezing and using 100% memory.

however,

first go to any folder which is not in usb stick, then press CTRL+F12 and choose whatever mask. it is ok of course. now changing to usb stick, it is ok now. but deleting something in case of whatever mask, TC is freezing and using 100% memory.

if it is in usb stick and if i want to delete something, first press CTRL+F10, then delete. it is ok.

in a word, if it is usb stick, i can't do any operation about mask, no matter it is showing something or deleting something.

it seemed that i am the only person to have this problem. really strange.
Back to top
View user's profile Send private message
petermad
Power Member
Power Member


Joined: 05 Feb 2003
Posts: 7323
Location: Valsted, Denmark

PostPosted: Tue Mar 09, 2010 5:51 am    Post subject: Reply with quote

Quote:
first go to usb stick, then press CTRL+F12 and choose whatever mask. now TC is freezing and using 100% memory.

Cannot confirm that here - but I am not using Vista though.

Quote:
it seemed that i am the only person to have this problem. really strange.

Yes indeed!
_________________
#524
Danish Total Commander Translator
TC 9.10b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit. TC 2.81b8 on Android 6.0

Get Extended Total Commander Menus
Back to top
View user's profile Send private message Send e-mail Visit poster's website
karlchen
Power Member
Power Member


Joined: 06 Feb 2003
Posts: 4505
Location: Germany

PostPosted: Tue Mar 09, 2010 3:18 pm    Post subject: Reply with quote

Quote:
first go to usb stick, then press CTRL+F12 and choose whatever mask. now TC is freezing and using 100% memory.

Cannot confirm so here, either - and I am using Vista.

Total Commander 7.50a
Vista Home Premium, 32bit
Intenso USB stick, 4 GB

Karl
Back to top
View user's profile Send private message Send e-mail
warem
Junior Member
Junior Member


Joined: 05 Mar 2010
Posts: 21

PostPosted: Tue Mar 09, 2010 7:48 pm    Post subject: Reply with quote

ok, let's finalize this topic. maybe it is due to hardware issue.

anyway, thank petermad and karlchen.
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 34715
Location: Switzerland

PostPosted: Tue Apr 06, 2010 10:05 am    Post subject: Reply with quote

I couldn't confirm this problem, but I fixed some others with that >* filter. Does the error still occur?
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> Bug reports from previous betas (unresolved) All times are GMT - 6 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Impressum: This site is maintained by Ghisler Software GmbH

Using phpBB © 2001-2005 phpBB Group