Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Synchronize Dirs - Suppress error messages HIDDEN,READONLY

 
Post new topic   Reply to topic    Total Commander Forum Index -> TC suggestions (English) Printable version
View previous topic :: View next topic  
Author Message
flexscan676
Junior Member
Junior Member


Joined: 13 Jul 2009
Posts: 6

PostPosted: Mon Feb 27, 2012 4:02 pm    Post subject: Synchronize Dirs - Suppress error messages HIDDEN,READONLY Reply with quote

Hi there, this is annoying me long time already.

I am synchronizing large volumes (2TB) and do this usually over night.
Only few things can be more annoying than checking the next morning, just to find a error message "File xxxxxxx is READ ONLY ! Delete anyway ?".

OF COURSE !
But the error popped up 30 minutes after start and there is still 8 hours to go....
Can you PLEASE add the selection here - before starting the Synchro - to "IGNORE ALL ERRORS" or "ANSWER ALL YES" ?

Would be such an improvment !

Regards
/flexscan676
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28269
Location: Switzerland

PostPosted: Tue Feb 28, 2012 3:35 am    Post subject: Reply with quote

Just click on the "Options" button in the F5 copy dialog, you can find these options there.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Samuel
Power Member
Power Member


Joined: 29 Aug 2003
Posts: 1650
Location: Brandenburg, Germany

PostPosted: Tue Feb 28, 2012 3:01 pm    Post subject: Reply with quote

But they do not affect Synchronize Dirs. (or am I missing something?)
Could you please configure Synchronize Dirs to behave the same way?
Would be a great improvement.
_________________
QuickSearch eXtended | ButtonBar eXtended | www.familie-plentz.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28269
Location: Switzerland

PostPosted: Wed Feb 29, 2012 2:15 am    Post subject: Reply with quote

You can turn off the questions for hidden/system and read only files in Configuration - Options - Misc. And you can check to overwrite all in the sync tool copy dialog.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Samuel
Power Member
Power Member


Joined: 29 Aug 2003
Posts: 1650
Location: Brandenburg, Germany

PostPosted: Wed Feb 29, 2012 3:18 pm    Post subject: Reply with quote

Thank you I got it working if I use:

1) Configuration > Misc. > uncheck confirmation for overwriting/deleting hidden/system and read only.
2) in Synchronize Dirs start copy progress
3) uncheck "confirm overwrites"
4) no messages appear when syncronizing

However there is a little bug in it: (TC 8.0▀21)
1) Configuration > Misc. > uncheck confirmation for overwriting/deleting hidden/system and read only.
2) in Synchronize Dirs start copy progress
3) keep "confirm overwrites" checked
4) at the first normal file that will be overwritten a popup will show up: "Overwrite file?" > choose "overwrite all"
5) further messages appear "overwrite hidden or system?"

Could you please fix it in upcoming betas?

Idea:
Perhaps you should add another filter-button: show only hidden/system/readonly files that would be overwritten.
_________________
QuickSearch eXtended | ButtonBar eXtended | www.familie-plentz.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Samuel
Power Member
Power Member


Joined: 29 Aug 2003
Posts: 1650
Location: Brandenburg, Germany

PostPosted: Wed Feb 29, 2012 3:24 pm    Post subject: Reply with quote

Could you move it to TC8 bugs, or should I create a new topic?
_________________
QuickSearch eXtended | ButtonBar eXtended | www.familie-plentz.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28269
Location: Switzerland

PostPosted: Wed Feb 29, 2012 4:12 pm    Post subject: Reply with quote

I don't think that it's a bug - if I remember correctly, I'm showing hidden/system warnings there because the sync tool shows them even if hidden/system files are disabled in the rest of the program.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Samuel
Power Member
Power Member


Joined: 29 Aug 2003
Posts: 1650
Location: Brandenburg, Germany

PostPosted: Thu Mar 01, 2012 6:20 am    Post subject: Reply with quote

ghisler(Author) wrote:
I don't think that it's a bug - if I remember correctly, I'm showing hidden/system warnings there because the sync tool shows them even if hidden/system files are disabled in the rest of the program.

Even if this is the case it is a bug, because the popups are not shown in the first case below. (in the second case they are shown)
Could you please use the "hidden/system warnings" in Synchronize Dirs too? (in both cases)

Otherwise I would ask you to add a new wincmd.ini option for it.
Please?

Samuel wrote:
Thank you I got it working if I use:

1) Configuration > Misc. > uncheck confirmation for overwriting/deleting hidden/system and read only.
2) in Synchronize Dirs start copy progress
3) uncheck "confirm overwrites"
4) no messages appear when syncronizing

However there is a little bug in it: (TC 8.0▀21)
1) Configuration > Misc. > uncheck confirmation for overwriting/deleting hidden/system and read only.
2) in Synchronize Dirs start copy progress
3) keep "confirm overwrites" checked
4) at the first normal file that will be overwritten a popup will show up: "Overwrite file?" > choose "overwrite all"
5) further messages appear "overwrite hidden or system?"

Could you please fix it in upcoming betas?

Idea:
Perhaps you should add another filter-button: show only hidden/system/readonly files that would be overwritten.

_________________
QuickSearch eXtended | ButtonBar eXtended | www.familie-plentz.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28269
Location: Switzerland

PostPosted: Thu Mar 01, 2012 9:39 am    Post subject: Reply with quote

Quote:
Even if this is the case it is a bug, because the popups are not shown in the first case below.

I don't understand - you unchecked the confirmation options, so why should they be shown if the user unchecks confirmations?
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Samuel
Power Member
Power Member


Joined: 29 Aug 2003
Posts: 1650
Location: Brandenburg, Germany

PostPosted: Thu Mar 01, 2012 12:59 pm    Post subject: Reply with quote

ghisler(Author) wrote:
Quote:
Even if this is the case it is a bug, because the popups are not shown in the first case below.

I don't understand - you unchecked the confirmation options, so why should they be shown if the user unchecks confirmations?

They are shown if I decide to show confirmations in Configuration:

1) Configuration > Misc. > keep confirmation for "overwriting/deleting hidden/system and read only" checked.
2) in Synchronize Dirs start copy progress
3) uncheck "confirm overwrites"
4) messages appear "overwrite hidden or system?"

1) Configuration > Misc. > uncheck confirmation for "overwriting/deleting hidden/system and read only".
2) in Synchronize Dirs start copy progress
3) uncheck "confirm overwrites"
4) no messages appear when syncronizing

IMO its inconsistent, because the Configurations are partly considered. I ask you to always follow the Configuration or to add a wincmd.ini switch.

What would be the advantage of not considering the Configuration in each case? Could you please clarify that?
_________________
QuickSearch eXtended | ButtonBar eXtended | www.familie-plentz.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28269
Location: Switzerland

PostPosted: Fri Mar 02, 2012 4:30 am    Post subject: Reply with quote

As I wrote, it's shown because hidden/system files are considered by sync even if you don't show them in the main program. But then there would be no way for unattended copying, so the checkbox "Confirm overwrites" works as a "catch all" option.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Samuel
Power Member
Power Member


Joined: 29 Aug 2003
Posts: 1650
Location: Brandenburg, Germany

PostPosted: Fri Mar 02, 2012 6:46 am    Post subject: Reply with quote

ghisler(Author) wrote:
As I wrote, it's shown because hidden/system files are considered by sync even if you don't show them in the main program. But then there would be no way for unattended copying, so the checkbox "Confirm overwrites" works as a "catch all" option.

I see, so each case is by design. Confused

I usually uncheck the checkbox "Confirm overwrites", but sometimes I forget about it. In this case this additional messages bug me.

Could you please add a wincmd.ini switch?
_________________
QuickSearch eXtended | ButtonBar eXtended | www.familie-plentz.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
flexscan676
Junior Member
Junior Member


Joined: 13 Jul 2009
Posts: 6

PostPosted: Fri Mar 02, 2012 6:01 pm    Post subject: Reply with quote

The "Confirm Overwrites" in the copy dialog does not cover "System/Hidden" files, and the related message - often long time after I start the "Synchronise" process - are the ones annoying me.
Of course I did uncheck that option for the regular files.

I want to be "in charge", so I want to be able to determine that I do not care about any possible System/Hidden files in the folder.
(those are usually some hidden thumbnail indexes and crap like that)

However, I was not aware of the optional checkboxes in "Configurations" - "Options".
How did I miss them. Maybe added by a newer version ?

Anyway, thank you for the feedback, TOTAL COMMANDER IS GREAT !
Just want to emphasize this again.
I love your software and the features.

/flexscan

ghisler(Author) wrote:
You can turn off the questions for hidden/system and read only files in Configuration - Options - Misc. And you can check to overwrite all in the sync tool copy dialog.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC suggestions (English) All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Impressum: This site is maintained by Ghisler Software GmbH

Using phpBB © 2001-2005 phpBB Group