This forum uses cookies. Click X button to hide this message. What is stored? 
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Wrong file icon

 
Post new topic   Reply to topic    Total Commander Forum Index -> TC9.0x bug reports (English) Printable version
View previous topic :: View next topic  
Author Message
JJJ
New Member
New Member


Joined: 13 Oct 2017
Posts: 1

PostPosted: Fri Oct 13, 2017 2:01 am    Post subject: Wrong file icon Reply with quote

Hi

I┤m using 9.0a -32bit on Win7-64, i5, 16gb, Samsung 850 ssd, uptime ~ 1h.

Just saw the typical setup-icon in front of an jpg file. There are 75 files in the folder, all different types. The two topmost are jpgs, the third a setup file with the typical 'disc in front of computer' icon.
This icon was also shown for the second jpg file. The first one had the correct jpg icon of xnview, that I use.
When I changed into a sub directory and came back, the icon was back to normal.

Some minutes later I copied another setup file with an individual Icon into the same folder. It took about 5 seconds to show the icon, allthough it was shown allready in the source folder (both on the same SSD drive but different partitions.)

I don┤t think I realised this behaviour in the past. Nothing serious, but weired.

Greetings
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 34726
Location: Switzerland

PostPosted: Fri Oct 13, 2017 4:02 am    Post subject: Reply with quote

You can thank virus scanners like Microsoft's built-in scanner for that 5 second delay: TC requests EXE icons from Windows in a background thread because of this.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC9.0x bug reports (English) All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Impressum: This site is maintained by Ghisler Software GmbH

Using phpBB © 2001-2005 phpBB Group