This forum uses cookies. Click X button to hide this message. What is stored? 
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

New beta plugin: WebDAV (WebFolders)
Goto page Previous  1, 2, 3 ... 17, 18, 19
 
Post new topic   Reply to topic    Total Commander Forum Index -> Plugins and addons: devel.+support (English) Printable version
View previous topic :: View next topic  
Author Message
godandag
New Member
New Member


Joined: 13 Oct 2017
Posts: 1

PostPosted: Fri Oct 13, 2017 6:15 am    Post subject: Reply with quote

Hello!

Don't know is it a bug or just specific webDAV server (MarkLogic) behavior, but i have a problem when openig a folder using plugin - it shows me the folder is empty, but i'm sure there are some files in there.

I have another webDAV client (oxygen) which shows files correctly.

I can see the difference in a webDAV server logs:
1) plugin sends "PROPFIND /delegation/us HTTP/1.1"
2) another client sends PROPFIND /delegation/us/ HTTP/1.1
- there is a / after us folder.

In my case under delegation folder i have both directory and file with the same name - us. Mat be this is the reason, because in general the plugin works fine.

Regards,
Dmitry
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 34726
Location: Switzerland

PostPosted: Sun Oct 15, 2017 12:45 am    Post subject: Reply with quote

There is a checkbox in the connection settings to alaways append a slash to directory names. Can you try this please?
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
yar229
New Member
New Member


Joined: 07 Nov 2017
Posts: 1

PostPosted: Tue Nov 07, 2017 8:00 pm    Post subject: WebDAV COPY/MOVE Reply with quote

2ghisler(Author)

Is there any chance to add full support for WebDAV COPY/MOVE operation?
For example, as a checkbox in connection properties?

At this time (plugin v.2.9) it's ok when copying one file, but when I try to copy folder plugin creates inner folders and than recusively uses WebDAV COPY for each file. My server copies inner content by itself.

That makes me cry when there's a lot of files and work doubles.

P.S. And the same for DELETE
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 34726
Location: Switzerland

PostPosted: Wed Nov 08, 2017 5:05 am    Post subject: Reply with quote

Interesting, I didn't know that there are servers where COPY command also works for folders. I will consider adding it when I can get it to work.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> Plugins and addons: devel.+support (English) All times are GMT - 6 Hours
Goto page Previous  1, 2, 3 ... 17, 18, 19
Page 19 of 19

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Impressum: This site is maintained by Ghisler Software GmbH

Using phpBB © 2001-2005 phpBB Group