Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

ftp port mode in Windows 7

 
Post new topic   Reply to topic    Total Commander Forum Index -> Bug reports from previous betas (unresolved) Printable version
View previous topic :: View next topic  
Author Message
Lefteous
Power Member
Power Member


Joined: 08 Feb 2003
Posts: 7943
Location: Germany

PostPosted: Fri May 01, 2009 12:04 pm    Post subject: ftp port mode in Windows 7 Reply with quote

I connected to a local ftp in TC hangs in both passive and port mode. Then I tried the Windows command utility is used port but asked me if I want to allow ftp.exe to execute the command. Why isn't this question asked when TC is performing a similar action?
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28637
Location: Switzerland

PostPosted: Sun May 03, 2009 8:39 am    Post subject: Reply with quote

Maybe it was already asked before and you declined, so TC is now on a block list? Please check in the firewall settings.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Lefteous
Power Member
Power Member


Joined: 08 Feb 2003
Posts: 7943
Location: Germany

PostPosted: Wed May 13, 2009 8:02 am    Post subject: Reply with quote

No nothing like that.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28637
Location: Switzerland

PostPosted: Wed May 13, 2009 2:43 pm    Post subject: Reply with quote

Well, like Vista, Windows 7 is blocking apps from being a server. In port mode, TC is the server on varying ports, while in passive mode, the ftp server itself is the server on varying ports. Maybe Microsoft have removed support for ftp? Then you can only use TC with passive mode, and cannot run any ftp server on Windows 7.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Lefteous
Power Member
Power Member


Joined: 08 Feb 2003
Posts: 7943
Location: Germany

PostPosted: Fri May 15, 2009 12:45 am    Post subject: Reply with quote

I think this is a permission problem. TC just doesn't try to elevate here.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28637
Location: Switzerland

PostPosted: Fri May 15, 2009 3:16 am    Post subject: Reply with quote

Elevation for FTP? That's insane! Why should TC do that? This wasn't needed on Vista either. To the contrary, programs like Internet Explorer work at a LOWER elevation level to reduce the risk of exploits from the net! Therefore I cannot immagine that Microsoft would require elevation for ftp.

But you can test that yourself: Just run TC via right click "as administrator" and check whether port mode works then...
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
roentgen
Power Member
Power Member


Joined: 03 Dec 2005
Posts: 759

PostPosted: Fri May 15, 2009 12:44 pm    Post subject: Reply with quote

It works for me

Quote:
CWD /
250 OK. Current directory is /
Connect ok!
PWD
257 "/" is your current location
Get directory
TYPE A
200 TYPE is now ASCII
PORT 192,168,0,200,197,149
200 PORT command successful
LIST -la
150 Connecting to port 50581
Download


Windows 7 x64 build 7100, firewall disabled.
_________________
TC for Linux please!
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28637
Location: Switzerland

PostPosted: Sun May 17, 2009 6:05 am    Post subject: Reply with quote

2roentgen
Can you make it work also with enabled firewall? The problem seems to be caused by the Windows 7 firewall not asking the user for permission to allow server mode...
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
roentgen
Power Member
Power Member


Joined: 03 Dec 2005
Posts: 759

PostPosted: Sun May 17, 2009 6:32 am    Post subject: Reply with quote

I just enabled it and it asks. I said yes for both home and public networks and FTP works.
_________________
TC for Linux please!
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> Bug reports from previous betas (unresolved) All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Impressum: This site is maintained by Ghisler Software GmbH

Using phpBB © 2001-2005 phpBB Group