This forum uses cookies. Click X button to hide this message. What is stored? 
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

[9.0a] WM_USER+50 with 1005/1006/1007/1008 in thumb mode

 
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs Printable version
View previous topic :: View next topic  
Author Message
MVV
Power Member
Power Member


Joined: 03 Aug 2008
Posts: 7980
Location: Russian Federation

PostPosted: Tue Jan 17, 2017 9:46 am    Post subject: [9.0a] WM_USER+50 with 1005/1006/1007/1008 in thumb mode Reply with quote

When in thumbnail mode, TC returns wrong values on WM_USER+50 with wParam=1005/1006/1007/1008. Values for 1005/1006 (number of selected items) are always 0, values for 1007/1008 (index of current item) represent row index instead of focused item index.

When in normal mode, return values are OK.
_________________
TCFS2 + TCFS2Tools: Full-screen mode for TC etc (forum)
TOTALCMD.NET: AskParam, CopyTree, NTLinks, Sudo, VirtualPanel…
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35075
Location: Switzerland

PostPosted: Thu Jan 19, 2017 4:54 am    Post subject: Reply with quote

Indeed these values are currently only guaranteed while TC isn't minimized. I will check it, but it may not be possible while minimized.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
MVV
Power Member
Power Member


Joined: 03 Aug 2008
Posts: 7980
Location: Russian Federation

PostPosted: Thu Jan 19, 2017 5:16 am    Post subject: Reply with quote

TC is not minimized, I mean that in brief/full view modes return values are OK, but not in thumbnail view mode (Ctrl+Shift+F1).
_________________
TCFS2 + TCFS2Tools: Full-screen mode for TC etc (forum)
TOTALCMD.NET: AskParam, CopyTree, NTLinks, Sudo, VirtualPanel…
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35075
Location: Switzerland

PostPosted: Mon Jan 23, 2017 9:26 am    Post subject: Reply with quote

Ah, I see - I will check that.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35075
Location: Switzerland

PostPosted: Mon Oct 02, 2017 3:17 am    Post subject: Reply with quote

This should be fixed in TC 9.10 beta, please test it!
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
MVV
Power Member
Power Member


Joined: 03 Aug 2008
Posts: 7980
Location: Russian Federation

PostPosted: Tue Jan 09, 2018 1:18 am    Post subject: Reply with quote

Sorry for late reply, the problem is fixed. Thank you!
_________________
TCFS2 + TCFS2Tools: Full-screen mode for TC etc (forum)
TOTALCMD.NET: AskParam, CopyTree, NTLinks, Sudo, VirtualPanel…
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung

Using phpBB © 2001-2005 phpBB Group