cannot download files via FTP (special chars in filename)

Please report only one bug per message!

Moderators: sheep, Hacker, Stefan2, white

Post Reply
michael202
Junior Member
Junior Member
Posts: 3
Joined: 2010-03-31, 11:22 UTC

cannot download files via FTP (special chars in filename)

Post by *michael202 » 2010-03-31, 11:32 UTC

two (related ?) errors:

assume a file on an FTP Server is named
vierländereck.xml

a)
the file is displayed as
verl#ereck.xml
(where # is a small rectangular box that I have never seen
elsewhere: 㭤, 3b64)

b)
when trying to download this file, the commander gives me:
550 Failed to open file.

Seems like the display in TCMD is UTF-8, but the filename is cp1252 or 850.

Regards,
Michael

Sob
Power Member
Power Member
Posts: 908
Joined: 2005-01-19, 17:33 UTC

Post by *Sob » 2010-03-31, 15:48 UTC

If you go to connection properties, you can select the code page. Default is autodetection and UTF-8 is preferred.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37695
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2010-03-31, 16:02 UTC

Can you post the connection log here, please? You can get it by double clicking on the two line text in the ftp toolbar after connecting. It should show me why TC thinks that your server supports UTF-8.
Author of Total Commander
http://www.ghisler.com

michael202
Junior Member
Junior Member
Posts: 3
Joined: 2010-03-31, 11:22 UTC

Post by *michael202 » 2010-04-06, 12:38 UTC

Hello Chrstian,

the interessting part of the log might be:

...............
SYST
215 UNIX Type: L8
FEAT
211-Features:
EPRT
EPSV
MDTM
PASV
REST STREAM
SIZE
TVFS
UTF8
211 End
OPTS UTF8 ON
200 Always in UTF8 mode.
Connect ok!
...............



So perhaps the one who uploaded the files made the error in the first place ???


Regards,
Michael

PS:
great job so far, total commander makes working with files extremely efficient. I like the "RegExp-Multiple-Renamer" and the "Synchronise Dirs" funktions most :-)

michael202
Junior Member
Junior Member
Posts: 3
Joined: 2010-03-31, 11:22 UTC

Post by *michael202 » 2010-04-06, 12:44 UTC

Thanks a lot Sob !!

I did not know, there was such an option.

When I use "ANSI/Local" the Umlaut ä is displayed correctly and the
download works.

So I have to tell the admins to switch of the UTF-8 feature, because there are still some clients that cannot handle this ?

Smiling,
Michael

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37695
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2010-04-06, 15:16 UTC

You can try to send
OPTS UTF8 OFF
in TC, maybe the server allows to turn off UTF-8.
Author of Total Commander
http://www.ghisler.com

Post Reply