Date format

Please report only one bug per message!

Moderators: sheep, Hacker, Stefan2, white

Post Reply
wiki
New Member
New Member
Posts: 1
Joined: 2010-05-11, 07:32 UTC

Date format

Post by *wiki » 2010-05-11, 08:09 UTC

i have problem with date format in windows 7... see examples:

if i have default short date settings in windows regional dialog, is everything fine and date is in format: 5/20/2010


but, if i choose for example date format: Tue 5/20/2010
TC show date in format: 5 20 2010
- separator "/" disappear
- no day of week
- windows explorer show date format correctly

IMHO is problem in first used separator. if i use date in format 5/20/2010 Tue
TC show date in format 5/20/2010
- separator ok
- still no dat of week

User avatar
petermad
Power Member
Power Member
Posts: 8581
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad » 2010-05-11, 09:19 UTC

I can confirm this under Windows XP using one of these formats as the short date format:

DDD DD-MM-yyyy
DDDD DD-MM-yyyy
License #524 (1994)
Danish Total Commander Translator
TC 9.5b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1903) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37766
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2010-05-11, 20:06 UTC

Total Commander uses the Windows function GetLocaleInfo with the parameter LOCALE_SDATE to get the date separator.
http://msdn.microsoft.com/en-us/library/ms906223.aspx

It seems that Windows reports the first separator if you use this specific date format.
Author of Total Commander
http://www.ghisler.com

mhtcf
Junior Member
Junior Member
Posts: 14
Joined: 2007-01-21, 00:55 UTC
Location: Pennsylvania, USA

Same problem here

Post by *mhtcf » 2011-01-07, 16:57 UTC

Confirmed here as well. Running Windows 7 with Total Commander 7.56a, I see dates with blank as a separator. My system date format is "dddd M/d/yyyy".

My workaround is to set the date format to: dddd-M/d/yyyy but maybe we need an optional date format in wincmd.ini. (Personally, I may prefer to see file dates in yyyy-mm-dd format even through I like to see it in mm/dd/yyyy format elsewhere so a full date format would be nice instead of just a separator option).

FYI, The reason I changed the date format in Windows in the first place is so I could see the day name in the taskbar (works only if "use small icons" is not checked when the taskbar is single height). Finally I can stop using TclockEX with Windows 7..

-Michael

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37766
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2011-01-10, 14:49 UTC

Try using
M/d/yyyy dddd
instead. As described above, Windows reports the first separator to all programs.
Author of Total Commander
http://www.ghisler.com

kilimanjaro25
Junior Member
Junior Member
Posts: 3
Joined: 2014-04-07, 18:52 UTC

Post by *kilimanjaro25 » 2014-04-07, 18:58 UTC

Somebody please tell me where should I change date format, when using Total Commander under Ubuntu 12/Wine. I already tried this:
(wine settings)
~/.wine/drive_c/windows/win.ini
~/.wine/user.reg

(linux settings)
dconf-editor
gsettings set com.canonical.indicator.datetime custom-time-format "my settings"

But still no luck. ;(

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37766
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2014-04-08, 16:22 UTC

In totalcmd, run regedit.exe from the command line, then go to:
HKEY_CURRENT_USER\Control Panel\International

24 Hour Time Format
iTime=1
iTLZero=1
sTimeFormat=HH:mm:ss

12 hour am/pm time format:
sTimeFormat=h:mm:ss tt
iTime=0
iTLZero=0

For the date, use iDate, sDate, sShortDate, sLongDate.
Author of Total Commander
http://www.ghisler.com

kilimanjaro25
Junior Member
Junior Member
Posts: 3
Joined: 2014-04-07, 18:52 UTC

Post by *kilimanjaro25 » 2014-04-09, 14:35 UTC

Thanks for reply, but I already tried that. My current date format is:
Month/Day/Year, while I want:
Day/Month/Year (example: 21/07/2012)

Could you please check this registry and tell me what else should be changed?

Code: Select all

[HKEY_USERS\Control Panel\International]
"iCalendarType"="1"
"iCountry"="1"
"iCurrDigits"="2"
"iCurrency"="0"
"iDate"="0"
"iDigits"="2"
"iFirstDayOfWeek"="6"
"iFirstWeekOfYear"="0"
"iLDate"="0"
"iLZero"="1"
"iMeasure"="1"
"iNegCurr"="0"
"iNegNumber"="1"
"iPaperSize"="1"
"iTime"="0"
"iTimePrefix"="0"
"iTLZero"="0"
"LC_CTYPE"="00000409"
"LC_MEASUREMENT"="00000409"
"LC_MONETARY"="00000409"
"LC_NUMERIC"="00000409"
"LC_PAPER"="00000409"
"LC_TELEPHONE"="00000409"
"LC_TIME"="00000409"
"Locale"="00000409"
"Numshape"="1"
"s1159"="AM"
"s2359"="PM"
"sCountry"="United States"
"sCurrency"="$"
"sDate"="/"
"sDecimal"="."
"sGrouping"="3;0"
"sLanguage"="ENU"
"sList"=","
"sLongDate"="dddd, MMMM dd, yyyy"
"sMonDecimalSep"="."
"sMonGrouping"="3;0"
"sMonThousandSep"=","
"sNativeDigits"="0123456789"
"sNegativeSign"="-"
"sPositiveSign"=""
"sShortDate"="dd/MM/yyyy"
"sThousand"=","
"sTime"=":"
"sTimeFormat"="h:mm:ss tt"
"sYearMonth"="MMMM, yyyy"

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37766
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2014-04-09, 14:50 UTC

set iDate to "1":

0 = English mdy
1 = European dmy
2 = East Asian ymd
Author of Total Commander
http://www.ghisler.com

kilimanjaro25
Junior Member
Junior Member
Posts: 3
Joined: 2014-04-07, 18:52 UTC

Post by *kilimanjaro25 » 2014-04-14, 14:45 UTC

It's perfect now! Thanks again! ;)

Post Reply