TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Bug reports will be moved here when the described bug has been fixed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
HolgerK
Power Member
Power Member
Posts: 5158
Joined: 2006-01-26, 22:15 UTC
Location: Europe, Aachen

TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *HolgerK » 2019-11-10, 18:00 UTC

Dark mode theme is not applied to the horizontal scroll bars in "Set default Icon library" dialog (x86 only).

Same bug in "Change button bar" ("Change single button" and/or x64 is okay).

Regards
Holger
Make our planet great again

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38408
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *ghisler(Author) » 2019-11-11, 11:31 UTC

Not confirmed, works fine here. Which Windows version?
Author of Total Commander
http://www.ghisler.com

User avatar
HolgerK
Power Member
Power Member
Posts: 5158
Joined: 2006-01-26, 22:15 UTC
Location: Europe, Aachen

Re: TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *HolgerK » 2019-11-11, 13:22 UTC

The report from yesterday was @home with W10 pro x64 1903 single monitor setup, AMD GPU, AMD Ryzen 1700x.
It may also be caused by a huge background task, about 90% CPU load on all 16 logical processors.
But if i remember well, i could also reproduce this while the background task (handbrake.exe) was in pause mode.

It works fine @work (W10pro x64 1803 multi monitor setup, nVidia Quadro GPU, Intel Xeon.
Only observed flickering while moving the scroll bar with the mouse.
So yes, this seems to be not 100% reproducible.

I will try it again @home this evening (also with an default ini-file, and without background CPU-load).

Regards
Holger
Make our planet great again

User avatar
HolgerK
Power Member
Power Member
Posts: 5158
Joined: 2006-01-26, 22:15 UTC
Location: Europe, Aachen

Re: TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *HolgerK » 2019-11-11, 21:52 UTC

100% reproducible here with TC9.50Beta4 x86 (clean install extracted from cab), W10 x64 version 1903, fresh.ini and no background cpu load:
http://holgerk.drivehq.com//TC9.50Beta/IconListBoxScrollBars(TC9.50,beta4,x86).png
fresh.ini
Show

Code: Select all

[Configuration]
UseNewDefFont=1
SetEncoding=äö.do.not.remove
firstmnu=3066
FirstTime=0
FirstTimeIconLib=0
DarkMode=2
test=248
SeparateTree=0
PanelsVertical=0
[ButtonbarCache]
IconDll_default.bar=TCNewLib1
IconDll_vertical.bar=TCNewLib1
[Colors]
InverseCursor=0
ThemedCursor=1
InverseSelection=0
BackColor=-1
BackColor2=-1
ForeColor=-1
MarkColor=-1
CursorColor=-1
CursorText=-1
[left]
path=c:\
ViewMode=10001
activepanelcolor=-1
activepanelcolor2=-1
activepanelcolordark=-1
activepanelcolordark2=-1
ShowAllDetails=1
SpecialView=0
show=1
sortorder=0
negative Sortorder=0
[right]
path=c:\
ViewMode=10001
activepanelcolor=-1
activepanelcolor2=-1
activepanelcolordark=-1
activepanelcolordark2=-1
ShowAllDetails=1
SpecialView=0
show=1
sortorder=0
negative Sortorder=0
[FileSystemPlugins64]
$checksum$=3014672
[Buttonbar]
DefaultLib=wcmicon2
[RightHistory]
0=c:\	#0
[LeftHistory]
0=c:\	#0
Regards
Holger
Make our planet great again

User avatar
petermad
Power Member
Power Member
Posts: 8977
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *petermad » 2019-11-11, 22:39 UTC

I can confirm this with here with TC9.50Beta4 x86 - clean ini - under Windows 10 but not Windows 7
License #524 (1994)
Danish Total Commander Translator
TC 9.5b8 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38408
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *ghisler(Author) » 2019-11-12, 20:16 UTC

I can reproduce it now on Windows 10 1903 - that's very strange, here Windows itself should draw these scrollbars dark, as it does with the upper scrollbar in "Change button bar". I will try to find out what's different with the upper listbox.
Author of Total Commander
http://www.ghisler.com

User avatar
petermad
Power Member
Power Member
Posts: 8977
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *petermad » 2019-11-13, 23:17 UTC

This semms to be fixed in TC 9.5b5 :-)
License #524 (1994)
Danish Total Commander Translator
TC 9.5b8 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
HolgerK
Power Member
Power Member
Posts: 5158
Joined: 2006-01-26, 22:15 UTC
Location: Europe, Aachen

Re: TC9.50B4(x86) Dark mode: scroll bars in "Set default Icon library"

Post by *HolgerK » 2019-11-17, 19:58 UTC

Fixed with TC9.50B4 x86 (W10-1903)

Thanks
Holger
Make our planet great again

Post Reply