Deleting files when using Thumbnail view

The behaviour described in the bug report is either by design, or would be far too complex/time-consuming to be changed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
jtkno
Junior Member
Junior Member
Posts: 5
Joined: 2016-12-18, 14:41 UTC

Deleting files when using Thumbnail view

Post by *jtkno »

When i'm using thumbnail view I can't delete my files in TC anymore. Windows is saying that the file is open/in use and can there for not delete it.

OS: Windows 10 x64
TC: 9.0a x64
Last edited by jtkno on 2016-12-18, 17:25 UTC, edited 1 time in total.
User avatar
sqa_wizard
Power Member
Power Member
Posts: 3586
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard »

Are you running TC as administrator? (see here)
#5767 Personal license
jtkno
Junior Member
Junior Member
Posts: 5
Joined: 2016-12-18, 14:41 UTC

Post by *jtkno »

sqa_wizard wrote:Are you running TC as administrator?
Thanks for replying - I checked the settings now and I runs TC in normal mode. Tried to run TC as administrator to see if there was a different result, but it was not. :?
User avatar
sqa_wizard
Power Member
Power Member
Posts: 3586
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard »

Deletion of files is not possible, if it is in use by another program.

In case of thumbnails this could be:
1. your antivirus, which is currently scanning this file (because you access it for viewing).
=> try to delete it again after a while

2. your plugin to create the thumbnail
#5767 Personal license
jtkno
Junior Member
Junior Member
Posts: 5
Joined: 2016-12-18, 14:41 UTC

Post by *jtkno »

I disabled the antivirus for the test and it did not help.
Have also tested on another PC with the same result.
The thumbnail is visible and created.
Other tips?

(trying to add an attachment to but not allowed, who can approve this?)
User avatar
Horst.Epp
Power Member
Power Member
Posts: 3933
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Post by *Horst.Epp »

jtkno wrote:I disabled the antivirus for the test and it did not help.
Have also tested on another PC with the same result.
The thumbnail is visible and created.
Other tips?

(trying to add an attachment to but not allowed, who can approve this?)
You have to store your image on some public avilable host like your Google Drive, One Drice or Dropbox and provide the link.
Also you didn't say anything about the plugins you use to create the thumbs
as this may block the deletion.
Windows 10 Home x64 Version 20H2 (OS Build 19042.662)
TC 9.51 x64 / x86, Everything 1.4.1.1000 (x64)
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40083
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

You can try to switch to a different extraction method. There are some faulty Explorer extensions out there which don't close the file after extracting the thumbnail.
Author of Total Commander
http://www.ghisler.com
jtkno
Junior Member
Junior Member
Posts: 5
Joined: 2016-12-18, 14:41 UTC

Post by *jtkno »

When I tried to uncheck "Use Explorer method (OLE2) for (*.*| *.htm *.html)" under Configuration->Thumbnails it worked.

But then I don't see thumbnails for pictures anymore (JPG,PNG) :(
So then is better to use explorer or another program to view and delete pictures.
User avatar
sqa_wizard
Power Member
Power Member
Posts: 3586
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard »

When I tried to uncheck "Use Explorer method (OLE2) for (*.*| *.htm *.html)" under Configuration->Thumbnails it worked.
Obviously a faulty EXPLORER extension blocks your files.
Using explorer directly may block them also.

I have installed IrfanView and enabled Option Operation - Thumbnails "Get from Irfan-/Xnview for: *.*"
No problems so far ...
#5767 Personal license
jtkno
Junior Member
Junior Member
Posts: 5
Joined: 2016-12-18, 14:41 UTC

Post by *jtkno »

Installed IrfanView 4.42 x64 - and disabled "Use Explorer method" and enabled "Get from Irfan/xnview".
This is not working flawless..
In a folder with 24 pictures I see only 9 pictures with thumbnails. Rest is showing icons.
Tried to reinstall TC as well to see if that had an impact but unfortunately not.
https://www.dropbox.com/s/jidlu9dtvp4tmcu/2016-12-21_18-31-59.png?dl=0
https://www.dropbox.com/s/u7rtj7bqg2rrcqg/2016-12-21_18-34-06.png?dl=0
User avatar
petermad
Power Member
Power Member
Posts: 9910
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad »

2jtkno
Try and reload the thumbnails by selecting the files and the run the command cm_ReloadSelThumbs
License #524 (1994)
Danish Total Commander Translator
TC 9.51 32+64bit on Win XP 32bit & Win 7, 8.1 & 10 (2004) 64bit, 'Everything' 1.4.1.992 (x64)
TC 3.11 on Android 6.0
Get:
Extended TC Menus | TC Languagebar | TC Dark Help | PHSM-Calendar
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40083
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

Or select them, right click, and choose "Re-load selected thumbnails".
Author of Total Commander
http://www.ghisler.com
Korutz
Junior Member
Junior Member
Posts: 3
Joined: 2020-11-07, 15:44 UTC

Re: Deleting files when using Thumbnail view

Post by *Korutz »

I have the same problem - moving or deleting any file (with delete, context menu, F6 or F8) reloads all thumbnails in current view EVERY SINGLE TIME, it's very irritating. Changing folders reloads the thumbnails as well - is it using the cache at all? My Database Location is: C:\Users\opti\AppData\Local\GHISLER.

Thumbnails work only with option "Use Explorer method (OLE2)", otherwise images have only IrfanView icon instead thumbnail.
Post Reply