TGZ gepackt, Sonderzeichen gehen verloren

German support forum

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
Unused
Member
Member
Posts: 100
Joined: 2005-01-19, 20:26 UTC

TGZ gepackt, Sonderzeichen gehen verloren

Post by *Unused » 2019-01-22, 16:38 UTC

Hallo auch. Habe auf einem Rechner mit dem TotalCommander ein Verzeichnis in das *.tgz Format archiviert und wollte es auf einem anderen Rechner entpacken. Mehrere Dateinamen enthalten Umlaute und Sonderzeichen. Diese werden nicht korrekt dargestellt, wenn ich dieses *.tgz mit dem TotalCOmmander auf einem anderen PC entpacken möchte.

Was kann ich tun?

User avatar
prian
Junior Member
Junior Member
Posts: 59
Joined: 2008-08-28, 11:23 UTC
Location: Ingolstadt, Bavaria

Re: TGZ gepackt, Sonderzeichen gehen verloren

Post by *prian » 2019-01-23, 05:28 UTC

Hi,

soeben probiert auf meinem Rechner, Umlaute bleiben erhalten. (W10 64bit)
Auch noch auf einen W2008R2 Server kopiert und dort entpackt, auch keine Probleme.

Da meine Glaskugel verstaubt ist und Du sonst recht geizig mit Infos bist, deshalb diese Fragen:
- welche TC-Version?
- welche Betriebssystem (packen und entpacken)?
- tritt auf Rechner der packt auch auf?

Gruß
Robert
Intel Core I7-8700K, 32768 MB RAM, Asus ROG Maximus X Hero, Gainward RTX2080Ti Phoenix GS
Win10 Pro: Samsung 960 Pro 512GB (M.2), Crucial MX500 2000GB, WD40EFRX 4000GB, WD80EFZX 8000GB
OpenSuse TumbleWeed: Samsung 960 Evo 256GB (M.2), WD30EZRX 3000GB

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36788
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TGZ gepackt, Sonderzeichen gehen verloren

Post by *ghisler(Author) » 2019-01-24, 10:31 UTC

2Unused
Möglicherweise ist auf dem Zielrechner eine andere Zeichencodierung für nicht-Unicode-Programme eingestellt als auf dem Quellrechner, z.B. Kyrillisch und Deutsch. TC benutzt die Codierung für Dateinamen un tar-Dateien, weil da nicht explizit eine Codierung vorgegeben ist.
Author of Total Commander
http://www.ghisler.com

User avatar
Unused
Member
Member
Posts: 100
Joined: 2005-01-19, 20:26 UTC

Re: TGZ gepackt, Sonderzeichen gehen verloren

Post by *Unused » 2019-01-28, 08:58 UTC

Hallo Christian,

nein das passt dort alles. In der Zwischenzeit habe ich folgendes heraus gefunden. Wende ich TGZ auf ein Verzeichnis mit mehreren Dateien und Unterordnern an, und die Dateinamen enthalten Sonderzeichen, ensteht obiger Fehler.

Wende ich TAR an und packe das anschließend mit GZ, klappt es ohne Probleme. Eine wirkliche Erklärung habe ich keine für das Verhalten. Aktuell bin ich auf 7Zip ausgewichen. Das passt eigentlich immer. ZIP ist zumindest auf meinem Raspberry PI irre langsam. 7Zip, bz2 und tar.gz sind für den gleichen Content beim öffnen des Archivs um Längen schneller. Zumindest wenn ich diese in MidnightCommander öffne. Auf der Shell hingegen scheint es keine Unterschiede zu geben. Wie auch immer, 7Zip passt erstmal. Brauch ich auch nicht all zu oft.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36788
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TGZ gepackt, Sonderzeichen gehen verloren

Post by *ghisler(Author) » 2019-01-28, 14:38 UTC

Welche Sonderzeichen genau?
Author of Total Commander
http://www.ghisler.com

Post Reply