Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

German support forum

Moderators: sheep, Hacker, Stefan2, white

Post Reply
siegi2000
Junior Member
Junior Member
Posts: 17
Joined: 2013-07-22, 19:43 UTC

Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *siegi2000 »

Hallo liebe alle!
Ich verwende die Alt-F7-Suche um in mehreren Festplatten zu suchen.
Dafür trage ich in Suchen in ein: D:\;E:\;F:\.....usw.
Ich suche über 7 Festplatten. Die externen habe ich nicht immer angehängt, will ich auch nicht.
In der Version 9.22a bekomme ich nach jeder Suche die Meldung, dass bestimmte Suchpfade nicht gefunden wurden (jene Platten, die gerade nicht angehängt sind).
Diese Meldung mag zwar grundsätzlich sinnvoll sein, benötige ich aber nicht. Kann man diese Meldung irgendwie abschalten?
lg Siegi

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39812
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *ghisler(Author) »

Leider nein. Aber Sie können 2 verschiedene Knöpfe im Toolbar oder 2 Tastenkombinationen anlegen, welche die Suche einmal mit und einmal ohne externe Laufwerke aufrufen.

Dazu müssten Sie:
1. Die gewünschten Suchparameter unter Alt+F7 - Laden/Speichern jeweils abspeichern.
2. Je einen Button anlegen mit dem Befehl
LOADSEARCH gespeicherte Einstellungen 1
und
LOADSEARCH gespeicherte Einstellungen 2
Author of Total Commander
http://www.ghisler.com

siegi2000
Junior Member
Junior Member
Posts: 17
Joined: 2013-07-22, 19:43 UTC

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *siegi2000 »

Super, danke für den Tipp! lg Siegi

User avatar
vdijken
Member
Member
Posts: 123
Joined: 2016-07-30, 14:07 UTC
Location: The Netherlands

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *vdijken »

Wenn man such kan man auch die Festplatten wählen. TC sucht welche Festeplatten angehängt sind. Dann braucht man nicht selber die Buchstaber einführen.

rrmoch
Junior Member
Junior Member
Posts: 48
Joined: 2013-10-08, 19:49 UTC

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *rrmoch »

Ich hatte ein ähnliches Problem. Bei mir ist der MultiCardReader nicht als verschiedene Laufwerksbuchstaben sondern als verschiedene Verzeichnisse in einem leeren Verzeichnis "Media" eingebunden. also z.B. "Media\SM", "Media\SD". Hier käm auch immer die Meldung "Verzeichnis nicht gefunden"

Hier habe ich mit mit dem "USB Drive Letter Manager" von Uwe Siebert beholfen, der kann diese leeren Verzeichnisse auch ausblenden und es kommt nicht mehr zu dieser Fehlermeldung

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39812
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *ghisler(Author) »

Welcher Cardreader macht das? Hier gibt es einen Laufwerksbuchstaben pro Kartenslot.
Author of Total Commander
http://www.ghisler.com

rrmoch
Junior Member
Junior Member
Posts: 48
Joined: 2013-10-08, 19:49 UTC

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *rrmoch »

habe hier z.B. einen von Sony, würde normalerweise 4 Laufwerke belegen. Habe in der Datenträgerverwaltung die Laufwerksbuchstaben der einzelnen Slots gelöscht und in ein leeres NTFS Verzeichnis gelegt, dabei werden aber die Verzeichnisse angelegt und sind leer und kein Zugriff wie beim DVDRom Lw.

Habe dann in der Datenträgerverwaltung auch diese Verzeichnisse gelöscht und mit dem USB-Tool zugewiesen in der

usbdlm.ini:
[Settings]
DeleteMountPointsOnRemoval=1

[DriveLetters]
DeviceID=USBSTOR\DISK&VEN_SONY&PROD_CARD_R/W__-CF&REV_
Letter=E:\Media\CF

[DriveLetters]
DeviceID=USBSTOR\DISK&VEN_SONY&PROD_CARD_R/W__-SM/XD&REV_
Letter=E:\Media\SM

[DriveLetters]
DeviceID=USBSTOR\DISK&VEN_SONY&PROD_CARD_R/W__-SD&REV_
Letter=E:\Media\MS

[DriveLetters]
DeviceID=USBSTOR\DISK&VEN_SONY&PROD_CARD_R/W__-MS&REV_
Letter=E:\Media\SD

danach finde ich je nach eingelegter Karte ein Verzeichnis und nach dem Entfernen verschwindet das Verzeichnis wieder

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39812
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *ghisler(Author) »

Danke, ich werde das mal mit einem meiner Reader ausprobieren. Ich vermute, dass das Tool nicht genügend Rechte gesetzt hat - TC benötigt nicht nur das Recht, ein Verzeichnis zu lesen, sondern auch, dieses als aktuelles Verzeichnis zu setzen.

Ist es dieses Tool?
https://www.uwe-sieber.de/usbdlm.html
Author of Total Commander
http://www.ghisler.com

rrmoch
Junior Member
Junior Member
Posts: 48
Joined: 2013-10-08, 19:49 UTC

Re: Alt-F7-Suche: Fehlermeldung "Suchpfad nicht gefunden"

Post by *rrmoch »

ja das ist das Tool, wird als Dienst gestartet und verhindert auch z.B. Bad USB Devives, läuft wirklich problemlos. Starten mit "_service_register.cmd", die INI datei kann jederzeit angepasst werden. Diese wird beim erkennen eines neuen Device immer wieder eingelesen. Interessant dabei ist auch das zugehöroge Tool "USB Drive Info" das alle Infos zu den angeschlossenen Devices anzeigt

Post Reply