copy directory: recursivly because of type error

This forum contains bug reports from previous beta tests - the issue has remained unresolved, either because it couldn't be reproduced, or couldn't be prevented/fixed

Moderators: white, sheep, Hacker, Stefan2

Post Reply
User avatar
Francesco
Junior Member
Junior Member
Posts: 40
Joined: 2003-02-06, 11:58 UTC
Location: Austria, Upper Austria

copy directory: recursivly because of type error

Post by *Francesco » 2007-09-09, 08:29 UTC

I have seen something strange. I wanted to copy the current directory to another one (to make a backupt). The caps lock was on, so I typed instead of "71" "/!". Then recursivly directories were created again and again. For my luck, I could interrupt this process. the progress bar also showed some erronous values like 161% progress.
The bug I want to show: Why did a directory "/!" cause recursivly create the same directory on step deeper again and again?

Is that a bug at all?
Francesco

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36425
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-09-09, 08:56 UTC

The forward slash is interpreted like a backslash by Windows, but ignored by TC. Please don't use the forward slash in file names.
Author of Total Commander
http://www.ghisler.com

User avatar
Francesco
Junior Member
Junior Member
Posts: 40
Joined: 2003-02-06, 11:58 UTC
Location: Austria, Upper Austria

Post by *Francesco » 2007-09-09, 09:02 UTC

ghisler(Author) wrote:The forward slash is interpreted like a backslash by Windows, but ignored by TC. Please don't use the forward slash in file names.
I said, this was a unlucky typing error because caps lock was switched on.
Would it be an idea to warn a user by a message box, if letters like '/' were in file/directory names and such a thing could happen?
Francesco

Post Reply