TC 7.02a - Problem with downloading folder list

This forum contains bug reports from previous beta tests - the issue has remained unresolved, either because it couldn't be reproduced, or couldn't be prevented/fixed

Moderators: Stefan2, white, sheep, Hacker

Post Reply
Junior Member
Junior Member
Posts: 2
Joined: 2008-04-16, 10:05 UTC

TC 7.02a - Problem with downloading folder list

Post by *Thorin » 2008-04-16, 10:25 UTC


I am not too sure is it right place to report that, however I have problem with latest version of TC, What is happening, I am trying to connect to FTP server and it does connect, but foldder list is empty. I saw FAQ on this one, but it says to connect via passive mode or check the firewall.

We have a firewall (but connections going through) , no proxy, and as I mentioned connection is established.

This servers working fine for other applications, so I assume only, thats not a problem with servers.

Weird thing is that TC works fine for some of hosts, even those on same physical server, we have a few of them, some are showing list, other don't.

I am running out of ideas...We tried to connect to them with all possible options in Net --> FTP connections

does anyone had a simillar problem? Thanks in advance.


New Member
New Member
Posts: 1
Joined: 2008-04-16, 12:18 UTC

Post by *JJ_JM_RO » 2008-04-16, 12:43 UTC

Hi here RO,
I"m not the specialist in our company for these problem.
Later my colleagues will also give a reply.
We have the same problem the last weeks.
And it is Random! Active or Passive Mode make no difference
If you re-connect a few times, it works

We changed notting in our ftp server Gene6 and use TotalComander 7.02a longer as client before this problem.

It give the impression that the ftp server need more time to collect the info as reply after a "LIST" command.
TotalCommander come in a kind of TimeOut and try it by Passive mode,
but FTP server don't accept it in this sequence.
Result empty list.

I did a search in the TotalComander Helpfiles and info about the wcx_ftp.ini file. But didn't find any possibility to give a parameter so TotalComander wait longer after his command "LIST"

Anyway I have the impression something is changed between our ftp server and the Microsoft Server where he is running on.
Because it is the ftp server that use more time to give an answer to TotalCommander.

Possible some Microsoft updates??

I have a talk with my colleagues.


User avatar
Power Member
Power Member
Posts: 3455
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard » 2008-04-16, 13:13 UTC

2Thorin: you may try to disable hidden files display

Remove checkmark from menu item "Net - FTP Show Hidden files".

Reason: to show hidden files, the command "ls -a" is sent, which is disliked by some servers.
#5767 Personal license

Junior Member
Junior Member
Posts: 2
Joined: 2008-04-16, 10:05 UTC

Post by *Thorin » 2008-04-16, 13:33 UTC

@sqa_wizard it doesn't make a difference, witl -la or without, I tried almost all options...

@JJ_JM_RO Yeah, ask your colleagues :) I would appreciate that! However connection, disconnecting, reconnection, trying to download list again didn't help, not even one time! there is this option to list while u r on, but doesn't work either...

Thanks for response anyway! :) waiting for more ;)

I think I forgot to mention, if I'll type mkdir folder_name or try to do any action it works, I just can't see the folders (can see them under different apps, but people in my comapny can't work like that :P)

Ok seems my problem is solved now, I found out that client was sending requests in IPv6 format, this is blocked on routers here, however it's werid why it happen! I didn't mark any option for it...after we disabled IPv6 on the server it's flying. Odd, but real :)
Thanks for your help again lads.


Post Reply