Total Commander is accessing wrong drives (disks)

This forum contains bug reports from previous beta tests - the issue has remained unresolved, either because it couldn't be reproduced, or couldn't be prevented/fixed

Moderators: Stefan2, white, sheep, Hacker

Post Reply
alex27a
Junior Member
Junior Member
Posts: 3
Joined: 2008-10-11, 09:56 UTC

Total Commander is accessing wrong drives (disks)

Post by *alex27a » 2008-10-11, 10:21 UTC

Description: Total Commander is accessing wrong drives (disks). This causes the Total Commander it to be annonyingly slow when the user is using network mounted disks (which need to timeout if the network is disconnected) or when the user is using USB drives that go to sleep mode.

OS: Windows XP
Vesrion: 7.02, 7.04a
Reproducible: 5 of 5

Steps to reproduce:

1. mount a netowork shared directory as a drive (eg. s: is \\dataserver\test)
2. put c:\ in your left pannel
3. put c:\ in your right pannel
4. make sure that are no tabs that access s:\ drive
4. press alt-f7 (search)
5. press esc (exit from search)
BUG: after pressing esc total commander will hang waiting for the s:\ drive to respond. When it times out, total commander continues.

6. create a directory (by pressing F7) in one of the pannels (c:\test)
BUG: after creating the directory, total commander will hang waiting for the s:\ drive to respond. When it times out, total commander continues.

7. close total commander (alt-f4)
BUG: after creating the directory, total commander will hang waiting for the s:\ drive to respond. When it times out, total commander closes.

Another way to reproduce the issue is by using a USB drive that goes into sleep mode. As I can't debug total commander, this is an obvious way to show that it is accesing the usb drive when it shoud not because you can hear it when it spins up.

1. put c:\ in your left pannel
2. put c:\ in your right pannel
3. make sure that are no tabs that access usb drive
4. wait for the usb drive to go to into sleep mode
5. create a directory (by pressing F7) in one of the pannels (c:\test)

BUG: Total commander hangs and you can hear the USB drive spining up. When the USB drive has started, total commander continues.

User avatar
roentgen
Power Member
Power Member
Posts: 757
Joined: 2005-12-03, 19:58 UTC

Post by *roentgen » 2008-10-11, 11:23 UTC

I can't confirm. I work with mapped network drives over slow connections most of the time but I've never seen anything like this.

You should try to start TC with default settings. In TC install directory write the following in the command line:

Code: Select all

totalcmd.exe /i=test.ini
Aside, how does explorer behave?
TC for Linux please!

alex27a
Junior Member
Junior Member
Posts: 3
Joined: 2008-10-11, 09:56 UTC

Post by *alex27a » 2008-10-11, 11:44 UTC

I could not find a way to shut down the hdd quicker so I can dig into it more. However, here is another way to reproduce.

I have 3 usb hdd:

F: G: and I:

F is the one that automatically goes to sleep.

1. put g:\ in left pannel
2. put c:\ in your right pannel
3. make sure that are no tabs that access usb drive
4. wait for the usb drive to go to into sleep mode
5. delete a directory from c:\

Result: total commander starts the F: drive.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36557
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2008-10-13, 16:19 UTC

Do you use the separate tree? It shows icons for all drives, so TC has to access them to get the icon. Otherwise TC just calls the GetDriveType function for all drives when refreshing the drive list, but this shouldn't cause a drive to spin up. Maybe a virus scanner or other background tool is reading from the drive when TC calls getDriveType...
Author of Total Commander
http://www.ghisler.com

Post Reply