FTP unicode problem?

This forum contains bug reports from previous beta tests - the issue has remained unresolved, either because it couldn't be reproduced, or couldn't be prevented/fixed

Moderators: sheep, Hacker, Stefan2, white

User avatar
Rocky
Junior Member
Junior Member
Posts: 13
Joined: 2004-12-23, 07:52 UTC

FTP unicode problem?

Post by *Rocky » 2009-05-15, 12:25 UTC

I have a ftp folder named "使命召唤4中文完全安装版 - 使命召唤中文站", I can't access it with 7.5beta3, but 7.04a works fine.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38170
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-05-15, 16:25 UTC

I have just tried that with a local FTP server (RaidenFTPd):
1. Create dir "使命召唤4中文完全安装版 - 使命召唤中文站" locally
2. Copy file to it
3. Connect
4. Switch to dir
-> no problem

Does your ftp server support Unicode? You should be able to see this in the log, there should be a line like this:
OPTS UTF8 ON
220 UTF8 OPTS ON.

If not, try turning off UTF-8 manually via Ctrl+F - Edit connection.
Author of Total Commander
http://www.ghisler.com

User avatar
Rocky
Junior Member
Junior Member
Posts: 13
Joined: 2004-12-23, 07:52 UTC

Post by *Rocky » 2009-05-21, 08:41 UTC

thanks ghisler for reply, I checked the login log, there are line like you said
OPTS UTF8 ON
200 OK, UTF-8 enabled
but i still can't enter the folder, the error is "550 Can't change directory to 使命召唤4中文完全安装版 - 使命召唤中文站_: No such file or directory", then I change the encode option to ansi, I can access the folder :)

User avatar
Rocky
Junior Member
Junior Member
Posts: 13
Joined: 2004-12-23, 07:52 UTC

Post by *Rocky » 2009-05-21, 08:44 UTC

By the way, not all the folder contains Chinese characters couldn't be accessed, but only some, like the one above. it's amazing...

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38170
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-05-21, 15:19 UTC

Maybe the server software doesn't correctly support UTF-8? If you look at the error message which you posted, there is an underscore '_' behind the name.

Can you try to connect to the server with a local encoding instead of UTF-8?
Author of Total Commander
http://www.ghisler.com

User avatar
Rocky
Junior Member
Junior Member
Posts: 13
Joined: 2004-12-23, 07:52 UTC

Post by *Rocky » 2009-05-21, 15:54 UTC

Yes, there is an '_' behind the name.

With a local encoding, I can connect to the server and access the folder. Maybe it's a bug of the ftp server( I found it named Pure FtpD).

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38170
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-05-22, 15:30 UTC

Can you try to access the directory with some other ftp client, like FileZilla?
Author of Total Commander
http://www.ghisler.com

User avatar
Rocky
Junior Member
Junior Member
Posts: 13
Joined: 2004-12-23, 07:52 UTC

Post by *Rocky » 2009-05-26, 05:47 UTC

Dear ghilser, I tried FileZilla and FlashFXP, in FlashFXP site encoding settings, whether Force UTF-8 or auto-detect was set, it could connect to the site correctly, but in FileZilla settings, Force UTF-8 must be set to access the folder, otherwise it could see it, but could't access it.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38170
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-05-26, 15:42 UTC

Strange, you should be able to access the same directories in Total Commander as in FileZilla. I need more information from you:
1. A log file from Total Commander where you connect to the site and then change to the directory
2. The same log file from FileZilla
3. A raw directory listing where this directory appears in. You can create it by connecting with Total Commander. Then do NOT disconnect, but go to the TEMP dir with
cd %temp%
in the command line. The newest file ftp*.tmp should contain the listing with the Chinese name.

Please send me these 3 files zipped to beta at ghisler dot com.

Thanks for your help!
Author of Total Commander
http://www.ghisler.com

User avatar
gewone
Junior Member
Junior Member
Posts: 48
Joined: 2008-03-06, 17:37 UTC

Post by *gewone » 2009-09-12, 14:26 UTC

Not 100% sure where to put this (whether to start new thread/not) but since this subject seems indeed related I think that I'll just slip in here ;)

My issue. First off said, I'm using TC 7.04a (w/ Shanny's Embellished Edition theme, for that matter), and FTPD is latest FileZilla. I'm a novice when it comes to which charsets belong to which country. Anyhow, I'm from Sweden. So, I have this file on FTP for instance:

Börja gå - Bebisars utveckling.pdf

When I connect to my FTPD using TC (using default settings) I get the following filename:


Börja gå_ Bebisars utveckling.pdf

Something with the charset, right? I try connecting with FileZilla Client (also default settings), and the "åäö" characters shows up like they're supposed to.

After reading this thread, I tried pulling the cmd "OPTS UTF8 OFF" in TC when connected. Then (after CTRL+R reload), the "åäö" chars show up properly. However(!), when I try downloading one of these files, it fails.

Wait, now I tried again. It seems like the stunt worked out with file named above when it was close to rootdir. However, just a few digs down in the dirtree on sysdrive made it snap again.


I simply told to download:
ftps://localhost/Documents and Settings/Ingrid/Lokala inställningar/Application Data/PUTTY.RND, and it gave me a Thread download window box stating "Error downloading file!". I enabled logging and reproduced to see what would be in it. It came up with.. nada!

See enclosure:

CWD Application Data
250 CWD successful. "/Documents and Settings/Ingrid/Lokala inställningar/Application Data" is current directory.
Get directory
PASV
227 Entering Passive Mode (77,110,10,175,50,9)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK



How should I proceed? What could be the error?

Regards in adv~

User avatar
gewone
Junior Member
Junior Member
Posts: 48
Joined: 2008-03-06, 17:37 UTC

Interesting follow-up.

Post by *gewone » 2009-09-12, 14:40 UTC

I took this file as simple example:

ftps://localhost/Documents and Settings/Ingrid/Lokala inställningar/Temp/_tc0/License.txt

When I'm connected, and try drag-n-droping it to local target (eg. C:\ for simple example) I get the errorbox stated in prev. post. However(!), if I hit F3 (View) w/ the Licence.txt file targeted, the GNU license shows up correctly in internal viewer. No downloading though. Same issue goes w/ all files anyplace in dirtree below(!):

ftps://localhost/Documents and Settings/Ingrid/Lokala inställningar/Temp/_tc0/License.txt

Files above stated dir is downloading just fine. Hence presumably because of something to do with the "ä" in the dirname.
I'm no expert, so I don't have a solution, just stating my issue here! ;)

User avatar
Clo
Moderator
Moderator
Posts: 5731
Joined: 2003-12-02, 19:01 UTC
Location: Bordeaux, France
Contact:

Hexa coding

Post by *Clo » 2009-09-12, 16:09 UTC

2gewone

:) Hello !

• What does occur if you make the path like :
ftps://localhost/Documents%20and%20Settings/Ingrid/Lokala%20inst%E3llningar/Temp/_tc0/License.txt
:?:

:mrgreen: KR
Claude
Clo
#31505 Traducteur Français de TC French translator Aide en Français Tutoriels Français English Tutorials

Sob
Power Member
Power Member
Posts: 908
Joined: 2005-01-19, 17:33 UTC

Post by *Sob » 2009-09-13, 02:40 UTC

The first part is clear, "Börja ga" / "Börja gÃ¥" is the usual "utf-8 displayed as ansi" problem. Solved by turning utf8 off.

The rest is very strange. I was able to replicate something similar with "å" character and non-unicode locale set to czech (codepage windows-1250) where that character does not exist. But that way it was turned to plain "a" by server. It's not your case when you see it correctly.
If it really was charset issue and the "ä" character was the problem, you would not only have problems with downloading, but you wouldn't be able even to change into that directory. Also working viewing with F3 and non-working download sounds as nonsense, because F3 means downloading to temp directory and then showing the local file.
My only other thought is permissions problem. But as FileZilla normally runs under local system account, it again doesn't sound likely.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38170
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-09-13, 10:02 UTC

Can you try with Total Commander 7.50 instead of 7.04a? Don't forget to remove OPTS UTF8 OFF since TC 7.50 now supports UTF-8.
Author of Total Commander
http://www.ghisler.com

User avatar
gewone
Junior Member
Junior Member
Posts: 48
Joined: 2008-03-06, 17:37 UTC

Post by *gewone » 2009-09-15, 09:36 UTC

Sob wrote:Also working viewing with F3 and non-working download sounds as nonsense, because F3 means downloading to temp directory and then showing the local file.
Yeah, I know! That's whats bugging me too. However, just below I've stated some indeed interesting discoverys.

ghisler wrote:Can you try with Total Commander 7.50 instead of 7.04a? Don't forget to remove OPTS UTF8 OFF since TC 7.50 now supports UTF-8.
Just tried. Same goes with 7.5. I seem to have pin-pointed the issue now though. Check this out.

ftps://remoteip/Documents and Settings/Ingrid/Lokala inställningar/Temp/java_install_reg.log

When I press F3, the file pop up correctly in Viewer/Lister. However, when trying to download, it fails. I then tried unticking checkboxes in the download opts box. The problem seems to derive from "Download in background (sepereate thread)". When/if I untick that option, the file downloads properly. With the option checked (like I used to have as default for all file transfers), it fails.

Post Reply