Two bugs (?) with LAN plugin on x86 tablet

Support for Android version of Total Commander

Moderators: Stefan2, white, sheep, Hacker

Post Reply
tmsg
Junior Member
Junior Member
Posts: 7
Joined: 2019-04-14, 12:01 UTC

Two bugs (?) with LAN plugin on x86 tablet

Post by *tmsg » 2019-04-14, 12:19 UTC

First things first, TC is a great file manager for Android! I am no friend of these things in Windows/Linux where command line tools are king (well, for me at least :wink: ) but for Android TC is a real find!

I have two problems though, both in connection with the LAN plugin (TC v2.91/LAN v3.08) and both only on a Samsung x86 tablet (ie a Lenovo arm tablet works fine). The first problem is that I can copy from the LAN source to the external sdcard but not to any folder on the internal sdcard. So currently I first have to copy files to ext SD and then again to int SD.

Second tapping a filename on a LAN share (say an APK file) does open the dialog to download and open with (or edit) but upon tapping one of the options nothing happens (whereas on the Lenovo the APK is downloaded and installation starts).

EDIT: both tablets are rooted and TC has su access.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37363
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Two bugs (?) with LAN plugin on x86 tablet

Post by *ghisler(Author) » 2019-04-15, 13:34 UTC

Which Android version do you use? It's odd that you cannot write to /storage/emulated/0. Can you check in the Android settings - Apps whether the LAN plugin has the rights to write to internal storage?
Author of Total Commander
http://www.ghisler.com

tmsg
Junior Member
Junior Member
Posts: 7
Joined: 2019-04-14, 12:01 UTC

Re: Two bugs (?) with LAN plugin on x86 tablet

Post by *tmsg » 2019-04-15, 15:26 UTC

@ghisler: both tablets use Android 6.0.1. On the Lenovo (ie the one which works OK) it's the Android version that came with the tablet (though updated); on the Samsung it's LineageOS.

As to storage permissions that was the very first thing I checked, and yes, both the LAN plugin and TC itself have this enabled (I just double-checked). As stated copying from the LAN to the external SD does work and copying on to internal SD works as well.

EDIT: I have disabled and re-enabled this option a couple of times manually, doesn't make a difference.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37363
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Two bugs (?) with LAN plugin on x86 tablet

Post by *ghisler(Author) » 2019-04-18, 09:56 UTC

Sorry, I have no other ideas of what could be wrong. :(
Author of Total Commander
http://www.ghisler.com

tmsg
Junior Member
Junior Member
Posts: 7
Joined: 2019-04-14, 12:01 UTC

Re: Two bugs (?) with LAN plugin on x86 tablet

Post by *tmsg » 2019-04-20, 09:47 UTC

I have uninstalled, reinstalled and reconfigured the plugin on the Samsung tablet... and now it seems to work :o

Well, as Al Stewart was singing... "Maybe it's just one of those things."

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37363
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Two bugs (?) with LAN plugin on x86 tablet

Post by *ghisler(Author) » 2019-04-23, 13:31 UTC

Thanks for your feedback. So apparently the permissions got mixed up. Uninstalling an app removes all its permissions, so that must have fixed it.
Author of Total Commander
http://www.ghisler.com

Post Reply