TCMP: video playback may start in audio (playlist) mode after exit from player

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
DrShark
Power Member
Power Member
Posts: 1623
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *DrShark »

I can reproduce this sometimes on Android 5.1 device, but so far coudn't reproduce on Android 10 one.
To reproduce:
1. Select at least 1 video file (put a checkmark on its icon).
2. Execute a button with internal command 139 (Enquene selected).
3. Execute a button with internal command 137 (TC Media Player).
4. Tap on video file.
5. While it starts playing, close the player with red X button.
6. Repeat steps 2, 3, 4:
sometimes the video window almost immediately is covered by TC Media Player playlist and playback continues only in audio only mode.
If it is not reproduced on first try, repeat steps 2...5 few times.

The pause between the click on buttons 139 and 137 (mentioned here: https://ghisler.ch/board/viewtopic.php?f=22&t=72706) doesn't matter, and many files may be added in step 1, though at least one, on which we click in step 4, should be in video format, and it's convinient (but I don't think required) if it's the last one from all selected.
Android 4.3.1 no root, kernel 08.09.2016; Win7 Home Premium SP1 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39935
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *ghisler(Author) »

I couldn't reproduce this problem with beta 8 on Android 4.4.4 and 6.0.
1. Did you try with beta 8 or some older version? I ask because it may be related to the other problem you reported (TCMP: IllegalStateException...)
2. When the error happens, are there multiple entries in the play list, or just one? I ask because the player goes in a delayed close state when closing via "X" while there are multiple entries in the list.
Author of Total Commander
http://www.ghisler.com
User avatar
DrShark
Power Member
Power Member
Posts: 1623
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

Re: TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *DrShark »

ghisler(Author) wrote:
2020-09-06, 10:06 UTC
I couldn't reproduce this problem with beta 8 on Android 4.4.4 and 6.0.
1. Did you try with beta 8 or some older version? I ask because it may be related to the other problem you reported (TCMP: IllegalStateException...)
2. When the error happens, are there multiple entries in the play list, or just one? I ask because the player goes in a delayed close state when closing via "X" while there are multiple entries in the list.
Yes, I tried with beta 8. It happens either with single or with many files in playlist, I simplified reproduce case to single track then, but you can try with many files too. Originally I found all mentioned issues when expereminting with adding different files to queue with command 139 and closing the player window in different ways (e.g. with red X button and Android Back button). As I wrote in linked above thread about IllegalStateException, I encountered it only twice after update to beta 8, so it looks like under original conditions that bug is fixed - so far I couldn't find reliable conditions to make it appear again. So yes, in theory the issue mentioned here and IllegalStateException may be related (I guess under some conditions player may show IllegalStateException instead of putting the video just to background, which is also a bug, as described in start post), but I don't have a proof yet.
Android 4.3.1 no root, kernel 08.09.2016; Win7 Home Premium SP1 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39935
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *ghisler(Author) »

Unfortunately I couldn't reproduce it even after 10 tries. Can you give me more info about the video?
I tried with
1. Horizontal video, portrait mode
2. Horizontal video, landscape mode
3. Vertical video, portrait mode
4. Vertical video, landscape mode

I tried with 3gp and mp4 videos.
Author of Total Commander
http://www.ghisler.com
User avatar
DrShark
Power Member
Power Member
Posts: 1623
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

Re: TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *DrShark »

ghisler(Author) wrote:
2020-09-07, 09:25 UTC
Unfortunately I couldn't reproduce it even after 10 tries. Can you give me more info about the video?
[...]
I tried with 3gp and mp4 videos.
It seems it may really depend on file. I just sent by email (to your GMail account) 2 sample files: one in wmv (horizontal video; originally was shared here but now removed there) and one in mp4 format (vertical one).

The wmv file is only played by TC Media Player on my Android 5.1 device.
The mp4 file is played on Android 10 device too, and there instead of going to background after following the reproduce steps, sometimes it just stops after showing the first frame of the video.
On both devices it doesn't matter whether the player is in portrait or in horizontal orientation when to tap on the video track in queue playlist.

Another difference is that on Android 10 two taps on X button are required while the video is playing: after the first tap the "status bar" with Android Back/Home/Recent apps buttons appears. On Android 5 device the tap on X in such a case immediately closes the player.

BTW, Google Play here just updated the TC4A 3.10 beta 8 previously installed from apk (version build 590) to store version (build 593).
Are there any changes between builds 590 and 593 (except distribution methods)?
Android 4.3.1 no root, kernel 08.09.2016; Win7 Home Premium SP1 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39935
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *ghisler(Author) »

Thanks for the test videos, but I couldn't reproduce the problem on Android 4.4.4, 6 and 10. Does it only happen when you tap on 139 and 137 with very little delay (less than half a second)? If yes, then it could be related to your other report where there were more entries in the playlist. Btw, both videos play here on Android 6 and 10.
Another difference is that on Android 10 two taps on X button are required while the video is playing: after the first tap the "status bar" with Android Back/Home/Recent apps buttons appears. On Android 5 device the tap on X in such a case immediately closes the player.
Yes, normally tapping on the video should show both the 3 Android buttons and the player buttons. But the player starts up with just the player buttons, which causes this problem.
Are there any changes between builds 590 and 593 (except distribution methods)?
No, 590 is the Universal one containing the compiled C binaries for all processors, while 593 is the one for your specific processor (ARM64), so it's smaller.
Author of Total Commander
http://www.ghisler.com
User avatar
DrShark
Power Member
Power Member
Posts: 1623
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

Re: TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *DrShark »

The problem described in start post as "sometimes the video window almost immediately is covered by TC Media Player playlist and playback continues only in audio only mode", which happened on my Android 5.1 device, is fixed in TC4A 3.10 beta 9 (uncredited fix). Though Christian Ghisler couldn't reproduce it on own devices, some logging helped to understand what happens and to find a solution, explanation from email:
Christian Ghisler wrote:Immediately after receiving the onPrepared notification, the media player returns a video size of w=480, h=852. But shortly afterwards in the play loop, it returns a size of 0,0 in the first case, and w=480, h=852 in the second case. Apparently this is some kind of timing problem. I have now tried to save the size received in the onPrepared notification. So when the second onesies 0,0, I simply use the old size.
The problem with playback auto-stop just after showing only the first frame of video on Android 10 device is not related, and Christian Ghisler also cannot reproduce it, so currently it is not known whether it will be possible to fix it.

Also, beta 9 has another uncredited change: "Edit association" dialog in Internal associations now shows that toggle of "Command: Play (foreground)" changes the extension which is edited: real .ext, or virtual play:.ext. Separate virtual one is used only when "Command: Play (foreground") is enabled because the "Command:" field set there is used to define an app for "Play (foreground)" context menu item. This means real .ext and virtual play:.ext may coexist in a same Internal associations list.
ghisler(Author) wrote:
2020-09-07, 16:50 UTC
No, 590 is the Universal one containing the compiled C binaries for all processors, while 593 is the one for your specific processor (ARM64), so it's smaller.
Do you upload only processor-specific builds to Google Play? If yes, then it makes sense, when possible, to use higher build number for universal build, so if user already installed universal one, Google Play won't update it to process-specific. In case user have carrier/ISP's Internet data plan which requires to pay for some amount of downloaded data, user then will also save some money.
Android 4.3.1 no root, kernel 08.09.2016; Win7 Home Premium SP1 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39935
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TCMP: video playback may start in audio (playlist) mode after exit from player

Post by *ghisler(Author) »

Yes, I only put processor specific builds in the Play Store - this way the installation is considerably smaller.
Author of Total Commander
http://www.ghisler.com
Post Reply