"Copy NTFS permissions" on move default enabled

Please report only one bug per message!

Moderators: Stefan2, white, sheep, Hacker

Post Reply
s_a
Junior Member
Junior Member
Posts: 3
Joined: 2016-09-12, 11:17 UTC

"Copy NTFS permissions" on move default enabled

Post by *s_a » 2016-10-19, 14:17 UTC

Our file server is unix based, but accessible from Windows. Whenever I move a file into a directory without also copying the NTFS permissions, the result is that the moved file loses all access rights. I get "access denied, contact administrator" for Word files, as an example. If I was able to enable this switch by default it would be great.
Thank you.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37417
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2016-10-19, 21:13 UTC

This is a known bug of some Unix servers: They report file system type "NTFS" via SMB, but actual NTFS functions fail to work. When you move a file in TC from a directory with certain user rights to a directory with other user rights, TC sets the rights of the file to the rights of that directory. The idea is that when you move a file from user "A" to user "B", the file should afterwards be accessible by user "B".

You can disable this behaviour as follows:
Please add the following string to the file wincmd.ini, section [Configuration]:
XPMoveMethod=0

You can edit the wincmd.ini via Configuration - Change settings files directly.
Last edited by ghisler(Author) on 2016-11-07, 14:38 UTC, edited 1 time in total.
Author of Total Commander
http://www.ghisler.com

s_a
Junior Member
Junior Member
Posts: 3
Joined: 2016-09-12, 11:17 UTC

Post by *s_a » 2016-11-07, 12:50 UTC

Thank you!

Post Reply