Page 1 of 1

Bug - TC right click crash

Posted: 2018-06-28, 11:43 UTC
by grasii
TC 9.12 64 bit

Running TC in admin mode from a user account it crashes when I right click on any file or drive in the tool bar. I'm on Windows 10 1803.

Below there is some info about it from a dump analized with Windbg preview.

Symbol search path is: srv*
Executable search path is:
Windows 10 Version 17134 MP (4 procs) Free x64
Product: WinNt, suite: SingleUserTS
Machine Name:
Debug session time: Thu Jun 28 12:23:48.000 2018 (UTC + 1:00)
System Uptime: 0 days 20:37:15.879
Process Uptime: 0 days 0:06:36.000
Loading unloaded module list
This dump file has an exception of interest stored in it.
The stored exception information can be accessed via .ecxr.
(39b0.3c20): Security check failure or stack buffer overrun - code c0000409 (first/second chance not available)
00007ff8`fa790af0 cd29 int 29h


Posted: 2018-07-01, 07:03 UTC
by ghisler(Author)
Not confirmed, tried on Windows 10 Pro x64 Spring Creators Update (17134).

The problem you have is most probably a faulty shell extension.

To correct it, please try the following:
1. Get the free tool ShellExView:
2. Start it. If using Total Commander 32-bit (even on 64-bit Windows!), you need to get the 32-bit version, otherwise the 64-bit version of ShellExView. The 32-bit version needs to be called like this: shexview.exe /wow64
3. Sort the shell extensions by type
4. Disable all context menu shell extensions one by one (you can hide/keep those belonging to Windows, they are usually OK).
5. Continue until Total Commander stops crashing
6. Now you can re-enable the extensions which don't cause any problems

Posted: 2018-07-03, 07:52 UTC
by grasii
Hi ghisler,

I've done what you asked and it made no difference. I've disabled 3 extensions I have and TC would still crash. But what I've noticed is that this crashing behaviour is repeatable. It happens only on Win10 upgraded from 1709 to 1803 not freshly installed. I've tried it on 3 different upgraded machines and on all of them TC crashed. On a win10 cleanly installed TC would just work fine.
Forgot to mention I'm on Win10 1803 Ent.

Posted: 2018-07-03, 09:00 UTC
by ghisler(Author)
My Windows 10 x64 has also been upgraded from 1709 to 1803, no crash.

However, I'm using Windows 10 Pro, not Enterprise. Maybe that one contains additional context menu extensions from Microsoft causing the crash? Try disabling the Microsoft extensions too.

Posted: 2018-07-03, 09:49 UTC
by grasii
I found it! It's the "Pin to Start Screen verb handler". It crashes the TC whenever I right click on a folder/drive while TC started in admin mode. What's the solution now?


Posted: 2018-07-04, 14:03 UTC
by ghisler(Author)
Great, that thing doesn't even work within Total Commander.

All you can do is keep it disabled.

Posted: 2018-07-04, 14:32 UTC
by petermad
However, I'm using Windows 10 Pro, not Enterprise.
No problems here either with Windows 10 Home 1803 (build 17134.112)