Ctrl-C copy problems with Lister

Please report only one bug per message!

Moderators: Stefan2, white, sheep, Hacker

Post Reply
leonbloy
Junior Member
Junior Member
Posts: 15
Joined: 2009-06-22, 13:53 UTC

Ctrl-C copy problems with Lister

Post by *leonbloy » 2019-05-14, 20:54 UTC

I was trying to copy some selected text from a Lister window with Ctrl-C and it didn't work, in the Clipboard I got strange things like

Code: Select all

---------------------------
Reading directories: %3i  (Esc to abort)
---------------------------
func2 
---------------------------
OK   
---------------------------
or

Code: Select all

---------------------------
Search for selected text with Google
---------------------------
func2
---------------------------
OK   
---------------------------
or

Code: Select all

---------------------------
Not found:
---------------------------
ASDASDA
---------------------------
OK   
---------------------------
Copying from the menu->Edit->Copy as text worked, though. I was quite perplexed, until I discovered that I had left another Lister window
with an unclosed search popup window. That shouldn't mess other Listers operations, but it seems it does.

==============================
Steps to reproduce:

Open a Lister window on some file, search for some non-existant string, and whn the "Not found:" popup appears, don't close it.
Switch to TC, open another Lister windows on some other text file, select some text and copy it with Ctrl-C.
Paste to Notepad.
==============================

Experienced with 9.12 and latest 9.22a (64 bits)

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3307
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: Ctrl-C copy problems with Lister

Post by *Horst.Epp » 2019-05-15, 09:04 UTC

Not confirmed
Followed your steps and it works as it should be.
I guess you run some strange Clipboard tool.
Windows 10 Home x64 May 2019 Update, Version 1903 (OS Build 18362.116)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.22a x64 and x86, Everything 1.4.1.941 (x64)

User avatar
petermad
Power Member
Power Member
Posts: 8341
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: Ctrl-C copy problems with Lister

Post by *petermad » 2019-05-15, 10:41 UTC

I can confirm it here at work in TC 9.12 - I will test it in TC 9.22a when I come home.

If I right-click on the selected text in the second instance of Lister and select "Copy as text" it works as it is supposed to.
Last edited by petermad on 2019-05-15, 16:15 UTC, edited 2 times in total.
License #524 (1994)
Danish Total Commander Translator
TC 9.22a 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit, 'Everything' 1.4.1.935 (x64) and TC 3.0b3 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3307
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: Ctrl-C copy problems with Lister

Post by *Horst.Epp » 2019-05-15, 11:44 UTC

petermad wrote:
2019-05-15, 10:41 UTC
I can confirm it here at work in TC 9.12a - I will test it in TC 9.22a when I come home.

If I right-click on the selected test in the second instance of Lister and select "Copy as text" it works as it is supposed to.
For me it works with Ctrl-C and also using right click and "Copy as text"
Windows 10 Home x64 May 2019 Update, Version 1903 (OS Build 18362.116)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.22a x64 and x86, Everything 1.4.1.941 (x64)

User avatar
chandragor
Junior Member
Junior Member
Posts: 82
Joined: 2005-06-01, 10:10 UTC
Location: Italy

Re: Ctrl-C copy problems with Lister

Post by *chandragor » 2019-05-15, 12:35 UTC

Confirmed here too: TC 9.22a on Windows 7, both 32 and 64 bits.
Happy owner of license #12422 since 1997

User avatar
petermad
Power Member
Power Member
Posts: 8341
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: Ctrl-C copy problems with Lister

Post by *petermad » 2019-05-15, 16:07 UTC

I have now tested it in TC 9.22a 32bit and 64bit - and I can still confirm it.
Tested under Windows 7 and 10, and also tested with clean ini file.

BTW it is a duplicate of this: https://www.ghisler.ch/board/viewtopic.php?f=16&t=46189 - and cannot be solved according to Ghisler
License #524 (1994)
Danish Total Commander Translator
TC 9.22a 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit, 'Everything' 1.4.1.935 (x64) and TC 3.0b3 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3307
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: Ctrl-C copy problems with Lister

Post by *Horst.Epp » 2019-05-15, 17:18 UTC

petermad wrote:
2019-05-15, 16:07 UTC
I have now tested it in TC 9.22a 32bit and 64bit - and I can still confirm it.
Tested under Windows 7 and 10, and also tested with clean ini file.

BTW it is a duplicate of this: https://www.ghisler.ch/board/viewtopic.php?f=16&t=46189 - and cannot be solved according to Ghisler
I found why I couldn't reproduce it :o
I was testing using your Lister menu entry "Auto (No Plugins/Multimedia)
but this is using a seperate TC (cmd=%COMMANDER_EXE% /S=L:N).
Tested with a clean Ini file I can confirm the error to.
Windows 10 Home x64 May 2019 Update, Version 1903 (OS Build 18362.116)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.22a x64 and x86, Everything 1.4.1.941 (x64)

Post Reply