Page 1 of 1

[TC 9.21a] Quick view: window-buttons & help menu don't work

Posted: 2018-09-17, 05:30 UTC
by ikarus1969
Hi folks!

Today i stumbled across a small error in TotalCommander 9.21a / 64Bit.

If you place the selection on the ".." directory (it doesn't matter if you mark it), then press the "Strg-Q" for quick-view mode, the Help menu on the upper right and the window buttons (minimize, maximize, close) don't work/react on mouse-clicks.
Then, when leaving the quick-view mode by pressing "Strg-Q" again, the buttons and the help-menu are working again.

Can anyone confirm this behavior?

Re: [TC 9.21a] Quick view: window-buttons & help menu don't work

Posted: 2018-09-17, 08:38 UTC
by browny
Windows 10, 32-bit.
Everything was back to normal after all the information for Quick view was collected.

PS. Ctrl-Q in English.

Re: [TC 9.21a] Quick view: window-buttons & help menu don't work

Posted: 2018-09-17, 09:56 UTC
by ikarus1969
Thank you for your reply!

So, if i'm in a directory that's very large i have to wait a long time for "Quick-View" collecting everything it needs, right?
Ok, i can abort this collecting by pressing "ESC" but i find it strange that the windows-buttons and the help-menu don't react during this time (maybe other buttons and/or menus don't react too but i didn't test that).

Re: [TC 9.21a] Quick view: window-buttons & help menu don't work

Posted: 2019-11-28, 17:34 UTC
by DrShark
Is the reason of such behavior (if I understand it right from description above) that QuickView is started within main TC thread (and it is like that because the plugins, supported by QuickView, can't be started in background thread for security reasons, as explained in another thread: https://ghisler.ch/board/viewtopic.php?f=28&t=52470) and it means this is intentional?