Trouble with restricted file-type View

English support forum

Moderators: white, sheep, Hacker, Stefan2

Post Reply
llinfeng
Junior Member
Junior Member
Posts: 3
Joined: 2014-10-03, 02:18 UTC
Location: Ann Arbor

Trouble with restricted file-type View

Post by *llinfeng » 2018-09-26, 16:50 UTC

How can I get out from the attached awkwardness? I am not aware how I got into it, and I did not find any specification for, say, "PIF" in any of those *.ini files. Yet, across all my Total Commander installation on different machines, since I am sourcing all those setting-files through a Dropbox folder, they all show me this restricted view.

Image: http://llinfeng.github.io/Image/TC_View_Restriction_to_File_type.png (not sure why this image is not loaded into the page automatically).

Any help is much appreciated :) Also, if this restricted view is triggered by a menu item, I am interested to learn how to remove such menu item, or to disable its shortcut trigger.

Thanks a lot!

User avatar
tuska
Power Member
Power Member
Posts: 1259
Joined: 2007-05-21, 12:17 UTC

Re: Trouble with restricted file-type View

Post by *tuska » 2018-09-26, 17:06 UTC

A custom view is displayed in the image (menu "Show" - "Custom... Ctrl+F12").
Menu 'Help' - 'Keyboard wrote:CTRL+F12 Show user defined files
1. Press Ctrl+F12
2. type in: *.*
3. Press "OK"

This switches back to the normal view.

User avatar
sqa_wizard
Power Member
Power Member
Posts: 3386
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Re: Trouble with restricted file-type View

Post by *sqa_wizard » 2018-09-26, 17:07 UTC

The view is "Show Programs" by pressing Ctrl-F11 (to be exact)
Just press Ctrl-F10 to reset the view to "All files"
#5767 Personal license

llinfeng
Junior Member
Junior Member
Posts: 3
Joined: 2014-10-03, 02:18 UTC
Location: Ann Arbor

Re: Trouble with restricted file-type View

Post by *llinfeng » 2018-09-26, 17:19 UTC

Thank you guys, this is super helpful! The following menu items helped solved my problem:
Show ==> All Files

A follow up question: can I disable/delete the keyboard mapping for Ctrl-F11 (or Ctrl-F12)?

User avatar
tuska
Power Member
Power Member
Posts: 1259
Joined: 2007-05-21, 12:17 UTC

Re: Trouble with restricted file-type View

Post by *tuska » 2018-09-26, 17:34 UTC

llinfeng wrote:
2018-09-26, 17:19 UTC
A follow up question: can I disable/delete the keyboard mapping for Ctrl-F11 (or Ctrl-F12)?
No, but under "Configuration" - "Options..." - "Misc." - "Redefine hotkeys (Keyboard remapping)"
you can reassign the shortcuts - for other purposes.
In the field "Command:" simply click on the magnifying glass...

An assignment/reassignment of function keys is also very suitable for self-created em_commands.

EDIT:
In the file "WCMD_ENG.MNU" I would adjust the lines 104 and 106 accordingly.
It is best to make a copy of the file, because with every update/upgrade this file will be overwritten,
i.e. the adjustment should take place immediately after each update/upgrade.

llinfeng
Junior Member
Junior Member
Posts: 3
Joined: 2014-10-03, 02:18 UTC
Location: Ann Arbor

Re: Trouble with restricted file-type View

Post by *llinfeng » 2018-10-04, 20:17 UTC

Confirm that editing the WCMD_ENG.MNU file helped. More details goes as follows:

On my machine, this file is stored as "C:\Program Files\totalcmd\LANGUAGE\WCMD_ENG.MNU"

After the change, on line 104 ==> MENUITEM "&Programs", cm_srcexecs
After the change, on line 106 ==> MENUITEM "&Custom...", cm_srcuserdef

Post Reply