Search behaviour suddenly changed

English support forum

Moderators: Stefan2, white, sheep, Hacker

Post Reply
abolibibelot
Junior Member
Junior Member
Posts: 3
Joined: 2019-02-03, 01:05 UTC

Search behaviour suddenly changed

Post by *abolibibelot » 2019-02-03, 01:25 UTC

Hi,
The behaviour of the Search module suddenly changed tonight, I don't understand how and why, and found nothing relevant so far.
Before, when I typed a word or even a part of a word, it would find all files containing that word or string. For instance, with « wiki » it would find any file with a name containing “wiki” anywhere. Now if I type « wiki » I get these files :
1024px-Wikipedia_meme_vector_version.svg.png
Brian Wilson (album) - Wikipedia.htm
but not these files :
[avisynth.nl] External filters - Avisynth wiki.html
[en.wikipedia.org] Ad libitum - Wikipedia.html
If I type « *wiki* » I get all files with a name containing “wiki” (including those four), just like before when typing only « wiki ». But I don't even see a clear pattern here, since examples 2 and 4 above both contain “Wikipedia” just before the extension, yet one is found and not the other.
So what is the explanation, and how could I recover the former / default / normal behaviour ?
Thanks.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37170
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Search behaviour suddenly changed

Post by *ghisler(Author) » 2019-02-04, 14:57 UTC

Did you search for a word containing a dot, like TC9.21? If yes, TC will look for the exact match.
Author of Total Commander
http://www.ghisler.com

User avatar
Stefan2
Power Member
Power Member
Posts: 2395
Joined: 2007-09-13, 22:20 UTC
Location: Europa

Re: Search behaviour suddenly changed

Post by *Stefan2 » 2019-02-04, 15:33 UTC

2abolibibelot


A search for wiki still finds all four files for me (same as *wiki* do)

1024px-Wikipedia_meme_vector_version.svg.png
Brian Wilson (album) - Wikipedia.htm
[avisynth.nl] External filters - Avisynth wiki.html
[en.wikipedia.org] Ad libitum - Wikipedia.html





TC 9.21a 32bit


Maybe you have other settings set (depth, or Advanced or Plugins)?



 

abolibibelot
Junior Member
Junior Member
Posts: 3
Joined: 2019-02-03, 01:05 UTC

Re: Search behaviour suddenly changed

Post by *abolibibelot » 2019-02-13, 10:20 UTC

I really don't know what happened, later that day or the day after there was a system failure / BSOD (I've had many of these since I upgraded from a SATA SSD to a NVMe SSD, still haven't found the cause and the fix), and after the computer rebooted, T.C.'s search behaviour was back to normal. It may or may not be related to a series of “NTFS” warnings I found in the Event viewer (with a recommandation to run CHKDSK), concerning the HDD on which I ran those searches (but CHKDSK found no issue whatsoever, so again I really don't know what happened).
Thanks for the feedback anyway !

abolibibelot
Junior Member
Junior Member
Posts: 3
Joined: 2019-02-03, 01:05 UTC

Re: Search behaviour suddenly changed

Post by *abolibibelot » 2019-03-02, 15:09 UTC

I received a notification on 27 Feb. 2019 about a new reply to this thread by “html12345”, but I see no new message – perhaps it was a spam ?

Post Reply