[solved] How to show all files in current dir only (without subdirectories)?

English support forum

Moderators: sheep, Hacker, Stefan2, white

Post Reply
Jorge24
Junior Member
Junior Member
Posts: 11
Joined: 2016-11-06, 18:14 UTC
Location: USA

[solved] How to show all files in current dir only (without subdirectories)?

Post by *Jorge24 » 2019-11-07, 03:11 UTC

With the button that says "show all files in current dir and all subdirs" I can see files only. However, this includes all the subfolders. Is there a way to show only the files and not the folders of the current folder without all the subfolders?

What I want to do is be able to sort a folder's content by "date created" and have the files show at the top. Right now, the folders show at the top so I always have to scroll down before I can see the files.
Last edited by Jorge24 on 2019-11-09, 21:23 UTC, edited 1 time in total.

User avatar
petermad
Power Member
Power Member
Posts: 9002
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: How to show all files in current dir only (without subdirectories)?

Post by *petermad » 2019-11-07, 03:31 UTC

You can use this button to hide all folders:

Code: Select all

TOTALCMD#BAR#DATA
cd *|*\

wcmicons.dll,24
Hide All Folders (Show Only Files)


-1

And this button to show them again:

Code: Select all

TOTALCMD#BAR#DATA
cd *

wcmicons.dll,13
Hide All files and folders


-1
To make the button:
1. Mark the green text above (click SELECT ALL).
2. Copy it to the ClipBoard (press Ctri+C).
3. Right click on TC's buttonbar and choose "Paste".
License #524 (1994)
Danish Total Commander Translator
TC 9.5b9 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

Jorge24
Junior Member
Junior Member
Posts: 11
Joined: 2016-11-06, 18:14 UTC
Location: USA

Re: How to show all files in current dir only (without subdirectories)?

Post by *Jorge24 » 2019-11-07, 18:24 UTC

Thanks, that works for most folders but for some reason it doesn't work on the folders that I access from "This PC" such as Documents, Downloads, Pictures, Videos, etc

Download folder from "This PC"
Image: https://i.imgur.com/EI0nHgL.png


This PC:
Image: https://i.imgur.com/TSjWg4q.png

User avatar
Hacker
Moderator
Moderator
Posts: 11405
Joined: 2003-02-06, 14:56 UTC
Location: Bratislava, Slovakia

Re: How to show all files in current dir only (without subdirectories)?

Post by *Hacker » 2019-11-07, 20:11 UTC

Jorge24,
Well, those are not real folders, they are fake folders that do not really exist but Windows pretends they do. There are many limitations what TC can do in such fake folders. It seems this is one of them.

Roman
Mal angenommen, du drückst Strg+F, wählst die FTP-Verbindung (mit gespeichertem Passwort), klickst aber nicht auf Verbinden, sondern fällst tot um.

Jorge24
Junior Member
Junior Member
Posts: 11
Joined: 2016-11-06, 18:14 UTC
Location: USA

Re: How to show all files in current dir only (without subdirectories)?

Post by *Jorge24 » 2019-11-08, 05:43 UTC

I see, is there a way to set a keyboard shortcuts to trigger the custom buttons described above?

User avatar
Hacker
Moderator
Moderator
Posts: 11405
Joined: 2003-02-06, 14:56 UTC
Location: Bratislava, Slovakia

Re: How to show all files in current dir only (without subdirectories)?

Post by *Hacker » 2019-11-08, 09:28 UTC

Jorge24,
Configuration - Options - Misc - choose your desired hotkey - Click the magnifying glass symbol with the three dots - usercmd.ini - New - em_HideFolders

Code: Select all

Command: cd *|*\
OK your way out. Also click the green checkmark button next to the magnifying glass button.
Similar for em_ShowFolders, cd *.

HTH
Roman
Mal angenommen, du drückst Strg+F, wählst die FTP-Verbindung (mit gespeichertem Passwort), klickst aber nicht auf Verbinden, sondern fällst tot um.

Jorge24
Junior Member
Junior Member
Posts: 11
Joined: 2016-11-06, 18:14 UTC
Location: USA

Re: How to show all files in current dir only (without subdirectories)?

Post by *Jorge24 » 2019-11-09, 21:22 UTC

Got it working, thanks again!

Post Reply