Mapped Drives not shown but work after click on every one

English support forum

Moderators: sheep, Hacker, Stefan2, white

Post Reply
masterwishx
Junior Member
Junior Member
Posts: 5
Joined: 2020-06-05, 09:49 UTC

Mapped Drives not shown but work after click on every one

Post by *masterwishx »

I have some mapped drives and after reboot they shown as disabled with (redX) in my case with (?) becose i using exploer icons in setting.
in exploer drives enabled but in tc its enabling only after i click on them. in setting i have - do not remember A/
1. tryed remove A/ from autoboot in setting
2. tryed LoadDriveIconsInBackground=1 in ini file
but nothing help ,please help

User avatar
petermad
Power Member
Power Member
Posts: 9660
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: Mapped Drives not shown but work after click on every one

Post by *petermad »

in my case with (?) becose i using exploer icons in setting.
I don't see an ? for unloaded drives . I see an X: https://madsenworld.dk/tcmd/unloadeddriveicon.png - so maybe ? means something else...
License #524
Danish Total Commander Translator
TC 9.51 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.965 (x64)
TC 3.0 on Android 6.0
Get:
Extended Total Commander Menus | TC Languagebar | TC Dark Help | PHSM-Calendar

masterwishx
Junior Member
Junior Member
Posts: 5
Joined: 2020-06-05, 09:49 UTC

Re: Mapped Drives not shown but work after click on every one

Post by *masterwishx »

I have Hard Disk Sentinel icons in exploer so i have them in tc if i use option (show exploer icons) (?) if i disable this option then i have (red X)
but the question why its not automaticly does not enabled drives ?
and what A/ mean in option do not show drives ?

User avatar
petermad
Power Member
Power Member
Posts: 9660
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: Mapped Drives not shown but work after click on every one

Post by *petermad »

and what A/ mean in option do not show drives
Where do you see that option? Is it the: "Configuration" -> "Options..." -> "Refresh" -> "Do not remember these drives on exit" you are referring to? or are you referring to a Boot Manager setting?
Last edited by petermad on 2020-06-08, 01:03 UTC, edited 1 time in total.
License #524
Danish Total Commander Translator
TC 9.51 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.965 (x64)
TC 3.0 on Android 6.0
Get:
Extended Total Commander Menus | TC Languagebar | TC Dark Help | PHSM-Calendar

masterwishx
Junior Member
Junior Member
Posts: 5
Joined: 2020-06-05, 09:49 UTC

Re: Mapped Drives not shown but work after click on every one

Post by *masterwishx »

petermad wrote:
2020-06-06, 00:04 UTC
and what A/ mean in option do not show drives
Where do you see that option? Is it the: "Configuration" -> "Options..." -> "Refresh" -> "Do not remember these drives on exit" you are referring to? or are you reffering to a Boot Manager setting?
Yes Setting ->Autorefresh->dont remember,dont save on the begining of menu it was by default i think A/
i think its about plugin somethink ... but how to enable auto refresh or save my mapped drives , that i will dont need after reboot to click on them for enable in total commander ? in exploer they are enabled so the problem maybe in total commander setting....

User avatar
petermad
Power Member
Power Member
Posts: 9660
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: Mapped Drives not shown but work after click on every one

Post by *petermad »

If TC is started automatically on reboot, then maybe TC is started before the shares are loaded by Windows. Try closing TC and restart it, to see if the drive icons are then updated...
Last edited by petermad on 2020-06-08, 09:56 UTC, edited 1 time in total.
License #524
Danish Total Commander Translator
TC 9.51 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.965 (x64)
TC 3.0 on Android 6.0
Get:
Extended Total Commander Menus | TC Languagebar | TC Dark Help | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39712
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Mapped Drives not shown but work after click on every one

Post by *ghisler(Author) »

TC gets these drive icons from the system, it doesn't determine the status of the network drives by itself. Drives which have not beeen reconnected yet normally show a red "x" overlayed over the drive icon. I only get a "?" overlay for drive icons in the tab headers when the drive has been removed, e.g. unmounted USB drives.
Author of Total Commander
http://www.ghisler.com

masterwishx
Junior Member
Junior Member
Posts: 5
Joined: 2020-06-05, 09:49 UTC

Re: Mapped Drives not shown but work after click on every one

Post by *masterwishx »

petermad wrote:
2020-06-08, 01:13 UTC
If TC is started automatically on reboot, then maybe TC is started before the shares are loaded by Windows. Try closing TC and restart it, to see if the drive icons are then updated...
its manualy start and i think its after nas unraid booted already but i will check it
thanks

masterwishx
Junior Member
Junior Member
Posts: 5
Joined: 2020-06-05, 09:49 UTC

Re: Mapped Drives not shown but work after click on every one

Post by *masterwishx »

ghisler(Author) wrote:
2020-06-08, 09:24 UTC
TC gets these drive icons from the system, it doesn't determine the status of the network drives by itself. Drives which have not beeen reconnected yet normally show a red "x" overlayed over the drive icon. I only get a "?" overlay for drive icons in the tab headers when the drive has been removed, e.g. unmounted USB drives.
very strange becose even i have mapped disks enabled in exploer, they not enabled in TC after rebooted NAS unraid ,and my Computer only after i click on them....

in my case - I have Hard Disk Sentinel icons in exploer so i have them in TC too
if i use option (show exploer icons) then i have (?)
if i disable this option then i have (red X) like usual
but the question why its not automaticly does not enabled drives ?
and what A/ mean in option do not show drives in setting? like plugins drives ?

User avatar
petermad
Power Member
Power Member
Posts: 9660
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: Mapped Drives not shown but work after click on every one

Post by *petermad »

and what A/ mean in option do not show drives in setting? like plugins drives ?
It is explained in the configuration dialog:
Note: Use a backslash \ for network paths (UNC), / for file system plugins, and a colon : for virtual folders like the desktop.
License #524
Danish Total Commander Translator
TC 9.51 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.965 (x64)
TC 3.0 on Android 6.0
Get:
Extended Total Commander Menus | TC Languagebar | TC Dark Help | PHSM-Calendar

Post Reply