[WLX] MMedia 2.62 x32/x64 Unicode/ANSI (Sep 2014)

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

[WLX] MMedia 2.62 x32/x64 Unicode/ANSI (Sep 2014)

Post by *fg_2002fr » 2003-11-27, 13:49 UTC

latest x32 and x64 version of MMedia
see comments and download link here

==========================================

Hi all

You can download it here:
http://fg.tcplugins.free.fr/wlx_mmedia240.zip
Size: 42 KB

What's new or fix
2.40 - 26.11.2003
- Added : (need to be tested) jump automatically to the next file when many files were selected (TC 6.0+ only)
- Added : you can now choose separately your interface in QuickView mode and in lister mode (see readme.txt)
- Added : allow user to resize column in frame tab
- Added : add shortkey 'M' to mute
- Change detectstring according to final version of TC 6.0
- Fixed : move and resize some elements to better fit in small display
- Fixed : crash when changing volume with MediaPlayer 6.4+
- Fixed : change tab order in ID3tagV1
- Fixed : sometimes genre was not saved in ID3TagV1

see webpage at:
http://fg.tcplugins.free.fr/
Last edited by fg_2002fr on 2014-09-28, 08:33 UTC, edited 15 times in total.

Joe @ Whale
Junior Member
Junior Member
Posts: 7
Joined: 2003-11-04, 09:37 UTC
Location: Czech Republic

Re: new version of mmedia.wlx (2.40)

Post by *Joe @ Whale » 2003-11-27, 22:47 UTC

fg_2002fr wrote: - Added : (need to be tested) jump automatically to the next file when many files were selected (TC 6.0+ only)
Works fine, thanks for smart update :)

Only small remark - on jumping to the next file the lister window gains focus - that seems a little bit strange to me :?

Thanks again for this great plug-in :D

Roberto Duarte Barreto
Junior Member
Junior Member
Posts: 9
Joined: 2003-11-19, 06:11 UTC

Post by *Roberto Duarte Barreto » 2003-11-27, 23:32 UTC

Reproduced the behavior. On jumping to next file, Lister window gains focus. I am using it on XP PRO SP1 and all updates from WU.

Thanks for this Plugin!!!!


Duarte

User avatar
Boofo
Power Member
Power Member
Posts: 1431
Joined: 2003-02-11, 00:29 UTC
Location: Des Moines, IA (USA)
Contact:

Post by *Boofo » 2003-11-28, 00:05 UTC

I am having problems with this. Some AVI files don't dispkay in the right size (they are bigger than they should be). Lister default displays them the right size. Also, I have one football AVI that plays all scrunched up to the top of the lister box while (again) Lister default plays it right. Any ideas what might be going on?

User avatar
Ergo
Senior Member
Senior Member
Posts: 204
Joined: 2003-02-05, 12:20 UTC
Location: Belarus
Contact:

Post by *Ergo » 2003-11-28, 07:38 UTC

I have only problems :(
Doesn't work in Ctrl+Q at all. I can't see configuration tabs any more :(
Wincmd.ru WWW.TOTALCMD.NET
I see that future is near...

User avatar
Maxwish
Senior Member
Senior Member
Posts: 370
Joined: 2003-02-05, 19:13 UTC
Location: .NL

Post by *Maxwish » 2003-11-28, 08:32 UTC

tested on w2ksp4:
- Works in ctrl-q, tabs visible

Bug/problem
when viewing mp3's , and I press the frame tab I keep getting "an unsupported oiperation was attempted" after that I can't change to another tab because this error message keeps poppin up.
If you have "remember tabs" configured, this is a real problem, and you have to cofigure the INI by hand to set the tab to another one.
...BRB...

User avatar
Ergo
Senior Member
Senior Member
Posts: 204
Joined: 2003-02-05, 12:20 UTC
Location: Belarus
Contact:

Post by *Ergo » 2003-11-28, 09:16 UTC

winXP. Total Commander hangs up if i choose Interface=3. windows Media Player 9.00.00.2926 - may be it is the reason?

AND BTW.

[ext]
MMEXT = mpg,m1v,asf,wmv,avi,mpeg,aiff,wav,au,snd,aifc,rmi,midi,mid,cda,wvx,wax,asx,wma,ogg
MP3EXT = mp2,mp3,m3u

[Options]
autostart = 0
infopresencewmp =1
autosave=0
RememberAP=0
CheckRE=1
Interface=2
autoclose=0


Note, that ther is no Alternate = 3 - that is why it was not working in Ctrl+Q!, when I added this line it became working, but I still don't see any configuration tabs
Wincmd.ru WWW.TOTALCMD.NET
I see that future is near...

User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr » 2003-11-28, 12:48 UTC

to Joe @ Whale
on jumping to the next file the lister window gains focus
confirmed, I have not observed this behavior before. I will see why.

to Boofo
Some AVI files don't dispkay in the right size
I think this is a bug of mediaplayer
did you try to see this avi directely with WMP ?
(get me informed of that)

to Ergo
windows Media Player 9.00.00.2926
I'm using the same to test this plugin
by default, if not present in ini file "Alternate = 0" is used
maybe a system dll is altered

to Maxwish
"an unsupported oiperation was attempted"
is this error occured for all your mp3 files ?
and which id3v2 tag editor are you using ?

thanx to all to participe to improve this plugin

User avatar
Maxwish
Senior Member
Senior Member
Posts: 370
Joined: 2003-02-05, 19:13 UTC
Location: .NL

Post by *Maxwish » 2003-11-28, 14:31 UTC

fg_2002fr wrote:"an unsupported operation was attempted"
is this error occured for all your mp3 files ?
and which id3v2 tag editor are you using ?
-It happens to all my mp3 files.
-I don't use a id3v2 editor, the tags are already in the mp3s.

But the id3 tabs work, it's only the FRAME tab that does nothing, and when I then click another tab, that message shows.

what does the frame tab show anyway ?
...BRB...

User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr » 2003-11-28, 14:59 UTC

to Maxwish

is msflxgrd.ocx present in your system32 dir and correctly configured
if not, follow instruction in section "installation" in readme.txt
say me if this correct your problem

User avatar
Maxwish
Senior Member
Senior Member
Posts: 370
Joined: 2003-02-05, 19:13 UTC
Location: .NL

Post by *Maxwish » 2003-11-28, 15:22 UTC

Can somebody please show me a rock I can hide under ?

This is a real case of RTFM! I must have lost that dll when I upgrade from win98 to w2k.
Still, there's some good news: there's nothing wrong with the plugin
...BRB...

User avatar
Lefteous
Power Member
Power Member
Posts: 9457
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Post by *Lefteous » 2003-11-28, 15:28 UTC

2fg_2002fr

It' always userfriendly to avoid unnecessary dependencies - especially dependencies to ActiveX controls.

User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr » 2003-11-28, 15:49 UTC

Don't hide, who could replace you to maintain "Club Total"

due to you're great contribution to TC and to all plugin's developers
You will be always welcome :lol:

User avatar
Strogg
Junior Member
Junior Member
Posts: 84
Joined: 2003-08-24, 17:16 UTC
Location: Georgia

Post by *Strogg » 2003-11-30, 13:16 UTC

2fg_2002fr
Thank you very much for such great plugin. It's easy configurable and handly to use.
Unfortunately i noticed some strange behavior since version 2.3.
When I choose in settings Wmplayer 7+ (Alternate = 3), plugin plays ok only mp3 files , but hangs in attempt to play video files (avi) :(
My OS is XP sp1, Wmp9.

User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr » 2003-11-30, 18:02 UTC

to Strogg

could you try to choose "MediaPlayer 6.4+" as player and see if movie are played

Post Reply