[WFX]TotalAndDroid4.0 file system plugin for Android devices

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: white, sheep, Hacker, Stefan2

blagoev
Junior Member
Junior Member
Posts: 23
Joined: 2012-06-11, 06:14 UTC
Location: Bulgaria

TAD website maintenance 28.08.2012

Post by *blagoev » 2012-08-27, 16:41 UTC

TotalAndDroid website will not be available between 8:30 till 14:30 GMT on 28.08.2012. Cause planned maintenance.

Thanks for the understanding.
blagoev

blagoev
Junior Member
Junior Member
Posts: 23
Joined: 2012-06-11, 06:14 UTC
Location: Bulgaria

TAD v4.0 released

Post by *blagoev » 2012-09-05, 22:11 UTC

TAD v4.0 is released

What's in it
» New: Support for dynamic wireless connections. (opening \\TAD\IP:Port will try to connect automatically the device)
» New: Support "reboot to download" and "Power off" commands
» New: Support "hot reboot" command
» New: "Screenshow.png" special file will capture device screenshot (Can be copied, or opened in lister with F3)
» New: Support custom shell commands from TC command bar.

» Fixed: Date and time of pulled files from device
» Fixed: Connecting to devices that has $ instead of # as shell suffix
» Fixed: Moved to synchronous sockets by default (some computer configurations reported socket errors when async communication)
» Fixed: Use TAD when device is in recovery mode

for more information check the news page http://www.blagoev.com/TotalAndDroid/totalanddroid-v4.0

Hope you like it
blagoev[/url]

ovi1
New Member
New Member
Posts: 1
Joined: 2012-09-06, 10:14 UTC

does not see the device

Post by *ovi1 » 2012-09-06, 10:18 UTC

I have windows 7 64 bit, I have automatically installed vers 3.5 and 4.0 but it does not see my phone (Samsung galaxy S2) Android 4.0.3
I have enabled debugging
Windows explorer sees the phone with no problem.

okiwankenoki
Junior Member
Junior Member
Posts: 2
Joined: 2012-03-07, 19:06 UTC

Post by *okiwankenoki » 2012-09-27, 17:17 UTC

Hello blagoev,

same Problem for me :cry:

I have windows 7 64 bit, I have installed TAD 4.0 but it does not shows my Samsung galaxy S3 (Android 4.1.1) - I have also enabled debugging

Errormessage
Error occured. Please press 'Disconnect' and try again

Windows explorer shows the phone without problems.

Please help us :wink:

Yours Olaf

blagoev
Junior Member
Junior Member
Posts: 23
Joined: 2012-06-11, 06:14 UTC
Location: Bulgaria

logging

Post by *blagoev » 2012-10-02, 09:25 UTC

Hi,
I have done a detailed help page how to enable debugging. Can you do the steps so we can get a log file with whats going on.

http://www.blagoev.com/totalanddroid/howtologging

I plan to enable better way to log these in the future versions

thanks,
blagoev

CITYGUY
Junior Member
Junior Member
Posts: 31
Joined: 2012-09-07, 11:00 UTC

time difference

Post by *CITYGUY » 2012-10-08, 15:48 UTC

Mr Blagoev

Thank you for this great tool. Amazing. Just what I needed. I installed the new Jelly Bean ROM on my HTC One X. (Android Revolution 10.2)

Now with this new Jelly Bean the Sd Card is only recognized as a MTP device, not UMS any more in windows.

I use Total Commander it to sync big folders between my HTC ONE X an my pc.

The problem now is when I run Sync, all files have different date/time on my phone and Total commander recognizes the as different. Every file has exactly 3 hours difference in the date/time.

I guess this is because GMD time and my time zone Sofia are 3 hours different according to my phone. I think this is FTP protocol and this always has such thing about it.

While I was using the previous android (Ice Cream Sandwich) I could see my sd card as another disk in windows. I could then sync in Total Commander without problem and the files had matching times on the phone and the pc.

How can this be corrected??
I really need your help!
All the rest runs fine - wifi and cable and installation - everything worked great. I like it so much that I only want to use this way now, but I can not have the time difference problem, cause it would mess all my data...
Thank you again!
Looking forward to your instructions.

blagoev
Junior Member
Junior Member
Posts: 23
Joined: 2012-06-11, 06:14 UTC
Location: Bulgaria

Re: time difference

Post by *blagoev » 2012-10-10, 13:22 UTC

CITYGUY wrote:Mr Blagoev

Thank you for this great tool. Amazing. Just what I needed. I installed the new Jelly Bean ROM on my HTC One X. (Android Revolution 10.2)

Now with this new Jelly Bean the Sd Card is only recognized as a MTP device, not UMS any more in windows.

I use Total Commander it to sync big folders between my HTC ONE X an my pc.

The problem now is when I run Sync, all files have different date/time on my phone and Total commander recognizes the as different. Every file has exactly 3 hours difference in the date/time.

I guess this is because GMD time and my time zone Sofia are 3 hours different according to my phone. I think this is FTP protocol and this always has such thing about it.

While I was using the previous android (Ice Cream Sandwich) I could see my sd card as another disk in windows. I could then sync in Total Commander without problem and the files had matching times on the phone and the pc.

How can this be corrected??
I really need your help!
All the rest runs fine - wifi and cable and installation - everything worked great. I like it so much that I only want to use this way now, but I can not have the time difference problem, cause it would mess all my data...
Thank you again!
Looking forward to your instructions.
Can you enable logging so we can track what's going on. Check this page for detailed how-to enable logging and send the log file to uservoice ticket from the web site.
http://www.blagoev.com/totalanddroid/howtologging

Cheers,
blagoev

CITYGUY
Junior Member
Junior Member
Posts: 31
Joined: 2012-09-07, 11:00 UTC

Re: time difference

Post by *CITYGUY » 2012-11-05, 21:53 UTC

blagoev wrote:
CITYGUY wrote:Mr Blagoev

Thank you for this great tool. Amazing. Just what I needed. I installed the new Jelly Bean ROM on my HTC One X. (Android Revolution 10.2)

Now with this new Jelly Bean the Sd Card is only recognized as a MTP device, not UMS any more in windows.

I use Total Commander it to sync big folders between my HTC ONE X an my pc.

The problem now is when I run Sync, all files have different date/time on my phone and Total commander recognizes the as different. Every file has exactly 3 hours difference in the date/time.

I guess this is because GMD time and my time zone Sofia are 3 hours different according to my phone. I think this is FTP protocol and this always has such thing about it.

While I was using the previous android (Ice Cream Sandwich) I could see my sd card as another disk in windows. I could then sync in Total Commander without problem and the files had matching times on the phone and the pc.

How can this be corrected??
I really need your help!
All the rest runs fine - wifi and cable and installation - everything worked great. I like it so much that I only want to use this way now, but I can not have the time difference problem, cause it would mess all my data...
Thank you again!
Looking forward to your instructions.
Can you enable logging so we can track what's going on. Check this page for detailed how-to enable logging and send the log file to uservoice ticket from the web site.
http://www.blagoev.com/totalanddroid/howtologging

Cheers,
blagoev
It is too complicated for me to do that. But the explanation is here:

http://ask-leo.com/why_do_file_timestamps_compare_differently_every_time_change.html

It is just abut this. The article is covering a topic about the day light savings time but this is also explaining what is going on in my case.

Even when I am not using the plugin I get exactly 1 hour of difference 2 times per year. Please, read the article and you will know what I mean.

This is a general problem of Total commander Sync option. Must find solution, guys. You are the only ones who can!

User avatar
GammelBert
Member
Member
Posts: 109
Joined: 2007-02-21, 18:42 UTC
Location: Germany

Post by *GammelBert » 2013-05-25, 22:27 UTC

it's not working. I have connected my android via usb but this plugin asks for IP:Port.

soniraj
Junior Member
Junior Member
Posts: 6
Joined: 2013-05-29, 02:37 UTC

Post by *soniraj » 2013-05-29, 02:43 UTC

No Device shown. asking for IP:Port. Using windows 7, TC755a, Android 4.1.1, Sony xperia e dual, USB debugging mode active. Connectivity mode MTP. Device shown in windows explorer. Given below is the log file created

System.Net.Sockets Verbose: 0 : [2740] Socket#63063909::Socket(InterNetwork#2)
System.Net.Sockets Verbose: 0 : [2740] Exiting Socket#63063909::Socket()
System.Net.Sockets Verbose: 0 : [2740] Socket#63063909::Connect(1:5037#16782290)
System.Net.Sockets Information: 0 : [2740] Socket#63063909 - Created connection from 127.0.0.1:51358 to 127.0.0.1:5037.
System.Net.Sockets Verbose: 0 : [2740] Exiting Socket#63063909::Connect()
System.Net.Sockets Verbose: 0 : [2740] Socket#63063909::Send()
System.Net.Sockets Verbose: 0 : [2740] Data from Socket#63063909::Send
System.Net.Sockets Verbose: 0 : [2740] 00000000 : 30 30 30 43 68 6F 73 74-3A 64 65 76 69 63 65 73 : 000Chost:devices
System.Net.Sockets Verbose: 0 : [2740] 00000010 : 0A : .
System.Net.Sockets Verbose: 0 : [2740] Exiting Socket#63063909::Send() -> 17#17
System.Net.Sockets Verbose: 0 : [2740] Socket#63063909::Receive()
System.Net.Sockets Verbose: 0 : [2740] Data from Socket#63063909::Receive
System.Net.Sockets Verbose: 0 : [2740] 00000000 : 4F 4B 41 59 : OKAY
System.Net.Sockets Verbose: 0 : [2740] Exiting Socket#63063909::Receive() -> 4#4
System.Net.Sockets Verbose: 0 : [2740] Socket#63063909::Receive()
System.Net.Sockets Verbose: 0 : [2740] Data from Socket#63063909::Receive
System.Net.Sockets Verbose: 0 : [2740] 00000000 : 30 30 30 30 : 0000
System.Net.Sockets Verbose: 0 : [2740] Exiting Socket#63063909::Receive() -> 4#4
System.Net.Sockets Verbose: 0 : [2740] Socket#63063909::Shutdown(Both#2)
System.Net.Sockets Verbose: 0 : [2740] Exiting Socket#63063909::Shutdown()
System.Net.Sockets Verbose: 0 : [2740] Socket#63063909::Disconnect()
System.Net.Sockets Verbose: 0 : [2740] Exiting Socket#63063909::Disconnect()

mabrik
Junior Member
Junior Member
Posts: 3
Joined: 2010-04-29, 18:47 UTC

Post by *mabrik » 2013-08-04, 14:54 UTC

Plugin TotalAndDroid ask me for connection to 84.10.105.26 (AS6830 LGI-UPC Liberty Global Operations B.V.), from Slovakia

abcd
Junior Member
Junior Member
Posts: 30
Joined: 2007-01-23, 08:53 UTC

Re: [WFX]TotalAndDroid4.0 file system plugin for Android devices

Post by *abcd » 2018-08-21, 14:50 UTC

Hey it seems that this plugin does not work anymore. when I lauch it I get a message :server out of date closing then opening daemon but nothing happen. It is a pity this addon was very good. any news?

Post Reply