This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TC opens a linked directory with microsoft explorer

 
Post new topic   Reply to topic    Total Commander Forum Index -> TC7.5x(a) final bug reports (English) Printable version
View previous topic :: View next topic  
Author Message
thoriane
Junior Member
Junior Member


Joined: 03 May 2010
Posts: 5

PostPosted: Tue May 04, 2010 4:43 am    Post subject: TC opens a linked directory with microsoft explorer Reply with quote

Total Commander Version 7.50 a
#89301 license

Windows XP Profession Version 5.1, Service Pack 2, all updates

Total Commander was updated last week to above mentioned version. Since then, it was no more possible to open linked directories in the TC window (direct links to a special directory installed in active directory, where I only have rights on this directory and not on the root directory). When I click the link, the directory will be opened in a Microsoft Explorer window.

Now I got the hint in the forum to use Strg+D. But this can only be a temporary solution because those links are used by different people in the company and Strg+D has to been configurated on each unit.

As it worked with the former version of TC now my question:

is it a bug or is there a configuration to change?

Thanks.
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35761
Location: Switzerland

PostPosted: Wed May 05, 2010 4:02 am    Post subject: Reply with quote

This happens when TC cannot resolve the link internally, e.g. when it points to some virtual folder which TC cannot handle. Where do these links point to? Can you give me some examples?
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
thoriane
Junior Member
Junior Member


Joined: 03 May 2010
Posts: 5

PostPosted: Wed May 05, 2010 5:26 am    Post subject: Reply with quote

I am not allowed to get in contact with you via email out of this forum. I took a print screen, but I have no possibility to upload it somewhere because of internal restrictions and it is not possible to upload it here directly. So I have to wait and try to explain our system.

By information of our IT collegues: the folders are not only virtual but if I think about it .....

Structure of every folder in Active Directory is:

Department Name (folder in Active director)
- In (everybody can put data in - read + write)
- Out (data, which we can get from there - not write)
- Data (only members of the department can come into it)
-- folder1
-- folder2
- Links (special links to a folder or subfolder of 'Data')
folder1.lnk (= i:\department\data\folder1 - read and/or write)

Those links only can be generated by the IT stuff. Perhaps this links-directory is the problem.

If I am the owner or a member of a Department, the link runs. But if I don't have rights on Department - Data but on Department-Data-folder1, then TC opens the explorer.

Because it went with the older version of TC I asked if it is perhaps a bug.

I hope, that I explained it understandable. If I shall send the print screen, I need an email adress.
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35761
Location: Switzerland

PostPosted: Wed May 05, 2010 7:43 am    Post subject: Reply with quote

Thanks for the explanation. This problem will be resolved in Total Commander 7.55. This version is currently in public beta test, you can already test it now with public beta 3.

TC 7.50a checks via FindFirstFile whether a link target exists or not, and whether the link points to a file or directory. In your case, FindFirstFile fails because you aren't allowed to look into the "data" folder containing "folder1". TC 7.55 will handle that by looking for i:\department\data\folder1\*.* if looking for i:\department\data\folder1 fails.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
thoriane
Junior Member
Junior Member


Joined: 03 May 2010
Posts: 5

PostPosted: Wed May 05, 2010 7:58 am    Post subject: Reply with quote

Super - thank you.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC7.5x(a) final bug reports (English) All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group