TotalCommander FTP client not showing files just upploaded

Please report only one bug per message!

Moderators: white, sheep, Hacker, Stefan2

Post Reply
zainka
New Member
New Member
Posts: 1
Joined: 2008-04-08, 20:29 UTC

TotalCommander FTP client not showing files just upploaded

Post by *zainka » 2011-06-17, 08:11 UTC

Hi

This is something I believe to be a bug, please verify.

I have connected to an ftp server and uploaded some files. I get OK but the files are not visible, not even when reconnecting to the server. Even when restarting total commander and reconnecting to server the files does not appear. Strange thing is though that if connecting to the ftp server through firefox or ie, the files are indeed visible, i.e. they have been successfully uploaded and they are valid files which can be downloaded and viewed. (it was a bunch of pdf's).

More strange is that if I from totalcommanders ftp client tries to upload the same files once again in the same spot I still get OK but nothing shows up in the destination folder.

This has to be a bug with the refreshing scheme used by the client sine CTRL+R will make the files appear, but they should have appear automatically i believe. Note that I am behind an proxy requiring authentication and this may influence on the refreshing of the folder content. I would expect though that the directory entry was updated when reconnecting instead of relying on what I believe must be buffered content.


Breg
Vidar
----------------
Vidar (Z)

User avatar
sqa_wizard
Power Member
Power Member
Posts: 3381
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard » 2011-06-17, 20:08 UTC

You may try to disable the option from main menu:

Net - FTP show hidden files

Then reconnect again.

Some servers have problems with this option enabled.
#5767 Personal license

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36425
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2011-06-20, 14:24 UTC

It's also possible that the implementation of the MLSD command is faulty on your server. TC tries to use MLSD only when the server reports to support it. You can disable MLSD via Ctrl+F - Edit connection.
Author of Total Commander
http://www.ghisler.com

Sob
Power Member
Power Member
Posts: 908
Joined: 2005-01-19, 17:33 UTC

Post by *Sob » 2011-06-22, 02:06 UTC

I'd say that problems with hidden files or MLSD tend to be more permanent. If it was the case, Ctrl+R would hardly make the files appear.

@zainka: TC does refresh directory listing after upload finishes, so everything is as it should be. Why it doesn't work for you, no idea. Check if you see something wrong in log. Or post it here and we'll check it for you. You can also post some info about used proxy (its type for example or any other useful info), for me it's the main suspect.

Post Reply