[8.0ß2-x64] FTP log mostly not updating

Bug reports will be moved here when the described bug has been fixed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
davidc2
Junior Member
Junior Member
Posts: 7
Joined: 2011-09-25, 15:09 UTC

[8.0ß2-x64] FTP log mostly not updating

Post by *davidc2 »

Using Windows 7 x64.

I've used the beta 2 program to do 2 updates (several hundred files) to a website.

In each case, the tcftp.log file only adds:

Connect to: (25-09-2011 9.21.31)
hostname=[server name removed]
username=[username removed]
startdir=htdocs

to the log file. In other words, all of the usual log information about files being transfered and overhead commands is not being added to the log.

It appears that the files were all uploaded correctly.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39100
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

Strange, works perfectly here...
Author of Total Commander
http://www.ghisler.com

davidc2
Junior Member
Junior Member
Posts: 7
Joined: 2011-09-25, 15:09 UTC

Post by *davidc2 »

I rebooted and deleted the old log, but still getting the same results. I'll experiment some more and see what I find.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39100
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

Maybe it's a settings problem? What log file settings do you use?
Author of Total Commander
http://www.ghisler.com

new2alex
Junior Member
Junior Member
Posts: 2
Joined: 2012-03-13, 01:27 UTC

Post by *new2alex »

Do not become to create a new topic. I have the same problem. The file (tcftp.log) is saved only the first few rows.
----------
Connect to: (11.03.2012 5:09:01)
hostname=ftp.xxx.xxx
username=xxxx
startdir=

OS: WinXP SP3. TC 7.57, 7.57a, 8.0b22.
With version 7.56a is not a problem!

Maybe a problem with ntfs file system. If you put the logs on removable media (fat32), the record is correct.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39100
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

Sorry, cannot reproduce. My tcftp.log is 570 kBytes and still growing.
Author of Total Commander
http://www.ghisler.com

User avatar
karlchen
Power Member
Power Member
Posts: 4557
Joined: 2003-02-06, 22:23 UTC
Location: Germany

Post by *karlchen »

Hello, Christian.

Sorry, but I have just "spammed" you with 3 or 4 e-mails holding screenshots and logfiles and INI files. This should at least explain what we see and what we do.
The most confusing thing is that the problem can be reproduced using 2 absolutely fresh INI files. Activate the ftp-logfile creation, confirm the default logfile name. Create just one ftp-connection.
T.C. 8.0ß22 did not log all activities in the ftp.logfile.
T.C. 7.56a did.
Commandlines used to launch T.C.:
+ 8.0ß22: D:\Utils\TC80beta\TOTALCMD.EXE /N /I=.\fresh.ini /F=.\ftp.ini
+ 7.56a: D:\Utils\TC756a\TOTALCMD.EXE /N /I=.\fresh.ini /F=.\ftp.ini

Yet, it is not a phenomenon which at least on my machine(s) can be seen when using T.C. 8.0ß22. It can be reproduced using anything newer than T.C. 7.56a.

Kind regards,
Karl
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

User avatar
petermad
Power Member
Power Member
Posts: 9360
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad »

I can confirm using TC 8.0b22 both x64 and x86 version, that using a set of fresh ini files for both wincmd.ini and wcx_ftp.ini, only adding the log file option and one ftp-server, then only 4 lines are written to the ftp log file.

Also there is only written one time per TC session to the log file - I have to close and open TC again to get TC to write to the log file - just openeing and closing the FTP connection doesn't do it.

EDIT: I can also confirm that this applies to TC 7.57a under WinXP.

If I use my regular ini files there are no problems.
License #524 (1994)
Danish Total Commander Translator
TC 9.5b10 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.960 (x64)
TC 3.0b16 on Android 6.0
Get: Extended Total Commander Menus | TC Languagebar | PHSM-Calendar

User avatar
karlchen
Power Member
Power Member
Posts: 4557
Joined: 2003-02-06, 22:23 UTC
Location: Germany

Post by *karlchen »

Good morning, Peter.
I can confirm using TC 8.0b22 both x64 and x86 version, that using a set of fresh ini files for both wincmd.ini and wcx_ftp.ini, only adding the log file option and one ftp-server, then only 4 lines are written to the ftp log file.
Thank you so much. :D I had started wondering what I might do the wrong way round in order to produce this behaviour.
Also there is only written one time per TC session to the log file - I have to close and open TC again to get TC to write to the log file - just openeing and closing the FTP connection doesn't do it.
Last night I had observed so, too, but had not reported so, yet. Also I have not tested too well whether this affects v7.57a only - where I saw it - or 8.0ß22, too.
EDIT: I can also confirm that this applies to TC 7.57a under WinXP.
Yep. Any version above v7.56a will do.
using a set of fresh ini files for both wincmd.ini and wcx_ftp.ini, only adding the log file option and one ftp-server, then only 4 lines are written to the ftp log file. [..]
If I use my regular ini files there are no problems.
This means that some (combination of) T.C. default settings are sufficient in order to encounter the logfile problem.
As - using my regular INI files - I encounter the problem this suggests that the relevant settings are on default values in my INIs, maybe not even mentioned explicitly in the INI files.
This is going to be a nice piece of work fiddling out the relevant setting(s) ...

Cheers,
Karl
---
Environments tested by me that

will not produce the logfile problem:
Total Commander v7.56a using
+ empty wincmd.ini and empty wcx_ftp.ini
+ my regular wincmd.ini and wcx_ftp.ini
on
+ Windows 7 Enterprise SP1, 32-bit
+ Server 2008 R2, 64-bit
+ Linux Mint12 / Wine 1.2.3 in WinXP mode

will produce the logfile problem:
Total Commander v7.57 / v7.57a / v8.0ß22 32-bit using
+ empty wincmd.ini and empty wcx_ftp.ini
+ my regular wincmd.ini and wcx_ftp.ini
on
+ Windows 7 Enterprise SP1, 32-bit
+ Server 2008 R2, 64-bit
+ Linux Mint12 / Wine 1.2.3 in WinXP mode
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39100
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

I could find the reason now: You also need to enable normal logging (and then restart TC) to make FTP logging work. Unfortunately it's too late for TC 7.57a, but I will fix it in TC 8.
Author of Total Commander
http://www.ghisler.com

User avatar
karlchen
Power Member
Power Member
Posts: 4557
Joined: 2003-02-06, 22:23 UTC
Location: Germany

FTP-Log working again in T.C. 8.0ß23 32-bit / 64-bit

Post by *karlchen »

Hello, Christian.

The FTP Logging works correctly again and independently of the parameter LogOptions for normal T.C. logging.

Tried
  • (wincmd.ini) LoggingOption=7198 (i.e. off)
    (wcx_ftp.ini) Logfile=%TEMP%\tc8ftp.log
    Result:
    %TEMP%\tc8ftp.log is updated with the complete FTP session details.
  • (wincmd.ini) LoggingOption=1 (i.e. on, but no details logged really)
    (wincmd.ini) Logfile=%temp%\totalcmd800.log
    (wcx_ftp.ini) Logfile=%TEMP%\tc8ftp.log
    restarted T.C.
    Results:
    %TEMP%\tc8ftp.log is updated with the complete FTP session details
    %TEMP%\Totalcmd800.log is created and logs startup and shutdown of T.C.
Environments:
Total Commander 8.0ß23 32-bit on Windows 7 Enterprise SP1, 32-bit
Total Commander 8.0ß23 64-bit on Server2008 R2, 64-bit

Thank you for fixing this little nuisance.

Karl
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

User avatar
petermad
Power Member
Power Member
Posts: 9360
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad »

Confirmed fixed in TC 8.0b23 x64 :-)
License #524 (1994)
Danish Total Commander Translator
TC 9.5b10 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.960 (x64)
TC 3.0b16 on Android 6.0
Get: Extended Total Commander Menus | TC Languagebar | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39100
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

Thanks!
Author of Total Commander
http://www.ghisler.com

new2alex
Junior Member
Junior Member
Posts: 2
Joined: 2012-03-13, 01:27 UTC

Post by *new2alex »

Thank you. In version 8.0b23 logs again to work.

Post Reply