Japanese filenames are garbled most of the time

Please report only one bug per message!

Moderators: Stefan2, white, sheep, Hacker

Post Reply
TotalFan999
Junior Member
Junior Member
Posts: 2
Joined: 2013-02-18, 09:43 UTC

Japanese filenames are garbled most of the time

Post by *TotalFan999 » 2013-02-18, 09:57 UTC

When filenames appear initially, they work correctly, but when the cursor moves over them (or the window is resized) parts of the filename disappear. In addition, occasionally random memory corruption appears over parts of the Total Commander window.
For example, I created three files in a directory:
試してみようascii中に入ってある.txt
試してみよう長い何か.txt
テスト一.txt
Unfortunately the board doesn't let me post URLs to the screenshots, but I can send images if this is not reproducible on other machines.
My system is a Windows 7 64 bit, running TCMD x64 8.01

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36554
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2013-02-18, 14:16 UTC

Thanks for your report. It sounds like a font problem. Please go to menu Configuration - Options - Fonts and set the listbox font to "Segoe UI".
Author of Total Commander
http://www.ghisler.com

TotalFan999
Junior Member
Junior Member
Posts: 2
Joined: 2013-02-18, 09:43 UTC

Post by *TotalFan999 » 2013-02-19, 10:45 UTC

Dear Ghisler,

Thanks for the quick reply!

I tried switching the Font to Sergoe UI, but that didn't help.

But you are right, that this seems to be a font handling issue, because when I switched the Font style to Regular instead of Bold, the filenames were displayed correctly even with the default Microsoft Sans Serif font.

The interesting part is that it's usually the ascii characters in the filename that disappear, and not the Japanese characters.
For example, the filename: "試してみようascii中に入ってある.txt"
shows up as "試してみよう   中に入ってある   ".

Unfortunately I prefer to use bold font for the file lists, as it is more readable. Is there any chance this font handling bug will be fixed in the future?

User avatar
Lefteous
Power Member
Power Member
Posts: 9433
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Post by *Lefteous » 2013-02-19, 13:28 UTC

Segoe UI isn't the right choice for Japanese file names.
http://msdn.microsoft.com/en-us/library/windows/apps/jj553415.aspx

Try 'Meiryo UI'

User avatar
LordKaos
Junior Member
Junior Member
Posts: 26
Joined: 2010-03-29, 19:31 UTC

SOLVED!

Post by *LordKaos » 2014-03-13, 17:16 UTC

Hi!

Well, in my case, I never changed anything in my computer configuration and after some TC updates, my japanese characters appear wrong.

I tryed the previous methods and nothing let my characters appear as usual.

I tested this on three computers and all have the same problem.

Where can I download older versions of TC to try with them? I´m using 8.5 x64 and 7.57 i386.


ADDED INFO: all other windows applications show it correctly.

THAT´S MY OLD POST. Here the solution:

In Windows XP, is needed to install the "support for east asian languages" under Languages in Regional Settings.

That will install about 230mb of needed files and VOILA! We can still use MS Sans Serif loved font as usual.

In Windows 7, in Regional and Languages, Keyboards and Languages, and install the Japanese keyboard. That will install needed files.

In both cases is mandatory to reboot the computer.


:D





Thanks
LORD KAOS WAS HERE!

Post Reply