Error executing program! (29) when trying to open excel file

Please report only one bug per message!

Moderators: white, sheep, Hacker, Stefan2

siealex
Senior Member
Senior Member
Posts: 222
Joined: 2009-03-22, 16:36 UTC

Post by *siealex » 2014-03-15, 19:27 UTC

Microsoft Word often throws "file not found" when the system (especially HDD) is heavily loaded (e. g. initial autostart or virus scanning). When the system is free I never see this window.
We are not so S.M.A.R.T. as we imagine...

mackz711
New Member
New Member
Posts: 1
Joined: 2014-04-16, 19:35 UTC

Post by *mackz711 » 2014-04-16, 19:53 UTC

In TC when I double Click on *.docx file got error message with MS Word Viewer.
I opened Window Explorer ( Start, then All Programs, then Accessories Folder, then Window Explorer.)
With Win Explorer I went to a word document file *.docx Click on file ( one click to highlight ) then Right click on the document.
Then choose Open with, then Choose Default Program, then Choose Microsoft Word. This did NOT Work When I selected MS Word Viewer.
This worked that I can click on a *.docx file from with in NC

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36439
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2014-04-18, 06:33 UTC

You could have done that trick with the right click menu also in TC. By default, you need to right click for half a second to get the menu, a short right click will just select the file.
Author of Total Commander
http://www.ghisler.com

Marco76
New Member
New Member
Posts: 1
Joined: 2014-05-13, 10:44 UTC

Post by *Marco76 » 2014-05-13, 10:49 UTC

Guiness wrote:Bring up the Excel options, go to advanced and then scroll down to the "General" section. Make sure that "Ignore other applications that use Dynamic Data Exchange (DDE)" is not checked.
This actually worked, but first I had to check it, close and restart Excel and then uncheck it, close and restart Excel. Now it's working...

Devi
Junior Member
Junior Member
Posts: 2
Joined: 2014-06-19, 12:30 UTC
Contact:

Post by *Devi » 2014-06-19, 12:43 UTC

Go to the Office Button / Excel Options / Advanced, and scroll all the way down to the General section. There you will see the “Ignore other applications that use Dynamic Data Exchange (DDE)” setting checked. Uncheck the box, click OK to apply, and you’re good to go.

Vektoren
New Member
New Member
Posts: 1
Joined: 2014-10-19, 17:48 UTC

Post by *Vektoren » 2014-10-19, 17:49 UTC

Devi wrote:Go to the Office Button / Excel Options / Advanced, and scroll all the way down to the General section. There you will see the “Ignore other applications that use Dynamic Data Exchange (DDE)” setting checked. Uncheck the box, click OK to apply, and you’re good to go.
Thank you very much :) That was my problem.

aboutblank
Junior Member
Junior Member
Posts: 7
Joined: 2014-11-11, 22:54 UTC

Post by *aboutblank » 2014-11-11, 23:22 UTC

November 11, 2014:

I ran into a similar problem with text files (.txt). When I double clicked on a text file within Total Commander, my favorite editor would open, but I got the 'error 29' message, in addition.

The problem was related to my DDE settings for .txt files. Using "Default Programs Editor" (a 3rd party freeware program that has been around for a long time), I noted that though I had the correct command line for my favorite text editor, I also had the box for "Command line DDE: |√| Use DDE Message" checked. I unchecked this box, saved my changes and exited. After that, double clicking on the .txt file opened my editor without an error 29 message. (Also, in Explorer, double clicking on a text file no longer produced a different error message that I had also been receiving.)

For those using "Default Programs Editor" (I am using version 2.7.2675.2253, running it as an Administrator), here is how you access the screen to make the change I described above:
- on the opening screen, click on the top box, "File Type Settings";
- on the next screen, click on the tob box, "Context Menu";
- on the 'Select an extension to change' screen, type ".txt" in the search box (without quotes); on my system, only one entry shows, ".txt TXT File"; click "Next"
- on the 'Select and change context menu items for .txt files' screen, make sure the highlight is on "Open", and click on 'Edit Selected Command...';
- on the lower half of the 'Edit settings for 'Open' ' screen, check the 'Advanced Settings': The 'Use DDE Message' box should be unchecked. Insure that in the upper half of the screen, you have placed the correct 'Program path:' to your program, for example: "C:\Program Files\EditPadLite\EditPad.exe" "%1" (include the quotation marks);
- Click on 'Next' on the bottom line, and on the next screen, click on 'Save Context Menu'; click on 'OK', then close the program, and test.

I hope that this explanation helps those with similar problems.

aboutblank
November 11, 2014

Post Reply