unable to delete pictures (jpg) when in thumbnail preview

The behaviour described in the bug report is either by design, or would be far too complex/time-consuming to be changed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
BuzzD
Junior Member
Junior Member
Posts: 6
Joined: 2016-10-30, 09:17 UTC
Location: Berlin

unable to delete pictures (jpg) when in thumbnail preview

Post by *BuzzD » 2016-10-30, 09:27 UTC

Hi, since (I think) beta 16 I am unable to delete jpg-files when I view them in thumbnail-preview mode.
It seems like TC somehow locks the file. This is a problem that also occurs when I try to delete it with windows explorer and goes away once I close TC.

When I deactive all options in configuration/thumbnails/loading thumbnails and thus prevent preview pictures from being created, deleting files works fine.

This occurs on Windows 10 professional and the bug was reproducable on 3 different computers (all running Win10 Prof. 64bit)

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3242
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Post by *Horst.Epp » 2016-10-30, 09:48 UTC

No such problem here in Windows 10 with TC 9.0 RC3 x64
The options for getting thumbnails from Lister plugins and Explorer are on.
Windows 10 Home x64 October 2018 Update, Version 1809 (OS Build 17763.379)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.22 x64 and x86, Everything 1.4.1.939 (x64)

BuzzD
Junior Member
Junior Member
Posts: 6
Joined: 2016-10-30, 09:17 UTC
Location: Berlin

Post by *BuzzD » 2016-10-31, 13:43 UTC

Well, I uninstalled TC, completely deleted all config data and reinstalled from scratch. For the computer I tested that with, it worked.

But with my main computer, I tried the same and it still occurs.
When I uninstall everything and then do a complete new install with RC3, the problem immediately occurs once I switch to thumbnail preview.
If I install 8.52a, it works. But as soon as I upgrade to RC3, the bug is there again.

Edit: I'm pretty shure, it has something to do with the explorer method (OLE2). Once I deactivate it and let irfanview do the job, it seems to work.

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3242
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Post by *Horst.Epp » 2016-10-31, 14:11 UTC

BuzzD wrote:Well, I uninstalled TC, completely deleted all config data and reinstalled from scratch. For the computer I tested that with, it worked.

But with my main computer, I tried the same and it still occurs.
When I uninstall everything and then do a complete new install with RC3, the problem immediately occurs once I switch to thumbnail preview.
If I install 8.52a, it works. But as soon as I upgrade to RC3, the bug is there again.

Edit: I'm pretty shure, it has something to do with the explorer method (OLE2). Once I deactivate it and let irfanview do the job, it seems to work.
As I said I have enabled Explorer method without that ill effect.
I guess it may be your Irfanview installation.
I use the Imagine plugin for pictures.
Windows 10 Home x64 October 2018 Update, Version 1809 (OS Build 17763.379)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.22 x64 and x86, Everything 1.4.1.939 (x64)

BuzzD
Junior Member
Junior Member
Posts: 6
Joined: 2016-10-30, 09:17 UTC
Location: Berlin

Post by *BuzzD » 2016-10-31, 14:24 UTC

I'm guessing it has something to do with that OLE2-thingy.

I've never even used irfanview before. I just now started using it as a workaround.
I had to configure TC to use irfanview as an internal viewer and deactivate OLE2. Now it works.
So I'm guessing it has something to do with the way that TC is using some api from windows. Because once deleting becomes impossible, it is impossible systemwide until I close TC...

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37060
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2016-10-31, 20:24 UTC

It sounds like some Explorer extension which is responsible for extracting/creating the thumbs picture isn't closing the files. It doesn't have to be the one responsible for JPG - other extensions may be checking the files for thumbnails, and failing to create a thumbnail.
Author of Total Commander
http://www.ghisler.com

Uli79
Junior Member
Junior Member
Posts: 2
Joined: 2015-01-21, 12:40 UTC

Re: unable to delete pictures (jpg) when in thumbnail preview

Post by *Uli79 » 2019-01-05, 19:01 UTC

Hi, I'm having this 'old' problem since I installed 9.21a on a Win10 notebook (using irfanview 4.52). Is there anything new on this topic?

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37060
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: unable to delete pictures (jpg) when in thumbnail preview

Post by *ghisler(Author) » 2019-01-07, 15:28 UTC

Which file types?
Author of Total Commander
http://www.ghisler.com

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3242
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: unable to delete pictures (jpg) when in thumbnail preview

Post by *Horst.Epp » 2019-01-07, 17:22 UTC

Uli79 wrote:
2019-01-05, 19:01 UTC
Hi, I'm having this 'old' problem since I installed 9.21a on a Win10 notebook (using irfanview 4.52). Is there anything new on this topic?
I use Imaging plugin on Windows 10 for picture viewing and I have no problem to delete files while their thumbnails are displayed.
I don't see any benefit of using IrfanView in Lister ?
Windows 10 Home x64 October 2018 Update, Version 1809 (OS Build 17763.379)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.22 x64 and x86, Everything 1.4.1.939 (x64)

User avatar
Usher
Senior Member
Senior Member
Posts: 283
Joined: 2011-03-11, 10:11 UTC

Re: unable to delete pictures (jpg) when in thumbnail preview

Post by *Usher » 2019-01-07, 17:27 UTC

2Horst.Epp
Does the Imaging plugin show incomplete or broken pictures?
Regards from Poland
Andrzej P. Wozniak

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3242
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: unable to delete pictures (jpg) when in thumbnail preview

Post by *Horst.Epp » 2019-01-07, 17:30 UTC

Usher wrote:
2019-01-07, 17:27 UTC
2Horst.Epp
Does the Imaging plugin show incomplete or broken pictures?
I don't know.
Do you have an example for testing ?
Windows 10 Home x64 October 2018 Update, Version 1809 (OS Build 17763.379)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.22 x64 and x86, Everything 1.4.1.939 (x64)

User avatar
Usher
Senior Member
Senior Member
Posts: 283
Joined: 2011-03-11, 10:11 UTC

Re: unable to delete pictures (jpg) when in thumbnail preview

Post by *Usher » 2019-01-07, 17:38 UTC

2Horst.Epp
Sure, let me some time to find and upload them.
Regards from Poland
Andrzej P. Wozniak

Post Reply