+'Move to archive' option leaves empty folders

The behaviour described in the bug report is either by design, or would be far too complex/time-consuming to be changed

Moderators: Stefan2, white, sheep, Hacker

Post Reply
spapost
Junior Member
Junior Member
Posts: 2
Joined: 2012-09-18, 19:16 UTC

+'Move to archive' option leaves empty folders

Post by *spapost » 2014-02-26, 17:13 UTC

Not sure whether this is a bug, but I'm getting this strange behaviour when creating archive:

1. Select several folders
2. Call 'Pack files' dialog
3. Choose options 'Move to archive' and 'Create separate archive, one per selected file/dir'
4. Start packing with built-in packer

After successful run of the packer, I get the folders emptied, but not deleted. The same behaviour was in at least 8.5RC3, but not in other (8.01 and earlier) versions - checked on two different PCs.

Edit
Tried both x64 and x86 version, with current and clean installs, still leaves folders emptied but not deleted

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2014-03-03, 14:22 UTC

This happens when the new option "leave out base directory when packing folders" is checked. Since the base directory isn't packed, it's not deleted either. I will change it.
Author of Total Commander
http://www.ghisler.com

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2014-03-27, 15:48 UTC

This has been fixed a while ago - please test with beta 5!
Author of Total Commander
http://www.ghisler.com

User avatar
DrShark
Power Member
Power Member
Posts: 1111
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

Post by *DrShark » 2017-05-21, 20:28 UTC

For 32-bit TC on Vista 32-bit I can confirm that reported issue was present in TC8.5 pb 3, but doesn't present in final releases of TC 8.5 and TC 9 except for following situations:
1) TC's "Move to archive" function still doesn't remove the folders with read-only attribute (and inner files with r-o attribute).
2) TC's "Move to archive" function still doesn't remove the folders and inner files if that folders have restricted acces rights (may be reproduced on the subfolders of %programfiles% on Vista).
Since both mentioned issues are not limited just to the "Create separate archive, one per selected file/dir" option, maybe it's better to make a new separate bugreport for each of mentioned issues?
Last edited by DrShark on 2017-05-22, 12:31 UTC, edited 1 time in total.
Android 4.3.1 no root, kernel 08.09.2016; Vista Home Premium SP2 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-05-22, 10:56 UTC

I don't think that I should change that. Read only is there for a reason...
Author of Total Commander
http://www.ghisler.com

User avatar
DrShark
Power Member
Power Member
Posts: 1111
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

Post by *DrShark » 2017-05-22, 12:43 UTC

ghisler(Author) wrote:I don't think that I should change that. Read only is there for a reason...
Help wrote:Move to archive If this option is checked, the files are deleted after a successful packing operation.
If TC knows that packing operation was successful and archive was made why at the end of delete operation for regular files/folders also not to ask user for confirmation to remove the source folders/files with read-only attribute or those with elevation requirement to be removed?
Android 4.3.1 no root, kernel 08.09.2016; Vista Home Premium SP2 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right

Post Reply