Display problem when remotely connecting with Custom Scaling

Bug reports will be moved here when the described bug has been fixed

Moderators: Stefan2, white, sheep, Hacker

Post Reply
argh0815
Junior Member
Junior Member
Posts: 8
Joined: 2016-11-24, 17:42 UTC
Location: Singapore

Display problem when remotely connecting with Custom Scaling

Post by *argh0815 » 2017-11-10, 15:27 UTC

Since updating to Windows 10 Fall Creators Update I'm having a problem using TC on my Desktop PC when connecting to it from my laptop using Remote Desktop. This only occurs when I use a custom display scaling of 120% or less on my laptop (125% or 100% work fine).

I've tested it on 9.10 as well as the latest 9.12RC and both show the same behaviour. I have some other minor issues with 120% custom scaling within Windows since the Fall update so it might well be a Microsoft rather than a TC issue.

120%: https://i.imgur.com/WDPNQmn.jpg
125%: https://i.imgur.com/UnnsEoy.jpg
Last edited by argh0815 on 2017-11-13, 15:46 UTC, edited 1 time in total.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-11-10, 15:34 UTC

This seems to be a duplicate report:
https://ghisler.ch/board/viewtopic.php?t=48829

So far I cannot reproduce it. Can you try to log out and back in after changing the DPI scaling?
Author of Total Commander
http://www.ghisler.com

argh0815
Junior Member
Junior Member
Posts: 8
Joined: 2016-11-24, 17:42 UTC
Location: Singapore

Post by *argh0815 » 2017-11-10, 16:14 UTC

Logging out and back in doesn't change it. Let me try to be a bit more clear as to what I'm doing:

Desktop, Windows 10 FCU:
Single monitor with 2560*1440, 100% scaling.

Laptop, Windows 10 FCU:
Laptop display with 1920*1080, 120% scaling.

I'm connecting remotely from the laptop to the desktop PC with Remote Desktop Connection. Then I start TC on the desktop PC via Remote Desktop. The screenshots show what I see on my laptop in the Remote Desktop window. The issue only occurs when I use a custom scaling of 120% on my laptop, if I use 125%, everything works fine.

Just tested it with 9.0a and that one works fine with 120%.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-11-12, 15:01 UTC

9.0a doesn't support custom resizing, it will appear blurred because it's resized by Windows. You can use this mode also in TC 9.1x by adding
DpiPerScreen=0
to the wincmd.ini under [Configuration]. But the goal would be to get this to work somehow with correct DPI scaling. It's just a big mess how this is handled by Windows 10. :(
Author of Total Commander
http://www.ghisler.com

argh0815
Junior Member
Junior Member
Posts: 8
Joined: 2016-11-24, 17:42 UTC
Location: Singapore

Post by *argh0815 » 2017-11-12, 15:21 UTC

Ok, understood, thanks a lot for the feedback!

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-11-13, 15:05 UTC

Does Total Commander look OK when you close and re-open it? So far I still couldn't reproduce the problem...
Author of Total Commander
http://www.ghisler.com

argh0815
Junior Member
Junior Member
Posts: 8
Joined: 2016-11-24, 17:42 UTC
Location: Singapore

Post by *argh0815 » 2017-11-13, 15:42 UTC

Nope, it still has these big gaps between title bar, menu bar and the file windows after closing and re-opening. As you suggested DpiPerScreen=0 helped to restore the 9.0a behaviour in 9.10, i.e. a bit blurry but no gaps.

I somehow think some bug was introduced with the Fall Creators Update when it comes to custom scaling at 120%, e.g. my action center shows only 3 quick actions per line with a gap on the right side, instead of 4: https://i.imgur.com/WHLYI3p.jpg

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-11-13, 16:22 UTC

Can you let me know the screen size and scaling of the target system (not the laptop), e.g. 1920x1080 with 125% scaling?
Author of Total Commander
http://www.ghisler.com

argh0815
Junior Member
Junior Member
Posts: 8
Joined: 2016-11-24, 17:42 UTC
Location: Singapore

Post by *argh0815 » 2017-11-13, 16:27 UTC

I tried with two different target systems, both of them showing the same symptom:
System A: 2560x1440 with 100% scaling
System B: 1920x1200 with 100% scaling

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-11-14, 16:36 UTC

Thanks, I could reproduce it! It's a bug in Windows 10 itself when displaying the main menu.

You can see a similar bug in notepad.exe - the menu bar is only 1 pixel high, the same as in TC 32-bit. Both use normal, not owner-drawn menu.

In TC 64-bit, which uses owner-drawn menu bar, the bar is >2500 pixels high, although Total Commander reports the correct menu item sizes!

You can turn off custom scaling by setting
DpiPerScreen=0
as described above. I will try to switch to this mode automatically when detecting the bug.
Author of Total Commander
http://www.ghisler.com

argh0815
Junior Member
Junior Member
Posts: 8
Joined: 2016-11-24, 17:42 UTC
Location: Singapore

Post by *argh0815 » 2017-11-15, 10:34 UTC

Thanks for the thorough investigation, much appreciated!

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-11-16, 16:51 UTC

I have now made the following changes in RC4 when DpiPerScreen=1 is enabled:
1. When TC 32-bit or 64-bit is launched during the remote session, it will launch as if DpiPerScreen=0 were set.

2. When TC 64-bit is launched locally and then the user connects via remote session, TC 64-bit will launch another copy of itself and close - if no file operation is active or dialog box is open. Otherwise it will show a warning to the user that he should restart Total Commander.
Author of Total Commander
http://www.ghisler.com

argh0815
Junior Member
Junior Member
Posts: 8
Joined: 2016-11-24, 17:42 UTC
Location: Singapore

Post by *argh0815 » 2017-11-17, 02:23 UTC

Works like a charm, thanks!

Post Reply