No more sound played when saving file edited from FTP

English support forum

Moderators: white, sheep, Hacker, Stefan2

Post Reply
Stv
Junior Member
Junior Member
Posts: 4
Joined: 2015-04-16, 14:17 UTC

No more sound played when saving file edited from FTP

Post by *Stv » 2018-07-06, 01:55 UTC

I tend to edit files live on a server a lot by going to the file, hitting F4, editing the file, then saving the file and letting Total Commander automatically upload and overwrite the edited file (introduced in 8.50). In the previous version I had installed (9.10?), this would be accompanied by a sound being played if Total Commander was not the foreground application, equivalent to the 'Windows Background.wav' sound.

After updating to 9.20, this file is no longer played. I did go into the sound settings in Control Panel (aside: not a fan of Microsoft's desires that developers would use this - anything that takes you out of native config is jarring) and tried to setup both 'Total Commander > Copy/Move complete' and 'Transfer complete'.
Neither ends up playing the sound.

Copy/Move does affect file copy/move locally, which I promptly disabled again.
Transfer does affect copying a file from local to the FTP server, but definitely not when edit->save->auto-upload.

Did I miss a (new) setting somewhere? The change log doesn't seem to suggest anything new in this area.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36500
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-07-06, 13:19 UTC

Thanks for your report. I can confirm that there is no more beep in this case. It's not an intentional change. I will check what the problem is.
Author of Total Commander
http://www.ghisler.com

Stv
Junior Member
Junior Member
Posts: 4
Joined: 2015-04-16, 14:17 UTC

Post by *Stv » 2018-07-06, 22:11 UTC

Thank you for looking into this, appreciate it :)

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36500
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-07-08, 09:31 UTC

The problem is apparently that all dialog boxes now have the WS_POPUP style, and then GetActiveWindow returns the dialog even when the dialog is in the background. It seems to work when using GetForegroundWindow, though.
Author of Total Commander
http://www.ghisler.com

iztoks
Junior Member
Junior Member
Posts: 2
Joined: 2018-07-11, 20:46 UTC

Missing beep after automatically re-upload changed files

Post by *iztoks » 2018-07-11, 21:04 UTC

Hello,

after TC upgrade from 9.1 to 9.2 there is no more beep sound after I save file and TC automatically re-uploads it to server. It's same on WIN 10 and WIN 7 computer. I'm using external editor to edit files and re-upload them via FTP/SFTP. I have tried custom sounds options without success. It was working fine until this upgrade.

Is this a bug or I'm missing something?

Thank you.

User avatar
tuska
Power Member
Power Member
Posts: 1258
Joined: 2007-05-21, 12:17 UTC

Post by *tuska » 2018-07-11, 21:25 UTC

Hi,
The forum search for "beep" brings the following post:
No more sound played when saving file edited from FTP

User avatar
Hacker
Moderator
Moderator
Posts: 11041
Joined: 2003-02-06, 14:56 UTC
Location: Bratislava, Slovakia

Post by *Hacker » 2018-07-11, 21:37 UTC

Message from moderator

Merged thread Missing beep after automatically re-upload changed files.

Hacker (Moderator)
Mal angenommen, du drückst Strg+F, wählst die FTP-Verbindung (mit gespeichertem Passwort), klickst aber nicht auf Verbinden, sondern fällst tot um.

iztoks
Junior Member
Junior Member
Posts: 2
Joined: 2018-07-11, 20:46 UTC

Post by *iztoks » 2018-07-12, 14:48 UTC

ghisler(Author) wrote:The problem is apparently that all dialog boxes now have the WS_POPUP style, and then GetActiveWindow returns the dialog even when the dialog is in the background. It seems to work when using GetForegroundWindow, though.
Is there anything we can do by ourselves to enable this feature? Any ETA for fix in future releases? :)

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36500
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-07-13, 09:54 UTC

No you can't, sorry. I'm working on a TC 9.21 now, but I'm still gathering bug reports.
Author of Total Commander
http://www.ghisler.com

User avatar
petermad
Power Member
Power Member
Posts: 8055
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: No more sound played when saving file edited from FTP

Post by *petermad » 2018-07-26, 13:28 UTC

History wrote:08.07.18 Fixed: There was no more beep when foreground file operation ended while the main window was in the background (e.g. re-upload when editing) (32/64)
Confirmed fixed in TC 9.21rc1 :)
License #524
Danish Total Commander Translator
TC 9.21a 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit and TC 2.92b1 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36500
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: No more sound played when saving file edited from FTP

Post by *ghisler(Author) » 2018-07-29, 06:49 UTC

Great, thanks!
Author of Total Commander
http://www.ghisler.com

Post Reply