LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

Post Reply
deesar
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-04, 17:17 UTC

LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *deesar »

Hi to all,
I have a strange problem accessing shares on win 10.
With my old smartphone Samsung S8 (Android 9) it works perfect (since years).
With my new Samsung S10 (Android 10) it don't work.
After one minute I'll get a timeout exception.

Regardless if I use ip or dns name.

Both phones same current version of TC and LAN Plug in installed.

Any idess?

Thank You

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39117
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *ghisler(Author) »

Unfortunately none of my phones (including the S10e) has received Android 10 yet, so I cannot test this. It works fine in the emulator, though.

Maybe you have disabled background data?
Author of Total Commander
http://www.ghisler.com

deesar
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-04, 17:17 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *deesar »

Thank you for the reply,
unfortunately background data was enabled and that was not the cause. I tried some other smb apps and I can't get any of them to work on the s10 with pie, so it must have something to do with Samsung or android pie.

Thx anyway for the good app 👍

Greets Bernd

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39117
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *ghisler(Author) »

My Galaxy S10e has just received Android 10! However, the lan plugin works just fine, no timeout even after 10 minutes.
It's strange that it works with my S10e but not your S10. Maybe I just tried the wrong steps?
Author of Total Commander
http://www.ghisler.com

modelno1
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-14, 10:02 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *modelno1 »

The plugin doesn't work for me on Android 10 either. I can log in, browse, copy to lan share (I gen an error in the copy window, socket something something, but the file gets copied correctly) but I can't copy from lan share to phone. I get "problem reading file" splash and a 0 kb file locally. If I try to browse lan share after that, the first time I try to open folder I get "j has already been closed" error, but if I tap on the folder again it opens normally.
Running fully updated TC and plugin on Honor View 20 (Android 10 with October security updates).

deesar
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-04, 17:17 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *deesar »

I've found the solution, in wifi settings of the connected network there is an option "Mac Address Type" this was set to "phone mac" by default. Switching this option to "random generated mac" restored the smb functionality in Total Commander.

Thank you all for your support.

modelno1
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-14, 10:02 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *modelno1 »

I don't have any MAC address settings for WiFi, so I can't verify.

modelno1
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-14, 10:02 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *modelno1 »

Joined beta programs for TC and plugin, updated, seems to work now.

Post Reply