TC does not handle soft links correctly

English support forum

Moderators: white, Hacker, petermad, Stefan2

Post Reply
Nop
Junior Member
Junior Member
Posts: 18
Joined: 2006-06-28, 11:01 UTC

TC does not handle soft links correctly

Post by *Nop »

Version: TC 11.02 x64

Reproducible behaviour. TC does not recognize soft links.

1. Create a soft link to a folder with mklink /D
2. Move softlink
=> TC will not move the softlink itself, but all the files in the linked folder

The same is true for copy operations and - quite dangerously - for delete.

Executing the same operations with Explorer moves/copies/deletes the links correctly.
User avatar
Horst.Epp
Power Member
Power Member
Posts: 6379
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: TC does not handle soft links correctly

Post by *Horst.Epp »

What about reading the forum or the help before posting an error ?
From the help
IgnoreLinks=0 Allows you to ignore hard links (junctions, reparse points) to directories in various functions.
Note: The function "Synchronize dirs" uses a separate option "SyncIgnoreJunctions".
Sum of:
1: copy/move/calculate occupied space
2: internal packers (zip, tar)
4: branch view
8: find files (except when using Everything), re-scan tree
16: ignore links even when they are selected in the current directory. Otherwise only links in selected subdirectories are ignored.

My setting
IgnoreLinks=15
Windows 11 Home x64 Version 23H2 (OS Build 22631.3155)
TC 11.03 x64 / x86
Everything 1.5.0.1367a (x64), Everything Toolbar 1.3.2, Listary Pro 6.3.0.63
QAP 11.6.2.3.2 x64
Nop
Junior Member
Junior Member
Posts: 18
Joined: 2006-06-28, 11:01 UTC

Re: TC does not handle soft links correctly

Post by *Nop »

Horst.Epp wrote: 2024-02-12, 18:09 UTC What about reading the forum or the help before posting an error ?
Searched the forum of course, found only some discussion about whether TC could create soft links.

Thanks for the help, but not for the tone.

I tried it, but that suggestion is missing the mark. Now TC totally ignores the links.
I need to move/copy/delete them, not skip them altogether.
Last edited by Nop on 2024-02-12, 20:07 UTC, edited 1 time in total.
User avatar
Dalai
Power Member
Power Member
Posts: 9289
Joined: 2005-01-28, 22:17 UTC
Location: Meiningen (Südthüringen)

Re: TC does not handle soft links correctly

Post by *Dalai »

I've never had issues deleting junctions or moving them within the same volume/partition. For symlinks the deletion should be possible in the same way. In regards to copying (and moving to a different volume), well, by default, TC copies the link's target. But there's the setting CopyLinks which controls whether or not the link or target should be copied; see TC help, section 4.b for more information.

Keep in mind though that creating symlinks requires administrative privileges! TC's admin tool should be able to handle that, but since I don't use symlinks (only junctions and hardlinks) I can't really tell if and how well that works. However, one thing is certain: When copying links or moving them to a different volume, TC won't create any links unless CopyLinks is set to a value of >=1. Deletion should work regardless.

Regards
Dalai
#101164 Personal licence
Ryzen 5 2600, 16 GiB RAM, ASUS Prime X370-A, Win7 x64

Plugins: Services2, Startups, CertificateInfo, SignatureInfo, LineBreakInfo - Download-Mirror
Nop
Junior Member
Junior Member
Posts: 18
Joined: 2006-06-28, 11:01 UTC

Re: TC does not handle soft links correctly

Post by *Nop »

Thank you, CopyLinks=1 was exactly what I was looking for.
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 47893
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TC does not handle soft links correctly

Post by *ghisler(Author) »

Moderator message

Moved to English forum
Author of Total Commander
https://www.ghisler.com
Post Reply