New SFTP plugin available now

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: sheep, Hacker, Stefan2, white

Post Reply
CoolWater
Power Member
Power Member
Posts: 676
Joined: 2003-03-27, 16:33 UTC

Re: New SFTP plugin available now

Post by *CoolWater »

Please check your sshd_config for the following entry:
PermitRootLogin yes

If this entry is missing, then add it. Otherwise, change no to yes.

By default, this seems to be disabled for /usr/lib/openssh/sftp-server.

There should also be an entry AllowUsers. Add root to the list.

HTH
CoolWater

Mantigora
Junior Member
Junior Member
Posts: 5
Joined: 2012-12-02, 18:11 UTC

Re: New SFTP plugin available now

Post by *Mantigora »

Hi Coolwater, thanks for your quick reply.

I did what you suggested, both PermitRootLogin yes and AllowUsers root , but it makes no difference.
Ofcourse, I restarted the ssh-service also.
As I said, it is not that I can not log in with root, using the /usr/lib/openssh/sftp-server, I can just fine with e.g. PuTTY, just not with TC.

It was an interesting idea that root would need to be added to the AllowUsers, for /usr/lib/openssh/sftp-server, but alas.

I am upgrading an older server, still running Debian Linux 8, where Subsystem sftp /usr/lib/openssh/sftp-server still works OK with TC.
This is why I thought of giving this another try, to get fixed.
Perhaps another solution might appear, hopefully.

User avatar
Dalai
Power Member
Power Member
Posts: 6975
Joined: 2005-01-28, 22:17 UTC
Location: Meiningen (Südthüringen)

Re: New SFTP plugin available now

Post by *Dalai »

2Mantigora
I suggest to try WinSCP, with a connection set explicitely to SFTP transfer mode. If that fails, it's a problem on the server side. Also, looking at /var/log/syslog and /var/log/auth.log on the server is always a good idea to find out what's wrong.

Regards
Dalai
#101164 Personal licence
Ryzen 5 2600, 16 GiB RAM, ASUS Prime X370-A, Win7 x64

Plugins: Services2, Startups

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39427
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: New SFTP plugin available now

Post by *ghisler(Author) »

PuTTY makes a raw SSH session. This seems to work with my plugin too, just starting the SFTP session within the SSH connection fails.
As an alternative, check the two SCP options (SCP for transfers and SCP for everything). This way no SFTP subsystem will be needed.
Author of Total Commander
http://www.ghisler.com

Mantigora
Junior Member
Junior Member
Posts: 5
Joined: 2012-12-02, 18:11 UTC

Re: New SFTP plugin available now

Post by *Mantigora »

@Dalai
Thanks for your reply.
WinSCP seems to be more useful because it gives more info in the logs:


. 2020-03-27 17:05:25.441 Attempt to close connection due to fatal exception:
* 2020-03-27 17:05:25.441 Received too large (1315905619 B) SFTP packet. Max supported packet size is 1024000 B.
* 2020-03-27 17:05:25.441
* 2020-03-27 17:05:25.441 The error is typically caused by message printed from startup script (like .profile). The message may start with "No S".
. 2020-03-27 17:05:25.441 Closing connection.

I removed the .profile but that made no difference.
So, the problem is indeed serverside.
I wonder what kind of error is the reason of a packet of 1,3 GB!
I will take this somewhere else, since it is not TC-related.
Thank you all.

Mantigora
Junior Member
Junior Member
Posts: 5
Joined: 2012-12-02, 18:11 UTC

Re: New SFTP plugin available now

Post by *Mantigora »

@ghisler
Thanks for replying.
I did what you suggested, the use of the 2 SCP options works indeed fine!
Still, I wonder why only the root-account has this problem and not the other accounts.
The old /usr/lib/openssh/sftp-server of debian 8 or 7 did not have this problem.

Anyway, thanks for making the most useful software I have ever bought :)

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39427
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: New SFTP plugin available now

Post by *ghisler(Author) »

My guess is that the server sends a big fat warning that you should never login with a root account, to make hacking harder.
Author of Total Commander
http://www.ghisler.com

Post Reply