This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Timezones and file time when FTP uploading
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Total Commander Forum Index -> TC7.5x(a) final bug reports (English) Printable version
View previous topic :: View next topic  
Author Message
Sob
Power Member
Power Member


Joined: 19 Jan 2005
Posts: 908

PostPosted: Wed Apr 21, 2010 2:18 pm    Post subject: Reply with quote

You may also try with SetEnv one more time and after editing the config and before rebooting, run:
Code:
/etc/init.d/ftp.sh reconfig

Some instructions on QNAP wiki (http://wiki.qnap.com) for changing other settings mention this command. It sounds that it should make the changes stay.
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35761
Location: Switzerland

PostPosted: Thu Apr 22, 2010 10:06 am    Post subject: Reply with quote

The LIST command uses local time, so you will see a time zone difference if your PC and the NAS don't use the same time zone (or LIST reports incorrect values).

Currently the only way to correct this is "synchronize dirs". You can set a time zone difference there.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
rhulsegge
Junior Member
Junior Member


Joined: 11 Apr 2010
Posts: 8
Location: The Netherlands

PostPosted: Thu Apr 22, 2010 2:37 pm    Post subject: Reply with quote

2Ghisler:
I checked PC, notebook, router and NAS: are all set to the same timezone.

2Sob:
I added the SetEnv code again in the proftpd.conf file
Then I opened a connection with putty and entered the reconfig command you suggested.
Putty answered:
Reconfigure FTP dervices:
reconfig ftp success

Then I restarted the QNAP from within the System Administration\Power Management page.

But... the proftpd.config file was overwritten again and the SetEnv line was gone again...

I searched the QNAP folders with SFTP to see if I could find another instance of the proftpd.conf file, but I didn't find anything.
Back to top
View user's profile Send private message
Sob
Power Member
Power Member


Joined: 19 Jan 2005
Posts: 908

PostPosted: Thu Apr 22, 2010 7:15 pm    Post subject: Reply with quote

ghisler(Author): The problem here is that it's not consistent, not all times are wrong, only those from DST period are. The file from December has correct time, but file from June has time shifted by an hour. By shifting time in "synchronize dirs" you fix the wrong ones and break the correct ones. But I don't think this can be reliably solved in TC.

rhulsegge: I checked the ftp.sh script and "reconfig" doesn't actually save settings, but makes FTP daemon reload them from config file. So you can use it to check if the change to config did something. Saving settings must be done in some other way. But I'm out of ideas.
Back to top
View user's profile Send private message Send e-mail
andres992
Member
Member


Joined: 12 Apr 2006
Posts: 123

PostPosted: Sat Nov 05, 2011 7:09 am    Post subject: Reply with quote

I am having the same trouble with my NAS (Smartstor NS2300N), which also uses proftpd.

My timezone is GMT+02:00 in winter. But now, in the winter time, TC shows uploaded files in GMT (e.g. I uploaded file at 14:00 but TC shows 12:00).

When I view the file in Windows Explorer's FTP, the file time is correct (14:00). When I view the file in FileZilla, it also seems that the correct time is shown (14:00). From FileZilla log:

Code:
Command:   LIST
Response:   150 Opening ASCII mode data connection for file list
Response:   226 Transfer complete.
Status:   Calculating timezone offset of server...
Command:   MDTM x.txt
Response:   213 20111105125955
Status:   Timezone offsets: Server: 0 seconds. Local: 7200 seconds. Difference: 7200 seconds.


It does not matter whether I have MLSD on or off in TC. TC still shows 12:00. The NAS I have does not support MLSD — but nevertheless I would like to have correct time for files. Hence it seems that TC is not actually calculating the timezone offset. Could I propose that TC should start calculating "timezone offsets" as several other pieces of FTP software already seem to do?
_________________
#68776 Personal Licence
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC7.5x(a) final bug reports (English) All times are GMT - 6 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group