FTP servers stop responding after MLSD command

English support forum

Moderators: Hacker, Stefan2, white

Post Reply
moverman
Junior Member
Junior Member
Posts: 4
Joined: 2010-06-17, 22:55 UTC

FTP servers stop responding after MLSD command

Post by *moverman »

Apparently many sites still use older versions of PureFTPd, with a problem related to the MLSD command. These sites stop responding completely, which makes it impossible to establish a connection with TC 7.55.
An option "always use LIST" would be highly appreciated in a future version! Meanwhile, I'll have to go back to an earlier one...
Sob
Power Member
Power Member
Posts: 923
Joined: 2005-01-19, 17:33 UTC

Post by *Sob »

Just open FTP connection properties, select Advanced tab and uncheck Use MLSD for directory listings.
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 44233
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

Can you give me an example of a public site using such an old version of PureFTPd? You can contact me at support at ghisler dot com if you cannot make it public. I will use it purely for test purposes.
Author of Total Commander
https://www.ghisler.com
moverman
Junior Member
Junior Member
Posts: 4
Joined: 2010-06-17, 22:55 UTC

Post by *moverman »

Thanks for responding both so quickly. I overlooked the option to uncheck MLSD, sorry for that. Regarding Ghisler's request for an example, I met this problem with some of my shared hosting accounts on U.S. based hosting company GoDaddy - not with public sites (yet).
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 44233
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

Are you sure that it's MLSD's fault? TC uses it only when the ftp server announces (in reply to the FEAT command) that it fully supports MLSD.

Maybe it's a problem with active vs. passive mode?
Author of Total Commander
https://www.ghisler.com
moverman
Junior Member
Junior Member
Posts: 4
Joined: 2010-06-17, 22:55 UTC

Post by *moverman »

I think I have to appologize for the second time... It was indeed the combination of MLSD and the active mode (which works fine with the LIST command). Switching over to passive mode did the trick. Thanks!
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 44233
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

I see, so it's probably a problem with your Internet router/firewall which doesn't know MLSD and doesn't allow the ports through...
Author of Total Commander
https://www.ghisler.com
moverman
Junior Member
Junior Member
Posts: 4
Joined: 2010-06-17, 22:55 UTC

Post by *moverman »

Bingo! Zonealarm 8.0.298.000 was causing this. The problem with a mostly fine working firewall is that you would almost forget that you've got one. I should have shut it down in the first place before blaming PureFTPd.
gisarb
New Member
New Member
Posts: 1
Joined: 2011-08-24, 12:19 UTC

Post by *gisarb »

Anyway I got flash fxp working, I changed it to not use passive.
Post Reply