uLister

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: white, sheep, Hacker, Stefan2

Post Reply
Dworkin
Junior Member
Junior Member
Posts: 2
Joined: 2018-04-04, 15:15 UTC
Location: Netherlands

Post by *Dworkin » 2018-04-05, 08:09 UTC

2Ovg
Thank you for the help, it works

teeceeuser
Junior Member
Junior Member
Posts: 33
Joined: 2018-06-21, 15:06 UTC

Post by *teeceeuser » 2018-06-29, 20:04 UTC

I would appreciate some help in getting the plugin to work.

I'm running TC 32-bit which I installed in c:\Program Files\totalcmd combined with the 64-bit version.

I installed ulister plugin (32-bit version) in the ...totalcmd\plugins\wlx\ulister subdirectory and inside the wlx subdirectory I copied the redist folder that has all the dll files (...plugins\wlx\ulister\redist).

I didn't change anything in the ulister.ini file. It is as installed.

Having done the above by pressing F3 I cannot view PDF files, Libre Office files (.ods, .odt) or MS Office files (Office 2013 or 2016). What I see is a Lister window which is undecipherable.

User avatar
Ovg
Power Member
Power Member
Posts: 555
Joined: 2014-01-06, 16:26 UTC
Location: MOW

Post by *Ovg » 2018-06-30, 06:35 UTC

IIRC Microsoft Visual C++ 2013 Redistributable required for plugin to work
It's impossible to lead us astray for we don't care even to choose the way.
#259941, TC 9.21a x64, Windows 7 SP1 x64

teeceeuser
Junior Member
Junior Member
Posts: 33
Joined: 2018-06-21, 15:06 UTC

Post by *teeceeuser » 2018-06-30, 06:48 UTC

Ovg wrote:IIRC Microsoft Visual C++ 2013 Redistributable required for plugin to work
Thank you. I'll install it. I presumed that it came already installed with Windows 10! :)

User avatar
Ovg
Power Member
Power Member
Posts: 555
Joined: 2014-01-06, 16:26 UTC
Location: MOW

Post by *Ovg » 2018-06-30, 06:50 UTC

2teeceeuser
for https://ghisler.ch/board/viewtopic.php?p=324284#324284 I have to install Microsoft Visual C++ 2013 Redistributable on Windows 8
It's impossible to lead us astray for we don't care even to choose the way.
#259941, TC 9.21a x64, Windows 7 SP1 x64

teeceeuser
Junior Member
Junior Member
Posts: 33
Joined: 2018-06-21, 15:06 UTC

Post by *teeceeuser » 2018-06-30, 13:33 UTC

Thank you for your help. I saw the particular posting, but I didn't know that I had to install it on my PC which runs Windows 10.

Following your advice, I initially tried it with Microsoft Visual C++ 2017 (both 32-bit and 64-bit) assuming that this would be a newer version, but it didn't work. Installing the 2013 32-bit version appears to have solved the problem.

teeceeuser
Junior Member
Junior Member
Posts: 33
Joined: 2018-06-21, 15:06 UTC

Post by *teeceeuser » 2018-07-03, 19:31 UTC

I thought I should mention that one annoyance remains: I have to run TC as Administrator in order for the plugin to work.

User avatar
Ovg
Power Member
Power Member
Posts: 555
Joined: 2014-01-06, 16:26 UTC
Location: MOW

Post by *Ovg » 2018-07-04, 03:04 UTC

I haven't Win10, sorry

I haven't such problem on Win7 ... or Win8
It's impossible to lead us astray for we don't care even to choose the way.
#259941, TC 9.21a x64, Windows 7 SP1 x64

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3105
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Post by *Horst.Epp » 2018-07-04, 07:22 UTC

Ovg wrote:I haven't Win10, sorry

I haven't such problem on Win7 ... or Win8
I have Windows 10 and there is no such problem with ULister.
I guess the installation was made in some strange way using the admin account and now he tries to use it under a normal account.
Windows 10 Home x64 October 2018 Update
Version 1809 (OS Build 17763.134)
TC 9.21a x64 and x86, Everything 1.4.1.921 (x64)

teeceeuser
Junior Member
Junior Member
Posts: 33
Joined: 2018-06-21, 15:06 UTC

Post by *teeceeuser » 2018-07-04, 12:38 UTC

Total Commander (both 32-bit and 64-bit) is installed in c:\program files\totalcmd and ulister in a plugins directory inside it. I use a standard user account for my daily work and therefore I had to install TC using an admin account. Similarly I had to install the MS Visual C++ redistributable as admin.

EDIT: All access problems are solved if I install TC in a directory under C:\ drive. I wonder though if I lay myself open to any vulnerabilities. The installation (as a standard user) did not require me to use an Administrator account (as it would have done if I tried to install it in c:\Program Files).

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3105
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: uLister

Post by *Horst.Epp » 2018-10-08, 13:12 UTC

Oracle has updated the Viewer Technology and Content Access files to version 8.5.4
Dated 09/27/2018
Windows 10 Home x64 October 2018 Update
Version 1809 (OS Build 17763.134)
TC 9.21a x64 and x86, Everything 1.4.1.921 (x64)

User avatar
tuska
Power Member
Power Member
Posts: 1258
Joined: 2007-05-21, 12:17 UTC

Re: uLister

Post by *tuska » 2018-10-08, 16:10 UTC

Horst.Epp wrote:
2018-10-08, 13:12 UTC
Oracle has updated the Viewer Technology and Content Access files to version 8.5.4
Dated 09/27/2018
Thank you for telling us!

Regards
Karl

fc62
Junior Member
Junior Member
Posts: 44
Joined: 2007-02-06, 16:30 UTC

Preview Files Very Slow With Ulister

Post by *fc62 » 2018-11-03, 19:00 UTC

I have already place a post in TC Forum but without found the solution and so I try to post the same question here.
I installed total commander on a new PC and I set the same configuration I've been using for years. (Same wincmd.ini file and same addon configuration).
Unfortunately I’m facing a problem with previewing files with “ulister” plugin: the software freezes and I have to wait several minutes for the preview to appear. This happens with both F3 and Ctrl + Q.
I tried to install the software several times, but I did not solve the problem.
Initially, after several attempts I decided to restore Windows and reinstall everything from 0 and then TC worked perfectly and also Ulister.
Unfortunately, after some time, the problem of very slow preview of files with Ulister has reappeared again without having done any kind of intervention on the PC. Until last week everything was perfect and suddenly the problem has reappeared again. I had an image copy of the hard disk C of 10 days ago and I installed it but incredibly the problem has not been solved. It seems therefore that the problem is not related to a setting of the PC. Then I tried to disconnect the PC from the internet via wireless and the problem was solved immediately, but as soon as I reconnected the wireless the problem occurred again (Only with Ulister).
The strange thing is that I'm connected to a home wireless line that has been the same for months and I can't explain what differences there may be between last week and today. Anyway, it seems that the problem is related only to some kind of internet connection: I’m using the PC also in my company and with the wireless in my office the problem disappear.
I also add another symptom: if in a directory I have many files, only the first one selected takes a long time to show the preview, after which all the others are very fast. However, if I go out and go back to the directory or change directory, the problem reoccurs.
I have also tried to disable the antivirus (First Bitedefender and then Windows Defender) but without solve the problem and I'm not sure that it's an antivirus problem, because I didn't make any variation on the antivirus software, so it's not explained why the problem occurs suddenly without any external intervention.
Initially I thought that there was a software or some other kind of conflicting control, maybe some Windows setting (Despite the fact that I use the same configuration of TC, same as wincmd.ini files in at least four different computers and have never encountered this kind of problem), but now, since the problem seems also to be related to the internet connection, I don’t really know what to check.
Which iterations there are between Ulister and the setting of Internet connection? Any other suggestions on what to check?
Moreover, I use Ulister to display mainly only some types of files (pdf, msg, and all those of the office package); can I try to set the setting of Ulister on a limited number of extensions? Will it benefit me?
I'm using Windows 10 Pro 10.0.17134 build 17134
It's very important for me as I use TC for my job and the previewing of the files is extremely useful
Thanks for your help!!!

Post Reply