[Solved] Thumbs.db can't be deleted

Please report only one bug per message!

Moderators: white, sheep, Hacker, Stefan2

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

[Solved] Thumbs.db can't be deleted

Post by *foxidrive » 2013-05-18, 06:32 UTC


The problem in this thread was due to a plugin in Total Commander and is solved by disabling this plugin:

CDBFVIEW 1.20

CDBFview - is a plugin for Total Commander (http://www.ghisler.com)
It allows you to view DBF files in Lister's window (Also in Quick View Panel).




TC 8.01 32 bit under Win8

I try and delete Thumbs.db and a Windows 8 dialog pops up which says:

The action can't be completed because the file is open in Total Commander 32


Maybe it is pointless trying to delete these but I was just curious if it was a bug or some Win 8 curiosity.
Last edited by foxidrive on 2014-05-22, 15:40 UTC, edited 1 time in total.

umbra
Power Member
Power Member
Posts: 783
Joined: 2012-01-14, 20:41 UTC

Post by *umbra » 2013-05-18, 07:02 UTC

Sorry, I can't confirm this. I use Win8 and TCx32 daily and I can delete these files without any error. (The warning dialog about a system file is not always correct, but that's for another bug report.)
Windows 7 Pro x64, Windows 8.1 Pro x64, Windows 10 Pro x64

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

Post by *foxidrive » 2013-05-18, 07:14 UTC

Are you using 64 bit Windows, as your sig suggests? Maybe that is a factor.

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

Post by *foxidrive » 2013-05-18, 07:25 UTC

umbra wrote:(The warning dialog about a system file is not always correct, but that's for another bug report.)
I should add that the dialog is in the next window when you confirm that you want to delete the file.

umbra
Power Member
Power Member
Posts: 783
Joined: 2012-01-14, 20:41 UTC

Post by *umbra » 2013-05-18, 07:28 UTC

Can you delete them with Explorer? And does it happen only with these files or others too?

From discussions on the Internet, it seems that it can be caused by 3rd party appllications that provide thumbnails (Adobe Reader, Picasa, ...).

A general suggestions is to reinstall the culprit (if you can find it) which "might" fix it. The other, more drastic and successful, solution is to forbid creation of Thumbs.db files completely. Windows doesn't use them anymore, they are created only for very old apps that might need them.
Windows 7 Pro x64, Windows 8.1 Pro x64, Windows 10 Pro x64

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

Post by *foxidrive » 2013-05-18, 07:42 UTC

umbra wrote:Can you delete them with Explorer? And does it happen only with these files or others too?
Yes, Explorer was able to delete the file.
I haven't seen the issue with any other filetype.

I use Irfanview to view graphics, and no other graphics programs are in normal use.

umbra
Power Member
Power Member
Posts: 783
Joined: 2012-01-14, 20:41 UTC

Post by *umbra » 2013-05-18, 07:43 UTC

2foxidrive
Are you using 64 bit Windows
Yes, I am. But I often work with 32b editions as well.
I should add that the dialog is in the next window when you confirm that you want to delete the file.
My issue is not relevant here, maybe I shouldn't have mentioned it at all.
Windows 7 Pro x64, Windows 8.1 Pro x64, Windows 10 Pro x64

umbra
Power Member
Power Member
Posts: 783
Joined: 2012-01-14, 20:41 UTC

Post by *umbra » 2013-05-18, 07:52 UTC

One experiment:
Open your wincmd.ini, and add "VistaDelete=0" to the "[Configuration]" section. If you have VistaDelete there already, configure it to "0". Restart TC and try to delete the file now.
Windows 7 Pro x64, Windows 8.1 Pro x64, Windows 10 Pro x64

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

Post by *foxidrive » 2013-05-18, 08:13 UTC

I will do that umbra - I can't figure out what is creating the thumbs.db as they haven't come back in the two spots I normally see them after deleting them with Explorer (I have also rebooted).

When they return I will try your suggestion. Ta.

Vulpix
Junior Member
Junior Member
Posts: 15
Joined: 2013-05-15, 18:06 UTC

Post by *Vulpix » 2013-05-18, 08:20 UTC

Windows is generating the thumbs.db file automatically every time you view the said folder in explorer - it contains thumbnails of files (mostly pictures) inside the folder; it is so that windows doesn't have to open the files and create a thumbnail every time you view that folder (which could be very time consuming for big folders with lots of photos, for example).

If you're bothered by the thumbs.db (and like me, you prefer to have total commander display hidden files), you can put the thumbs.db on the total commander ignore list in configuration=>options=>ignore list.

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

Post by *foxidrive » 2013-05-18, 08:29 UTC

I've found that viewing the folder in Explorer created the thumbs.db but it's not reproducible.

Anyway, I also found that after removing the system and hidden attributes in TC it allowed me to delete the file.

This is without the 'VistaDelete=0' in the ini file.

Thanks for your suggestions Vulpix

umbra
Power Member
Power Member
Posts: 783
Joined: 2012-01-14, 20:41 UTC

Post by *umbra » 2013-05-18, 08:41 UTC

2Vulpix
Beginning with Vista, Windows doesn't use these files anymore. It uses them only in special cases, like on network drives. On my computer, they appear only when I use Firefox to download something. But I don't know why.

2foxidrive
It should work even without removing of those attributes, but at least you have some kind of a workaround.
Windows 7 Pro x64, Windows 8.1 Pro x64, Windows 10 Pro x64

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

Post by *foxidrive » 2013-05-18, 08:51 UTC

umbra wrote: 2foxidrive
It should work even without removing of those attributes, but at least you have some kind of a workaround.
Windows thinks they are open in TC so why does this change when TC simply removes the hidden attribute? I left the system one on in my second test - will test further when they reappear.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36425
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2013-05-20, 12:56 UTC

Try to delete them with Shift+Del (bypassing the recycle bin).
Author of Total Commander
http://www.ghisler.com

foxidrive
Junior Member
Junior Member
Posts: 90
Joined: 2004-02-28, 11:50 UTC

Post by *foxidrive » 2013-05-20, 13:58 UTC

They haven't returned yet. I did change an explorer setting (several weeks ago) that was meant to stop them appearing - yet they have returned on occasion.

I restored the explorer setting and they have since reappeared.

So in TC when I use SHIFT DEL it makes the issue happen where it says the file is open in TC.

If I press DEL alone the file is deleted ok.

From a CMD prompt this deletes the file with no prompts: del thumbs.db /a

I added VistaDelete=0 to the configurations settings and then shift del worked to delete the file.

I removed VistaDelete=0 and restarted TC and shift del STILL deletes the file.

It's erratic in the behaviour. :x

Post Reply