Filetype icon displays correct in 32bit, not in 64bit TC

Please report only one bug per message!

Moderators: Stefan2, white, sheep, Hacker

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Filetype icon displays correct in 32bit, not in 64bit TC

Post by *NordicAlbino » 2013-11-20, 14:49 UTC

I created a file with an extension of .--- and associated a specific icon for that kind of filetype.

PROBLEM: The newly created associated icon shows well and correct in the TC-32bit version, but not in the TC-64bit version where it is shown like a default light blue icon ...
Gudene Må Være Gale... | #67047 - 2 User licences

User avatar
MVV
Power Member
Power Member
Posts: 8087
Joined: 2008-08-03, 12:51 UTC
Location: Russian Federation

Post by *MVV » 2013-11-20, 15:01 UTC

It seems that Windows registered this association in 32-bit section of registry... Does Windows Explorer show correct icon?

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Post by *NordicAlbino » 2013-11-20, 15:10 UTC

MVV wrote:It seems that Windows registered this association in 32-bit section of registry... Does Windows Explorer show correct icon?
Yes, he does.
Gudene Må Være Gale... | #67047 - 2 User licences

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2013-11-20, 17:29 UTC

What does TC x64 show when you go to menu Files - Associate and enter
---
there?

Either the 64-bit version doesn't see your extension, or there is a small error in the association which makes TC ignore the entry.
Author of Total Commander
http://www.ghisler.com

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Post by *NordicAlbino » 2013-11-20, 17:42 UTC

ghisler(Author) wrote:What does TC x64 show when you go to menu Files - Associate and enter
---
there?

Either the 64-bit version doesn't see your extension, or there is a small error in the association which makes TC ignore the entry.
TC x64 sees the extension and has associated it with the right application.
As I've already said, Windows Explorer and TC x32 show it correctly, only TC x64 doesn't ... :(
Gudene Må Være Gale... | #67047 - 2 User licences

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2013-11-20, 21:35 UTC

OK, then you will have to post parts of your registry, so I can recreate the problem:
1. Run regedit.exe
2. Go to HKEY_CLASSES_ROOT\.---
3. Choose File - Export - Only the selected branch
4. Post it here
5. Look at HKEY_CLASSES_ROOT\.--- and check what "default" contains. It is something like ---file or so
6. Go to that key, in this example HKEY_CLASSES_ROOT\---file
7. Choose File - Export - Only the selected branch
8. Also post it here
9. Also export the following key if it exists:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.---
Author of Total Commander
http://www.ghisler.com

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Post by *NordicAlbino » 2013-11-21, 08:18 UTC

This is the content of the exported REG-file:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.---]
@="---_auto_file"
"BrowserFlags"=dword:00000000
"EditFlags"=dword:00100000
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.---\DefaultIcon]
@="C:\\Program Files\\Total Commander\\Bar.ico,0"
Thanks in advance! I appreciate it. :)
Gudene Må Være Gale... | #67047 - 2 User licences

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2013-11-21, 14:11 UTC

Thanks, I will try it. The problem is probably "PerceivedType".
Author of Total Commander
http://www.ghisler.com

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Post by *NordicAlbino » 2013-11-21, 19:14 UTC

ghisler(Author) wrote:Thanks, I will try it. The problem is probably "PerceivedType".
I don't know for sure ... because I've tried some other types too ...
'Text' was the type I've used at last ...
Still I hope you're right.
Gudene Må Være Gale... | #67047 - 2 User licences

User avatar
MVV
Power Member
Power Member
Posts: 8087
Joined: 2008-08-03, 12:51 UTC
Location: Russian Federation

Post by *MVV » 2013-11-21, 19:18 UTC

NordicAlbino,
Please try to move your icon file to e.g. C:\ folder from C:\Program Files.

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Post by *NordicAlbino » 2013-11-22, 08:45 UTC

MVV wrote:NordicAlbino,
Please try to move your icon file to e.g. C:\ folder from C:\Program Files.
Yes! It works now! :D

Because it was in 'c:\Program Files\Total Commander\', I thought it was already in the right permissions scope.
Now I moved it to 'c:\Windows' as it seems a somewhat more better place, and it still keeps working.

Thank you very much for your time, your excellent support, and of course: the solution! :wink:

With kindly greetings,

NordicAlbino
Gudene Må Være Gale... | #67047 - 2 User licences

User avatar
MVV
Power Member
Power Member
Posts: 8087
Joined: 2008-08-03, 12:51 UTC
Location: Russian Federation

Post by *MVV » 2013-11-22, 09:13 UTC

You're welcome! :)

ghisler,
May it be some issue caused by mix Program Files and Program Files (x86)?

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36255
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2013-11-22, 10:44 UTC

2NordicAlbino
Unfortunately you didn't send all the necessary registry data - the following part was missing:

[HKEY_CLASSES_ROOT\.---_auto_file"]

I created it myself, and the icon showed up just fine in 32-bit and 64-bit even when in "Program files". Here is what I used:
[HKEY_CLASSES_ROOT\---_auto_file]
[HKEY_CLASSES_ROOT\---_auto_file\DefaultIcon]
@="C:\\Program Files\\Total Commander\\Bar.ico,0"

I wonder what you had there...
Author of Total Commander
http://www.ghisler.com

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Post by *NordicAlbino » 2013-11-22, 11:09 UTC

ghisler(Author) wrote:2NordicAlbino
Unfortunately you didn't send all the necessary registry data - the following part was missing:

[HKEY_CLASSES_ROOT\.---_auto_file"]

I created it myself, and the icon showed up just fine in 32-bit and 64-bit even when in "Program files". Here is what I used:
[HKEY_CLASSES_ROOT\---_auto_file]
[HKEY_CLASSES_ROOT\---_auto_file\DefaultIcon]
@="C:\\Program Files\\Total Commander\\Bar.ico,0"

I wonder what you had there...
I don't know ...
To check this I set it all back to its previous state and place (icon back in 'c:\Program Files\Total Commander') and it still keeps working now!
BTW: I use Nirsoft's FileTypeMan for that purpose.

But what I can see now (it wasn't there before!) is that its type is now changed to '---_auto_file'. Before that it was empty as far as I can remember.

This is the current situation:
---.reg

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.---]
@="---_auto_file"
"BrowserFlags"=dword:00000000
"EditFlags"=dword:00100000
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.---\DefaultIcon]
@="C:\\Program Files\\Total Commander\\Bar.ico,0"
---_auto_file.reg

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\---_auto_file]
@="Visual Delimiter Dummy File"
"EditFlags"=dword:00100000

[HKEY_CLASSES_ROOT\---_auto_file\DefaultIcon]
@="C:\\Windows\\Bar.ico,0"

[HKEY_CLASSES_ROOT\---_auto_file\shell]

[HKEY_CLASSES_ROOT\---_auto_file\shell\edit]

[HKEY_CLASSES_ROOT\---_auto_file\shell\edit\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
  54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,25,00,31,00,00,\
  00

[HKEY_CLASSES_ROOT\---_auto_file\shell\open]

[HKEY_CLASSES_ROOT\---_auto_file\shell\open\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,4e,00,4f,00,\
  54,00,45,00,50,00,41,00,44,00,2e,00,45,00,58,00,45,00,20,00,25,00,31,00,00,\
  00
Gudene Må Være Gale... | #67047 - 2 User licences

User avatar
NordicAlbino
Junior Member
Junior Member
Posts: 54
Joined: 2007-06-09, 17:41 UTC
Location: Norway // Belgium

Post by *NordicAlbino » 2013-11-22, 11:16 UTC

Of course, a copy of the specified icon still remains in c:\Windows\ for '---_auto_file' ...

New test: I removed the icon in 'c:\Windows\' and it still keeps working!

A new controle in RegEdit of '---_auto_file' gives now:

Code: Select all

[HKEY_CLASSES_ROOT\---_auto_file\DefaultIcon]
@="C:\\Program Files\\Total Commander\\Bar.ico,0"
Gudene Må Være Gale... | #67047 - 2 User licences

Post Reply