[solved]TC 9.50b4 Dark mode:wrong background color in thumbnail

Please report only one bug per message!

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
kesdoputr
Junior Member
Junior Member
Posts: 82
Joined: 2007-12-27, 12:38 UTC

[solved]TC 9.50b4 Dark mode:wrong background color in thumbnail

Post by *kesdoputr » 2019-11-11, 01:49 UTC

System:windows 7 SP1 x64 CHT
Version:TC9.50b4 32bit

When i use in thumbnail with pictures, background color is ok except the bigger font that i say in this post
viewtopic.php?f=32&t=54603

But when i use thumbnail to view ico file, the background color still the same with normal mode

In normal mode with ico's thumbnail view, backgound color is the BackColor
https://i.imgur.com/CyWRswP.png

In dark mode with ico's thumbnail view, backgound color is still othe BackColor of the normail mode
https://i.imgur.com/fokRQWN.png

I found in help and found it seems no setting of the thumbnail BackColor, Thanks for your watching.
Last edited by kesdoputr on 2019-11-11, 11:35 UTC, edited 1 time in total.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38017
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: TC 9.50b4 Dark mode:wrong background color in thumbnail

Post by *ghisler(Author) » 2019-11-11, 11:24 UTC

Unfortunately it depends on the thumbnail provider: If a provider returns a bitmap with alpha channel, then it will appear on a dark background. Most providers return a bitmap with white background, though.
Author of Total Commander
http://www.ghisler.com

User avatar
kesdoputr
Junior Member
Junior Member
Posts: 82
Joined: 2007-12-27, 12:38 UTC

Re: TC 9.50b4 Dark mode:wrong background color in thumbnail

Post by *kesdoputr » 2019-11-11, 11:34 UTC

OK i know, thanks for your reply.

Post Reply