Wiki - Automatic Install-settings doesn't work for me - please help me

English support forum

Moderators: sheep, Hacker, Stefan2, white

Post Reply
wasshup
Junior Member
Junior Member
Posts: 2
Joined: 2019-12-04, 09:46 UTC

Wiki - Automatic Install-settings doesn't work for me - please help me

Post by *wasshup » 2019-12-04, 09:57 UTC

Hello,
I am trying to create atomatic installer for tcmd922ax64 version.

I'm using 2. step from this instruction page: https://www.ghisler.ch/wiki/index.php/How_to_make_installation_fully_automatic%3F
I assume completed all steps correctly but still when I pack all the files back and run the .exe file, it just extract the files inside the exe (Image: https://imgur.com/a/MJ1fKKd).

Did I Missed Something? Can you help ?

Config file: https://pastebin.com/VJvPMRtr

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38395
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Wiki - Automatic Install-settings doesn't work for me - please help me

Post by *ghisler(Author) » 2019-12-04, 18:05 UTC

In this screenshot, the default sfxhead.sfx was used, to create regular self-extracting archives. You missed this step:
a) To create a pure 64-bit installer, unpack the 64-bit sfxhead.sfx to the Total Commander folder.
or
b) To create a 32-bit or combined 32+64-bit installer, unpack the 32-bit sfxhead.sfx to the Total Commander folder.
Author of Total Commander
http://www.ghisler.com

wasshup
Junior Member
Junior Member
Posts: 2
Joined: 2019-12-04, 09:46 UTC

Re: Wiki - Automatic Install-settings doesn't work for me - please help me

Post by *wasshup » 2019-12-05, 12:21 UTC

Hi,
thank you very much for explaining. Now I know that I misunderstood the requirements. I thought you must put sfxhead.sfx to others extracted files that I need to pack into the installer.

Everything is working now.

Thank you. Problem solved.

Post Reply