LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

deesar
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-04, 17:17 UTC

LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *deesar »

Hi to all,
I have a strange problem accessing shares on win 10.
With my old smartphone Samsung S8 (Android 9) it works perfect (since years).
With my new Samsung S10 (Android 10) it don't work.
After one minute I'll get a timeout exception.

Regardless if I use ip or dns name.

Both phones same current version of TC and LAN Plug in installed.

Any idess?

Thank You
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39929
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *ghisler(Author) »

Unfortunately none of my phones (including the S10e) has received Android 10 yet, so I cannot test this. It works fine in the emulator, though.

Maybe you have disabled background data?
Author of Total Commander
http://www.ghisler.com
deesar
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-04, 17:17 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *deesar »

Thank you for the reply,
unfortunately background data was enabled and that was not the cause. I tried some other smb apps and I can't get any of them to work on the s10 with pie, so it must have something to do with Samsung or android pie.

Thx anyway for the good app 👍

Greets Bernd
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39929
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *ghisler(Author) »

My Galaxy S10e has just received Android 10! However, the lan plugin works just fine, no timeout even after 10 minutes.
It's strange that it works with my S10e but not your S10. Maybe I just tried the wrong steps?
Author of Total Commander
http://www.ghisler.com
modelno1
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-14, 10:02 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *modelno1 »

The plugin doesn't work for me on Android 10 either. I can log in, browse, copy to lan share (I gen an error in the copy window, socket something something, but the file gets copied correctly) but I can't copy from lan share to phone. I get "problem reading file" splash and a 0 kb file locally. If I try to browse lan share after that, the first time I try to open folder I get "j has already been closed" error, but if I tap on the folder again it opens normally.
Running fully updated TC and plugin on Honor View 20 (Android 10 with October security updates).
deesar
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-04, 17:17 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *deesar »

I've found the solution, in wifi settings of the connected network there is an option "Mac Address Type" this was set to "phone mac" by default. Switching this option to "random generated mac" restored the smb functionality in Total Commander.

Thank you all for your support.
modelno1
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-14, 10:02 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *modelno1 »

I don't have any MAC address settings for WiFi, so I can't verify.
modelno1
Junior Member
Junior Member
Posts: 3
Joined: 2019-12-14, 10:02 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *modelno1 »

Joined beta programs for TC and plugin, updated, seems to work now.
rmmaniac
Junior Member
Junior Member
Posts: 20
Joined: 2009-04-14, 05:56 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *rmmaniac »

try enable win10 SMB1.0/CIFS,SMB direct and uncheck LAN plugins smb2
it work fine for me

Image: https://i.imgur.com/NCVVD6E.jpg
TW
Senior Member
Senior Member
Posts: 348
Joined: 2005-01-19, 13:35 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *TW »

i got a new phone with EMUI 10, LAN plugin does not work well.

most of the time i get

"Fehler beim Lesen der Datei"

when i try to copy a file. but sometimes it works (very rarely).

sometimes i get

"x has alredy been closed"

when i try to connect.



it's almost useless on this phone.
licenced and happy TC user since 1994 (#11xx)
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39929
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *ghisler(Author) »

Huawei devices are known to do very agressive closing of apps in the background. Plugins are treated as background apps.

To fix it, open the Android settings and go to "power save" or similar options. In the list of apps, look for Totalcmd-LAN app and disable all power saving options.

On my Huawei tablet, it's under Battery - App-Start - Totalcmd-FTP. You need to uncheck the entry, and then makr sure the option "Run in background" is enabled.
Author of Total Commander
http://www.ghisler.com
TW
Senior Member
Senior Member
Posts: 348
Joined: 2005-01-19, 13:35 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *TW »

thanks for the hint. i guess you mean "TotalCmd-WLAN-Transfer"?

i did that, enabled "im hintergrund ausführen", but even after a reboot it did not help.

i have to be extremely quick if i want to use this plugin.
licenced and happy TC user since 1994 (#11xx)
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39929
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *ghisler(Author) »

Could you try the latest beta? It shows an icon in the notification area during a connection, this prevents the unloading on many devices because it's then treated as a foreground service. But it may not work with Huawei, their app killing strategy is insane. You can request it here:
https://play.google.com/apps/testing/com.ghisler.tcplugins.LAN
The beta will then be installed via regular Play Store updates.
Author of Total Commander
http://www.ghisler.com
TW
Senior Member
Senior Member
Posts: 348
Joined: 2005-01-19, 13:35 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *TW »

thanks, i gave it a try.

and i'm pretty sure it did work some hours ago, but right now it does not. really weird, no idea what is different. :?

i need to do thorough testing.
licenced and happy TC user since 1994 (#11xx)
TW
Senior Member
Senior Member
Posts: 348
Joined: 2005-01-19, 13:35 UTC

Re: LAN plug in smb works on S8 Android 9 and not on S10 Android 10

Post by *TW »

ok, i did some more testing

it works well so far, as long as the notification is there. it disappears if i switch to another app and back. sometimes.
after all it is a big improvement on my device (Huawei P Smart+ 2019)

i wonder who will be their target customers? standard users might avoid them once they lose access to play store, advanced users will avoid them because there is no way to root the devices!? then they come up with silly behaviors like closing background apps within 10 seconds...
the P Smart+ 2019 itself really surprises me, a real bargain (well, i got it as a gift anyway).

thanks, the LAN plugin is usable again for me.
licenced and happy TC user since 1994 (#11xx)
Post Reply