ShellDetails 1.26 (Content plug-in)

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
Lefteous
Power Member
Power Member
Posts: 9460
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Post by *Lefteous »

I have never seen anything like that before. Could you please check if all column names are displayed correctly in Explorer?

User avatar
Clo
Moderator
Moderator
Posts: 5731
Joined: 2003-12-02, 19:01 UTC
Location: Bordeaux, France
Contact:

Mine is OK

Post by *Clo »

:arrow: Lefteous

:) Hello Christian !

• Below is my own INI (under XP-Pro), it looks quite OK. I just installed one column in order to test.
Paul Vansumsen-friend tried also in XP-Pro and in Vista, there is no problem…
- The captions are even in French, I don't know where they come from ? :roll: Windows ?
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}10]
Caption=Nom
UseDefault=1
State=17
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}12]
Caption=Taille
UseDefault=1
State=18
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}4]
Caption=Type
UseDefault=1
State=17
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}14]
Caption=Date de modification
UseDefault=1
State=19
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}15]
Caption=Date de création
UseDefault=1
State=3
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}16]
Caption=Date d'accès
UseDefault=1
State=131
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}13]
Caption=Attributs
UseDefault=1
State=1
[{D8C3986F-813B-449C-845D-87B95D674ADE}2]
Caption=État
UseDefault=1
State=129
[{9B174B34-40FF-11D2-A27E-00C04FC30871}4]
Caption=Propriétaire
UseDefault=1
State=97
[{F29F85E0-4FF9-1068-AB91-08002B27B3D9}4]
Caption=Auteur
UseDefault=1
State=97
[{F29F85E0-4FF9-1068-AB91-08002B27B3D9}2]
Caption=Titre
UseDefault=1
State=97
[{F29F85E0-4FF9-1068-AB91-08002B27B3D9}3]
Caption=Objet
UseDefault=1
State=225
[{D5CDD502-2E9C-101B-9397-08002B2CF9AE}2]
Caption=Catégorie
UseDefault=1
State=225
[{F29F85E0-4FF9-1068-AB91-08002B27B3D9}14]
Caption=Pages
UseDefault=1
State=226
[{F29F85E0-4FF9-1068-AB91-08002B27B3D9}6]
Caption=Commentaires
UseDefault=1
State=97
[{64440492-4C8B-11D1-8B70-080036B11A03}11]
Caption=Copyright
UseDefault=1
State=225
[{56A3372E-CE9C-11D2-9F0E-006097C686F6}2]
Caption=Artiste
UseDefault=1
State=97
[{56A3372E-CE9C-11D2-9F0E-006097C686F6}4]
Caption=Titre de l'album
UseDefault=1
State=97
[{56A3372E-CE9C-11D2-9F0E-006097C686F6}5]
Caption=Année
UseDefault=1
State=97
[{56A3372E-CE9C-11D2-9F0E-006097C686F6}7]
Caption=Numéro de piste
UseDefault=1
State=98
[{56A3372E-CE9C-11D2-9F0E-006097C686F6}11]
Caption=Genre
UseDefault=1
State=97
[{64440490-4C8B-11D1-8B70-080036B11A03}3]
Caption=Durée
UseDefault=1
State=97
[{64440490-4C8B-11D1-8B70-080036B11A03}4]
Caption=Débit
UseDefault=1
State=97
[{AEAC19E4-89AE-4508-B9B7-BB867ABEE2ED}2]
Caption=Protégée
UseDefault=1
State=97
[{14B81DA1-0135-4D31-96D9-6CBFC9671A99}272]
Caption=Modèle d'appareil photo
UseDefault=1
State=97
[{14B81DA1-0135-4D31-96D9-6CBFC9671A99}36867]
Caption=Date du cliché
UseDefault=1
State=97
[{6444048F-4C8B-11D1-8B70-080036B11A03}13]
Caption=Dimensions
UseDefault=1
State=97
[{6444048F-4C8B-11D1-8B70-080036B11A03}3]
Caption=Sans titre 0
UseDefault=1
State=353
[{6444048F-4C8B-11D1-8B70-080036B11A03}4]
Caption=Sans titre 1
UseDefault=1
State=353
[{F29F85E0-4FF9-1068-AB91-08002B27B3D9}12]
Caption=Sans titre 2
UseDefault=1
State=355
[{D5CDD502-2E9C-101B-9397-08002B2CF9AE}15]
Caption=Entreprise
UseDefault=1
State=97
[{0CEF7D53-FA64-11D1-A203-0000F81FEDEE}3]
Caption=Description
UseDefault=1
State=97
[{0CEF7D53-FA64-11D1-A203-0000F81FEDEE}4]
Caption=Version du fichier
UseDefault=1
State=97
[{0CEF7D53-FA64-11D1-A203-0000F81FEDEE}7]
Caption=Nom du produit
UseDefault=1
State=97
[{0CEF7D53-FA64-11D1-A203-0000F81FEDEE}8]
Caption=Version du produit
UseDefault=1
State=97
• Just hoping it helps…

:mrgreen: VG
Claude
Clo
#31505 Traducteur Français de TC French translator Aide en Français Tutoriels Français English Tutorials

User avatar
Lefteous
Power Member
Power Member
Posts: 9460
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Post by *Lefteous »

The captions are even in French, I don't know where they come from ? Windows ?
Yes they are provided by Windows.

Your settings file looks as it should be and I currently have no idea what the problem could be.

User avatar
Naruki
Junior Member
Junior Member
Posts: 14
Joined: 2009-02-21, 02:28 UTC
Location: Tokyo, Japan

Post by *Naruki »

[OT]
2fenix_productions
2Peter

Thanks for the links, guys.
[/OT]

Freddy
Junior Member
Junior Member
Posts: 80
Joined: 2009-03-21, 21:32 UTC

Post by *Freddy »

:arrow: Lefteous

I Hope you mean that :
http://www.neufgiga.com/n/50-17/share/LNK469549e74563349f3/
Apparantly, it runs well in Explorer (if I've good understood what you want...)

Vansumsen (in french forum) had given to me the full text of his ShellDetails.ini file, which is running well on his Vista computer, and it works fine, now !
I have so a workaround.

Thanks for the help and I hope you will find the bug.
Freddy

User avatar
Lefteous
Power Member
Power Member
Posts: 9460
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Post by *Lefteous »

and if you delete Pauls file and let ShellDetails recreate it? Can you reproduce the problem in this case?

Freddy
Junior Member
Junior Member
Posts: 80
Joined: 2009-03-21, 21:32 UTC

Post by *Freddy »

Yes, I find the bad labels if I do that.

User avatar
Lefteous
Power Member
Power Member
Posts: 9460
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Post by *Lefteous »

Ok at least it's reproducible

Please give me the following system details:
- Operating system version including service pack
- Operation system language
- Operation system architecture (32 or 64 bit)
- installed shell extensions ( http://www.nirsoft.net/utils/shexview.html, complete dump )

Freddy
Junior Member
Junior Member
Posts: 80
Joined: 2009-03-21, 21:32 UTC

Post by *Freddy »

:arrow: Lefteous

- Operating system version including service pack
Vista SP1 (32 bit)

- Operation system language
French

- Operation system architecture (32 or 64 bit)
See upper

- installed shell extensions ( http://www.nirsoft.net/utils/shexview.html , complete dump )
.txt file made, send by mail for a few moment... :roll:

Pandur
Junior Member
Junior Member
Posts: 5
Joined: 2008-10-30, 14:38 UTC

Captions of ShellDetails-colums

Post by *Pandur »

I have a problem with the captions of the shelldetails-colums: they only consist of special characters. Most of them display nothing.
The ShellDetails.ini looks like this (a delete of the shelldetails.ini and a restart doesn't change anything):

[{B725F130-47EF-101A-A5F1-02608C9EEBAC}10]
Caption=pÈ
UseDefault=1
State=17
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}12]
Caption=¨Y
UseDefault=1
State=18
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}4]
Caption=ÐY
UseDefault=1
State=17
...

Any ideas?
(OS is XP)

User avatar
Lefteous
Power Member
Power Member
Posts: 9460
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Post by *Lefteous »

More and more users report this problem - I could not reproduce it so far.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39394
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

2Lefteous
It looks like you are trying to pass Unicode to TC 7, or ANSI in Unicode functions or so. Could you check that, please?
Author of Total Commander
http://www.ghisler.com

DenisArd
Junior Member
Junior Member
Posts: 4
Joined: 2009-01-08, 10:24 UTC

Re: Captions of ShellDetails-colums

Post by *DenisArd »

Pandur wrote:I have a problem with the captions of the shelldetails-colums: they only consist of special characters. Most of them display nothing.
The ShellDetails.ini looks like this (a delete of the shelldetails.ini and a restart doesn't change anything):

[{B725F130-47EF-101A-A5F1-02608C9EEBAC}10]
Caption=pÈ
UseDefault=1
State=17
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}12]
Caption=¨Y
UseDefault=1
State=18
[{B725F130-47EF-101A-A5F1-02608C9EEBAC}4]
Caption=ÐY
UseDefault=1
State=17
...

Any ideas?
(OS is XP)
similarly.
TC 7.0

Pandur
Junior Member
Junior Member
Posts: 5
Joined: 2008-10-30, 14:38 UTC

Post by *Pandur »

ghisler(Author) wrote:2Lefteous
It looks like you are trying to pass Unicode to TC 7, or ANSI in Unicode functions or so. Could you check that, please?
I upgraded to TC7.5 and it works fine now. Looks like a problem with Unicode (was changed in TC7.5).

yeskky
Member
Member
Posts: 169
Joined: 2007-03-01, 05:32 UTC
Location: Jiang Su,China

Note to plugin writer of plugin shelldetails.

Post by *yeskky »

TC 7.50a
ShellDetails 1.20

Using TC with Chinese language in Japanese Windows XP.

Option-Custom Columns-New-Add column-press "+" button.
The error in the picture below happens.

http://img242.ph.126.net/0shEktWQj28WKmj9agewVQ==/1431863206528608949.jpg
#222405 Single user licence

Post Reply