FTP unicode problem?

This forum contains bug reports from previous beta tests - the issue has remained unresolved, either because it couldn't be reproduced, or couldn't be prevented/fixed

Moderators: Hacker, Stefan2, white, sheep

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36354
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-09-15, 09:48 UTC

Thanks for the info. Can you please do the following to compare download in background and foreground:
1. Enable logging in Configuration - Options - FTP
2. Open wcx_ftp.ini (via Configuration - Change settings files directly)
3. Add the following under [General] :
SpecialFlags=16
to enable detailed logging in background
4. Now try to download the same file both in foreground and then in background, and then send me the log (zipped) to beta at ghisler dot com .
Thanks!
Author of Total Commander
http://www.ghisler.com

User avatar
gewone
Junior Member
Junior Member
Posts: 47
Joined: 2008-03-06, 17:37 UTC

Post by *gewone » 2009-09-15, 16:54 UTC

Sure.
Here goes.

Code: Select all

----------
Connect to: (2009-09-15 6:45:37 PM)
hostname=targetip
username=myaxxacc
startdir=
220-FileZilla Server version 0.9.29 beta
220 BLOMMA, GEOGRAPHIX!
AUTH TLS
234 Using authentication type TLS
Cert subject: /CN=targethost/C=46/ST=Sweden/L=Stockholm
Cert issuer: /CN=targethost/C=46/ST=Sweden/L=Stockholm
USER myaxxacc
331 Password required for myaxxacc
PASS ***********
230 Logged on
SYST
215 UNIX emulated by FileZilla
FEAT
211-Features:
 MDTM
 REST STREAM
 SIZE
 MLST type*;size*;modify*;
 MLSD
 AUTH SSL
 AUTH TLS
 UTF8
 CLNT
 MFMT
211 End
PBSZ 0
200 PBSZ=0
PROT P
200 Protection level set to P
Connect ok!
OPTS UTF8 OFF
200 UTF8 mode disabled
PWD
257 "/" is current directory.
Get directory
TYPE A
200 Type set to A
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,52)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Documents and Settings
250 CWD successful. "/Documents and Settings" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,54)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Ingrid
250 CWD successful. "/Documents and Settings/Ingrid" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,55)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Lokala inställningar
250 CWD successful. "/Documents and Settings/Ingrid/Lokala inställningar" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,56)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Tidigare
250 CWD successful. "/Documents and Settings/Ingrid/Lokala inställningar/Tidigare" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,57)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CDUP
200 CDUP successful. "/Documents and Settings/Ingrid/Lokala inställningar" is current directory.
PWD
257 "/Documents and Settings/Ingrid/Lokala inställningar" is current directory.
CWD Temp
250 CWD successful. "/Documents and Settings/Ingrid/Lokala inställningar/Temp" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,58)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
BG:----------
BG:Connect to: (2009-09-15 6:46:17 PM)
BG:hostname=targetip
BG:username=myaxxacc
BG:startdir=/Documents and Settings/Ingrid/Lokala inställningar/Temp
BG:220-FileZilla Server version 0.9.29 beta
BG:220 BLOMMA, GEOGRAPHIX!
BG:AUTH TLS
BG:234 Using authentication type TLS
BG:Cert subject: /CN=targethost/C=46/ST=Sweden/L=Stockholm
BG:Cert issuer: /CN=targethost/C=46/ST=Sweden/L=Stockholm
BG:USER myaxxacc
BG:331 Password required for myaxxacc
BG:PASS ***********
BG:230 Logged on
BG:SYST
BG:215 UNIX emulated by FileZilla
BG:FEAT
BG:211-Features:
BG: MDTM
BG: REST STREAM
BG: SIZE
BG: MLST type*;size*;modify*;
BG: MLSD
BG: AUTH SSL
BG: AUTH TLS
BG: UTF8
BG: CLNT
BG: MFMT
BG:211 End
BG:PBSZ 0
BG:200 PBSZ=0
BG:PROT P
BG:200 Protection level set to P
BG:CLNT Total Commander (UTF-8)
BG:200 Don't care
BG:OPTS UTF8 ON
BG:200 UTF8 mode enabled
BG:CWD /Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp
BG:550 CWD failed. "/Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp": directory not found.
BG:Connect ok!
BG:TYPE I
BG:200 Type set to I
BG:PASV
BG:227 Entering Passive Mode (target-ip-coma-seperated,50,59)
BG:RETR vorbis.acm
BG:PWD
BG:257 "/" is current directory.
BG:QUIT
BG:221 Goodbye
TYPE I
200 Type set to I
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,60)
RETR vorbis.acm
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
Copied (2009-09-15 6:46:24 PM): ftps://targetip/Documents and Settings/Ingrid/Lokala inställningar/Temp/vorbis.acm -> T:\vorbis.acm 1 294 336 bytes, 927 kbytes/s
First attempt was with background x-fer box ticked, the second attempt (that yielded success) was with the checkbox un-ticked (foreground x-fer). My novice assumption is that this issue has something to do with this! :^

BG:CWD /Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp
BG:550 CWD failed. "/Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp": directory not found.


However, I hope this will be of any help to you.
Regards and ty for the all-round best file manager slash control tower ever.

Sob
Power Member
Power Member
Posts: 908
Joined: 2005-01-19, 17:33 UTC

Post by *Sob » 2009-09-15, 22:52 UTC

First connection sends OPTS UTF8 OFF (from settings), but background one uses default OPTS UTF8 ON. I tried it with other commands and it seems that backround connections don't use "Send Commands" at all.

Btw, with TC 7.50 you can remove "OPTS UTF8 OFF" and use the default UTF-8 mode. It should solve your problem.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36354
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-09-16, 13:31 UTC

User Sob is right! Please remove "OPTS UTF8 OFF" from "Send commands".
Author of Total Commander
http://www.ghisler.com

Sob
Power Member
Power Member
Posts: 908
Joined: 2005-01-19, 17:33 UTC

Post by *Sob » 2009-09-16, 14:06 UTC

But still, isn't it kind of bug? First user who will actually need to enter something vital for his server operation in "Send commands" will have the same problem with background transfers.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36354
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2009-09-16, 19:11 UTC

It's a missing feature - TC cannot know what you want to achieve with "Send commands", and whether it needs to be sent just for interactive connections, or also for background connections...
Author of Total Commander
http://www.ghisler.com

User avatar
gewone
Junior Member
Junior Member
Posts: 47
Joined: 2008-03-06, 17:37 UTC

Post by *gewone » 2009-09-17, 14:38 UTC

You were right ghisler, I had somehow forgotten to remove the old OPTS UTF8 OFF send. As of 7.50, the "bug" is no longer there, unless of ofc you (like I did) manually enter the OPTS UTF8 OFF, then this thingie will revisit. Somehow strange how it only affects during bg x-fers tho. Well, like you said, a matter of un/½-implemented feature. No biggie.

Post Reply