This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

FTP unicode problem?
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Total Commander Forum Index -> Bug reports from previous betas (unresolved) Printable version
View previous topic :: View next topic  
Author Message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35956
Location: Switzerland

PostPosted: Tue Sep 15, 2009 3:48 am    Post subject: Reply with quote

Thanks for the info. Can you please do the following to compare download in background and foreground:
1. Enable logging in Configuration - Options - FTP
2. Open wcx_ftp.ini (via Configuration - Change settings files directly)
3. Add the following under [General] :
SpecialFlags=16
to enable detailed logging in background
4. Now try to download the same file both in foreground and then in background, and then send me the log (zipped) to beta at ghisler dot com .
Thanks!
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
gewone
Junior Member
Junior Member


Joined: 06 Mar 2008
Posts: 47

PostPosted: Tue Sep 15, 2009 10:54 am    Post subject: Reply with quote

Sure.
Here goes.

Code:
----------
Connect to: (2009-09-15 6:45:37 PM)
hostname=targetip
username=myaxxacc
startdir=
220-FileZilla Server version 0.9.29 beta
220 BLOMMA, GEOGRAPHIX!
AUTH TLS
234 Using authentication type TLS
Cert subject: /CN=targethost/C=46/ST=Sweden/L=Stockholm
Cert issuer: /CN=targethost/C=46/ST=Sweden/L=Stockholm
USER myaxxacc
331 Password required for myaxxacc
PASS ***********
230 Logged on
SYST
215 UNIX emulated by FileZilla
FEAT
211-Features:
 MDTM
 REST STREAM
 SIZE
 MLST type*;size*;modify*;
 MLSD
 AUTH SSL
 AUTH TLS
 UTF8
 CLNT
 MFMT
211 End
PBSZ 0
200 PBSZ=0
PROT P
200 Protection level set to P
Connect ok!
OPTS UTF8 OFF
200 UTF8 mode disabled
PWD
257 "/" is current directory.
Get directory
TYPE A
200 Type set to A
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,52)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Documents and Settings
250 CWD successful. "/Documents and Settings" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,54)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Ingrid
250 CWD successful. "/Documents and Settings/Ingrid" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,55)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Lokala inställningar
250 CWD successful. "/Documents and Settings/Ingrid/Lokala inställningar" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,56)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CWD Tidigare
250 CWD successful. "/Documents and Settings/Ingrid/Lokala inställningar/Tidigare" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,57)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
CDUP
200 CDUP successful. "/Documents and Settings/Ingrid/Lokala inställningar" is current directory.
PWD
257 "/Documents and Settings/Ingrid/Lokala inställningar" is current directory.
CWD Temp
250 CWD successful. "/Documents and Settings/Ingrid/Lokala inställningar/Temp" is current directory.
Get directory
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,58)
LIST -la
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
BG:----------
BG:Connect to: (2009-09-15 6:46:17 PM)
BG:hostname=targetip
BG:username=myaxxacc
BG:startdir=/Documents and Settings/Ingrid/Lokala inställningar/Temp
BG:220-FileZilla Server version 0.9.29 beta
BG:220 BLOMMA, GEOGRAPHIX!
BG:AUTH TLS
BG:234 Using authentication type TLS
BG:Cert subject: /CN=targethost/C=46/ST=Sweden/L=Stockholm
BG:Cert issuer: /CN=targethost/C=46/ST=Sweden/L=Stockholm
BG:USER myaxxacc
BG:331 Password required for myaxxacc
BG:PASS ***********
BG:230 Logged on
BG:SYST
BG:215 UNIX emulated by FileZilla
BG:FEAT
BG:211-Features:
BG: MDTM
BG: REST STREAM
BG: SIZE
BG: MLST type*;size*;modify*;
BG: MLSD
BG: AUTH SSL
BG: AUTH TLS
BG: UTF8
BG: CLNT
BG: MFMT
BG:211 End
BG:PBSZ 0
BG:200 PBSZ=0
BG:PROT P
BG:200 Protection level set to P
BG:CLNT Total Commander (UTF-8)
BG:200 Don't care
BG:OPTS UTF8 ON
BG:200 UTF8 mode enabled
BG:CWD /Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp
BG:550 CWD failed. "/Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp": directory not found.
BG:Connect ok!
BG:TYPE I
BG:200 Type set to I
BG:PASV
BG:227 Entering Passive Mode (target-ip-coma-seperated,50,59)
BG:RETR vorbis.acm
BG:PWD
BG:257 "/" is current directory.
BG:QUIT
BG:221 Goodbye
TYPE I
200 Type set to I
PASV
227 Entering Passive Mode (target-ip-coma-seperated,50,60)
RETR vorbis.acm
150 Connection accepted
Download
Waiting for server...
226 Transfer OK
Copied (2009-09-15 6:46:24 PM): ftps://targetip/Documents and Settings/Ingrid/Lokala inställningar/Temp/vorbis.acm -> T:\vorbis.acm 1 294 336 bytes, 927 kbytes/s


First attempt was with background x-fer box ticked, the second attempt (that yielded success) was with the checkbox un-ticked (foreground x-fer). My novice assumption is that this issue has something to do with this! :^

BG:CWD /Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp
BG:550 CWD failed. "/Documents and Settings/Ingrid/Lokala inst㫬ningar/Temp": directory not found.


However, I hope this will be of any help to you.
Regards and ty for the all-round best file manager slash control tower ever.
Back to top
View user's profile Send private message
Sob
Power Member
Power Member


Joined: 19 Jan 2005
Posts: 908

PostPosted: Tue Sep 15, 2009 4:52 pm    Post subject: Reply with quote

First connection sends OPTS UTF8 OFF (from settings), but background one uses default OPTS UTF8 ON. I tried it with other commands and it seems that backround connections don't use "Send Commands" at all.

Btw, with TC 7.50 you can remove "OPTS UTF8 OFF" and use the default UTF-8 mode. It should solve your problem.
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35956
Location: Switzerland

PostPosted: Wed Sep 16, 2009 7:31 am    Post subject: Reply with quote

User Sob is right! Please remove "OPTS UTF8 OFF" from "Send commands".
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Sob
Power Member
Power Member


Joined: 19 Jan 2005
Posts: 908

PostPosted: Wed Sep 16, 2009 8:06 am    Post subject: Reply with quote

But still, isn't it kind of bug? First user who will actually need to enter something vital for his server operation in "Send commands" will have the same problem with background transfers.
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35956
Location: Switzerland

PostPosted: Wed Sep 16, 2009 1:11 pm    Post subject: Reply with quote

It's a missing feature - TC cannot know what you want to achieve with "Send commands", and whether it needs to be sent just for interactive connections, or also for background connections...
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
gewone
Junior Member
Junior Member


Joined: 06 Mar 2008
Posts: 47

PostPosted: Thu Sep 17, 2009 8:38 am    Post subject: Reply with quote

You were right ghisler, I had somehow forgotten to remove the old OPTS UTF8 OFF send. As of 7.50, the "bug" is no longer there, unless of ofc you (like I did) manually enter the OPTS UTF8 OFF, then this thingie will revisit. Somehow strange how it only affects during bg x-fers tho. Well, like you said, a matter of un/½-implemented feature. No biggie.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> Bug reports from previous betas (unresolved) All times are GMT - 6 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group